NiCE CXone Studio

Studio es una herramienta de scripting que puede utilizar para personalizar el flujo de enrutamiento de su centro de contacto a fin de satisfacer las necesidades de su organización. El scripting le permite definir cómo se enrutan los contactos hacia los agentes que mejor pueden ayudarlos. Por ejemplo, puede usar menús de ASRClosed Reconocimiento automático de Voz. Permite a los contactos responder a los avisos hablando, presionando teclas del teléfono o ambas opciones. o IVRClosed Respuesta de voz interactiva. menú telefónico automatizado que los contactos utilizan mediante voz o entradas de teclado para obtener información, enrutar una llamada de voz entrante, o ambas cosas., o agentes virtualesClosed Una aplicación de software que maneja las interacciones del cliente en lugar de un agente humano en vivo..

Studio tiene una interfaz visual de arrastrar y soltar, por lo que no necesita una experiencia de scripting extensa para crear scripts básicos. Puede crear scripts más complejos incluyendo código de scripting personalizado.

La Studio ayuda en línea proporciona información sobre:

Integraciones con Sistemas de Terceros

Studio le permite integrarseNiCE CXone con aplicaciones y sistemas de terceros, entre ellos:

Además, Integration Hub le permite administrar integraciones basadas en API con sistemas de terceros. También le permite administrar información que requiere seguridad adicional, como secretos o contraseñas.

Compatibilidad de Script entre Studio y Desktop Studio

Studio and Desktop Studio scripts are compatible. Any script that's saved to the NiCE CXone servers can be opened in either application.

Scripts cannot be exported from one application and imported into the other. This is because Desktop Studio scripts are XML and Studio scripts are JSON. The import feature cannot convert between formats.

Most Studio actions are available in both versions of the application. If an action isn't available in the version of Studio you're using, you can still see it in the script. However, you may not be able to modify the properties of those actions. You can open the script in the version of Studio you originally used if you need to modify those actions.

Paridad de funciones con Desktop Studio

La versión basada en navegador de Studio tiene paridad de funciones con Desktop Studio. Si es nuevo en Studio, la página de ayuda comenzar con Studio ofrece una introducción. También describe las opciones disponibles en la interfaz de usuario.

La siguiente tabla muestra dónde se ubican en Studio las funciones de Desktop Studio con las que está familiarizado.

Desktop Studio Característica Studio Característica
Acciones: Agregue funcionalidad a su script.

Todas las acciones están disponibles en Studio.

Las acciones se encuentran en dos paletas ubicadas en la barra de herramientas del lado izquierdo del lienzo del script:

Editor de acción Windows: Permite acceder a opciones de configuración adicionales.

Para las acciones que tienen ventanas de editor, existen dos formas de abrirlas:

  • Seleccione la acción y haga clic en Editor en el centro del icono de la acción.
  • Seleccione la acción y haga clic en Abrir editor en el panel de propiedades de la acción.

En las próximas versiones seguirá mejorando el diseño y la función de las ventanas del editor.

Browse Tab: Muestra una lista completa de los scripts de la unidad de negocio.

En Studio, la página que se carga cuando accede a la aplicación se llama la página de Scripts. Esta página muestra los scripts disponibles en su NiCE CXone sistema. Puede filtrar la lista para mostrar solo los scripts activos, solo los scripts inactivos o todos los scripts.

La página de Scripts ofrece información sobre cada script. Le permite realizar ciertas tareas con scripts sin dejar la página. Puede:

Compare Scripts (Edit > Compare): Le permite comparar dos scripts por títulos, parámetros, ramas o posición. Los Resultados se muestran en la pestaña Find Results. Puede comparar dos scripts en Studio abriéndolos y luego seleccionando Compare en el menú de la parte superior del lienzo del script. También puede comparar versiones históricas del mismo script. Los Resultados se muestran en la parte inferior de la página.
Conectores: Conectan acciones entre sí en el lienzo del script.

Puede conectar acciones con líneas en ángulo recto, líneas curvas y líneas lineales. Puede conectar acciones directamente a otras acciones o a anclas de conexión en la acción. Puede agregar puntos de vértice a las líneas en ángulo recto o curvas haciendo doble clic en el conector. Los puntos de vértice introducen curvas o ángulos adicionales en el conector.

Copiar y pegar acciones en el lienzo: Permite seleccionar y copiar acciones, y pegarlas de nuevo en el lienzo del script.

En Studio, puede copiar y pegar una o más acciones en el mismo script o entre scripts. También puede deshacer y rehacer acciones anteriores. Se admiten los atajos de teclado Estándar para estas tareas.

Crear y editar scripts: Permite crear scripts nuevos y modificar los existentes.

 

Puede crear y editar scripts. Cada script existe en una pestaña separada de su navegador.
Desactivar: Permite desactivar un script para que no se pueda usar.

Puede desactivar scripts desde el menú Opciones junto a cada script en la página Scripts en Studio. También puede abrir el script y seleccionar Desactivar desde el menú central en la parte superior del script.

Puede reactivar scripts en la página Scripts de la aplicación ACD. La reactivación de scripts no se admite en Desktop Studio, pero se agregará a Studio en una versión futura.

Errores y Advertencias (pestaña Script Errors): Muestra una lista de los errores o advertencias en el script actual. Los errores y advertencias del script aparecen en el panel de propiedades en el lado derecho del lienzo del script.
Pestaña Files: Brinda acceso a los archivos de la unidad de negocioClosed Agrupación organizativa de alto nivel utilizada para administrar el soporte técnico, la facturación y la configuración global de su sistema NiCE CXone.. Permite cargar archivos y grabar mensajes de avisos de audio.

Puede ver y cargar archivos en la página Browse ACD files de la plataforma NiCE CXone. En Studio, puede ver y cargar los siguientes tipos de archivos:

Actualmente, la página Prompts aún no admite la grabación de mensajes de Avisos de audio, como sí lo hace la pestaña Files en Desktop Studio. En Studio, puede grabar mensajes de avisos de audio con acciones como PLAY.

Pestaña Framework: Muestra una lista completa de las acciones disponibles en Studio.

El lado izquierdo del lienzo del script tiene opciones para ver la paleta Actions y la paleta API Actions. Estas paletas brindan acceso a todas las acciones de Studio con licencia para su sistema de NiCE CXone. La disponibilidad de algunas acciones depende del tipo de soporte de medios del script.

Importar y exportar scripts (Archivo > Importar y Archivo > Exportar): Le permite guardar copias de un script como archivo en su computadora, y agregar una copia guardada de un script a Studio.

Importar y exportar funcionan igual que en Desktop Studio. Sin embargo, en Studio, a importar se le llama cargar y a exportar se le llama descargar.

Además, los scripts de Studio están en JSON. Los scripts de Desktop Studio son XML. El proceso de importación no convierte entre los formatos. Esto significa que no puede importar a Studio un script que se exportó previamente desde Desktop Studio, y viceversa. Sin embargo, puede solucionar esto importando el script a la aplicación desde la que se exportó, después abrirlo en la aplicación deseada.

Múltiples instancias de Studio: Le permite tener más de una instancia de la aplicación en ejecución a la vez.

Cada navegador puede ejecutar dos instancias de Studio: una en modo regular y otra en modo incógnito. Puede ejecutar hasta cuatro instancias al mismo tiempo utilizando Chrome y Microsoft Edge.

Esta capacidad es útil si necesita conectarse a múltiples unidades de negocioClosed Agrupación organizativa de alto nivel utilizada para administrar el soporte técnico, la facturación y la configuración global de su sistema NiCE CXone. al mismo tiempo. Puede abrir más de un script en una sola instancia de Studio. Cada script se abre en una pestaña separada dentro de la misma ventana del navegador.

Navegar visualmente por el lienzo de scripts (pestaña Navegar): Muestra una vista en miniatura del lienzo de scripts por la que puede desplazarse para ver rápidamente diferentes partes del script. En Studio, puede navegar por el lienzo de scripts en la vista previa del lienzo. También puede usar las opciones ubicadas en la parte inferior del panel de propiedades. Hay opciones adicionales disponibles que le permiten ajustar el script a la pantalla, acercar y alejar, y tomar y mover el lienzo de scripts con el cursor.

Pestaña de propiedades (propiedades de la Acción y del script): Muestra las propiedades de la acción seleccionada o del script actual y le permite configurarlas.

Las propiedades de la acción seleccionada aparecen en el panel del lado derecho del lienzo de scripts. Puede ver:

  • El nombre de la acción y el id de acción.

  • Un campo para cambiar la etiqueta del subtítulo de la acción. También puede hacer clic con el botón derecho en el icono de la acción en el lienzo de scripts y seleccionar Agregar leyenda.

  • Un botón Abrir editor para acceder a la ventana del editor de la acción. Esta opción solo está disponible para acciones que tienen ventanas de editor.

  • Propiedades para configurar la acción. Puede presionar F1 para abrir la página de ayuda de la acción seleccionada.

La pestaña Propiedades de Desktop Studio muestra otra información cuando no hay acciones seleccionadas en el lienzo de scripts. Esta información está disponible en otras ubicaciones en Studio:

Revertir a la Versión anterior de los scripts: le permite guardar una versión guardada previamente del script y continuar trabajando en ella. La opción para ver versiones anteriores de un script, copiar versiones o revertir a versiones anteriores de un script está disponible en el menú central ubicado en la parte superior del lienzo del script. Cuando se muestra una versión anterior para su visualización, se carga en modo de solo lectura. Los Botones para copiar o revertir a esa versión están disponibles en la esquina superior derecha de la página.
Bloqueo y desbloqueo de scripts: permite poner el script en modo de solo lectura y en modo editable.

Actualmente, en Studio, puede bloquear un script para editarlo y desbloquearlo para ponerlo en modo de solo lectura. Puede anular el bloqueo de un script bloqueado por otro usuario.

En la página Scripts de Studio, se muestra el estado Bloqueado para cada script. Actualmente, no puede filtrar la lista de scripts por estado de bloqueo ni ordenar la tabla por la columna Bloqueado. Esto significa que no puede ver fácilmente una lista de todos los scripts bloqueados. Esto se incluirá en una versión futura.

Rastreo de scripts: le permite probar y depurar scripts.

Actualmente, en Studio, al rastrear un script, puede:

Search for Scripts (pestaña Scripts): Permite buscar scripts en la unidad de negocio utilizando el nombre del script, la versión y el tipo de soporte de medios del script.

Puede buscar scripts en la página Scripts en Studio. Puede buscar por nombre del script, por las variables que contienen o por el valor de la variable, el título de la acción y el tipo de soporte de medios del script.

Acción SNIPPET: Contiene una ventana de editor que permite codificación personalizada.

Actualmente, la ventana del editor de la acción SNIPPET admite código de snippet personalizado con resaltado de sintaxis. Puede depurar snippets desde dentro de la ventana del editor.

Se continúan haciendo mejoras a la funcionalidad del editor.

Cambios no guardados: Almacena los cambios del script que no se guardaron antes de que se cerrara la pestaña del script. Los cambios no guardados del script se guardan en el navegador. Si abre un script que tiene cambios no guardados, Studio le solicita que elija si desea abrir la versión con los cambios no guardados. Dado que los cambios se guardan en el navegador, al borrar la caché se eliminan los cambios no guardados. Además, los cambios almacenados son específicos del usuario y del navegador.
Pestaña Variables: Enumera las variables en el script y las acciones que hacen referencia a cada una. Hay una lista de variables en el script actual disponible en la pestaña Variables del panel de propiedades.
Modificación de variables: Permite especificar variables en un script cuyos valores deben omitirse en los rastreos y registros. Puede ocultar los valores de las variables en la pestaña Variables del panel de propiedades.

Historial de auditoría y guardados de scripts

Al guardar un script en Studio, el sistema realiza una rotación de versión:

  1. Se crea una nueva versión.

  2. La versión previamente activa se establece como inactivo.

  3. La nueva versión se activa.

Durante este proceso, el informe de Historial de auditoría puede atribuir la desactivación de la versión anterior al último usuario que modificó esa versión, en lugar de al usuario que realiza el guardado actual.