Trabajar con Scripts (Desktop Studio)

Esta página de ayuda corresponde a Desktop Studio. Esta información también está disponible para Studio.

Esta página proporciona información acerca de las tareas de Scripts esenciales, como crear o abrir Scripts, agregar y configurar Actions, y bloquear o desbloquear Scripts.

Crear un Nuevo script

Permisos requeridos: Crear/Editar Scripts de studio

Si el bloqueo está habilitado para Studio, su nuevo script no se bloqueará hasta que lo guarde.

  1. En Studio, haga clic en Nuevo Una pequeña ventana de un programa de computadora con un archivo delante y un brillo. en la barra de herramientas.

  2. Seleccione el tipo de script que desea crear de la lista en el lado derecho de la ventana. Si no ve los tipos de scripts en el lado derecho de la ventana, verifique que Scripts de Propósito general esté seleccionado en Plantillas disponibles.

  3. Haga clic en Aceptar. Se abre un lienzo de guión en blanco en Studio.
  4. Haga clic en Guardar y proporcione un nombre para su secuencia de comandos. Elija el nombre con cuidado. No puede cambiar el nombre de las secuencias de comandos una vez que se guardan.

Crear un guión a partir de una Plantilla

Permisos requeridos: Crear/Editar Scripts de studio

Si la función de bloqueo está habilitada para Studio, su nuevo script no se bloqueará hasta que lo guarde.

  1. En Studio, haga clic en Nuevo Una pequeña ventana de un programa de computadora con un archivo delante y un brillo. en la barra de herramientas.

  2. Seleccione una categoría de plantilla en Guiones especializados en Plantillas disponibles, luego haga clic en la Plantilla que desea usar de la lista de la derecha.

  3. Haga clic en Aceptar.
  4. Guarde el script. Elija el nombre con cuidado.No puede cambiar el nombre de las secuencias de comandos una vez que se guardan.

Abrir un script

Permisos requeridos: Crear/Editar Scripts de studio

Puede abrir un script de la siguiente manera:

  • Hacer clic en Archivo > Abrir, seleccionar un script y hacer clic en Seleccionar.
  • Haga clic en Abierto An open manila file folder with an arrow moving out of it. en la barra de herramientas, seleccione un script y haga clic en Seleccionar.
  • Buscando para un script en la pestaña Buscar, luego haga doble clic en el que desea abrir.
  • Utilice la pestaña Examinar para localizar un script y haga doble clic en el que desee abrir.

Nunca edite directamente un script de producción. Los cambios Guardados entran en vigor inmediatamente. Si un cambio causa un problema con un script, podría afectar la capacidad de funcionamiento de su centro de contacto. Si necesita hacer cambios, utilice Guardar como para crear una copia del script y nombrarlo para indicar que está en desarrollo. cuando esté completamente probado y listo.

Importar una secuencia de comandos

Permisos requeridos: Importación/exportación de Scripts de studio

Puede importar un script desde un archivo XML.

  1. En Studio, haga clic en File > Import from File.
  2. Navegue hasta la ubicación del script que desea importar, selecciónelo y haga clic en Abierto.
  3. Hacer clicGuardar.
  4. En la ventana Guardar script como, elija la carpeta donde guardará el script.
  5. Ingrese un nuevo Nombre del archivo para el script si desea cambiarlo. No se puede cambiar el nombre de los scripts después de guardarlos.
  6. Hacer clicGuardar.

Exportar una secuencia de comandos

Permisos requeridos: Importación/exportación de Scripts de studio

Puede exportar un script como un archivo XML.

  1. En Studio, haga clic en Archivo > Exportar a archivo.
  2. Navegue a la ubicación en su computadora donde desea guardar el script exportado.
  3. Entre un Nombre del archivo para el script y haga clic en Guardar.

Agregar y configurar una Acción en un script

Permisos requeridos: Crear/Editar Scripts de studio

Comportamiento SOn los componentes básicos de todos los scripts. La mayoría de las acciones tienen un conjunto de propiedades que deben configurarse para definir el comportamiento de la acción para el script específico que está creando. Consulte la ayuda en línea de cada acción para obtener información sobre las propiedades de la acción. Seleccione la acción en el lienzo del script y presioneF1 en su teclado. La página de ayuda se carga en su navegador predeterminado.

Esta sección describe cómo agregar una acción desde la pestaña Herramientas. Si la pestaña Framework está habilitada en Studio, puede agregar acciones desde ella.

  1. En Studio, cree o abra un script.
  2. En la pestaña Herramientas, busque la acción que desea agregar. Puedes encontrar acciones por:

    • Ingresar texto en el campo Filtro para buscar una acción. Puede realizar la búsqueda utilizando un nombre completo o parcial. Por ejemplo, si ingresa ai, la búsqueda encuentra todas las acciones cuyos nombres contengan esas letras en cualquier parte de sus nombres.
    • Hacer clic en Categorías Icon of two stacked boxes, each with a plus sign and lines of text para alternar entre ver las acciones por categoría o en una sola lista larga.
    • Hacer clic en Alfabético Icon of letters A and Z with a down arrow para alternar la visualización de las acciones en orden alfabético o en su orden predeterminado.
  3. Haga clic en la acción que desea agregar. No es necesario hacer clic y mantener presionado.
  4. Haga clic en el lienzo del guión para colocar la acción.
  5. Seleccione la acción y haga clic con el botón derecho para que aparezca la ventana Properties . También puede hacer clic en la pestaña Properties.

  6. Cambie la propiedad Caption a una palabra descriptiva o una frase corta que indique lo que hace esa acción en el script. Por ejemplo, para una acción Play, cambie el título por el nombre del archivo de audio que reproduce.
  7. Configure las otras propiedades según sea necesario. Puede configurar las propiedades mediante lo siguiente:

    • Selección de una opción: Haga clic en el icono de flecha hacia abajo Un galón apuntando hacia abajo. que aparece en el lado derecho del campo y, luego, seleccione una opción de la lista desplegable.
    • Usando la ventana del editor de expresiones: Haga clic en el icono de elipsis Una elipsis o un conjunto de tres puntos seguidos. que aparece en el lado derecho del campo y, luego, ingrese texto en la ventana del editor de expresiones.
    • Introducir texto directamente: Haga clic en el campo e ingrese directamente el texto. Algunas propiedades requieren texto estático o variables, pero muchas propiedades pueden aceptar cualquiera de los DOs.
    • Hacer doble clic en la acción: Algunas acciones tienen configuración adicional a la que puede acceder de esta manera.
  8. Guarde sus cambios en el script.

Agregar una Acción desde la pestaña Framework

Permisos requeridos: Crear/Editar Scripts de studio

La pestaña marco contiene una lista completa de todas las acciones disponibles en Studio. Algunas de las acciones de esta pestaña SOn acciones del sistema o internas que solo se pueden usar después de consultar a un representante de la cuenta. Use acciones desconocidas de esta pestaña con precaución.

La pestaña marco solo está visible si un representante de cuenta la ha habilitado para usted. Obtenga más información sobre la pestaña marco y las acciones que contiene.

  1. En Studio, cree o abra un script.
  2. En la pestaña marco, expanda las carpetas para ubicar la acción que desea agregar.
  3. Haga clic y arrastre la acción al lienzo del script.

Conectar Actions y crear Ramas

Permisos requeridos: Crear/Editar Scripts de studio

  1. En Studio, cree o abra un script.
  2. Agregue al menos DOs acciones al lienzo.
  3. Coloque el cursor sobre la primera acción y, luego, haga clic y mantenga presionada la flecha An arrow pointing to the right right. que se encuentra en la esquina inferior derecha del icono de la acción para iniciar un conector.
  4. Conecte la primera acción con la segunda arrastrando el cursor fuera de la acción y colocándolo sobre la segunda acción. Si la primera acción tiene más de una condición de ramificación disponible, aparece la ventana PickBranch .

  5. En la ventana PickBranch , seleccione la condición de rama que desea utilizar para esta conexión. En la mayoría de los casos, si la acción se conecta con solo otra acción, debe usar la rama Default. Para obtener información sobre cada una de las condiciones de bifurcación de una acción, consulte la ayuda en línea de la acción. Puede seleccionar una acción y presionar F1 en su teclado para abrir su página de ayuda.

  6. Haga clic en Aceptar.
  7. Repita los pasos 3 a 5 para conectar más acciones. Si conecta una acción con más de otra acción, utilice una condición de rama diferente para cada conexión. Siempre debe crear una rama que use el estado Defecto de la rama. Esto le da al script una opción para seguir si ninguna de las otras ramas aplica.
  8. Rearrange actions on the canvas if you need to make space for connections. Attached connectors move with an action. If you want to move more than one action at a time, you can: 
    • Haga clic en el lienzo y arrastre el cursor para dibujar un cuadro de selección alrededor de las acciones que desea mover. Las acciones seleccionadas se resaltan en rojo. Haga clic en una de las acciones seleccionadas para arrastrar el grupo a una nueva ubicación.
    • Presione CTRL y haga clic en cada acción que desee mover; luego, haga clic en una de las acciones seleccionadas y arrastre el grupo a una nueva ubicación.
    • Click an action, then click Edit > Selection in the Studio menu bar. Choose an option based on what you want to happen, then drag the highlighted actions to a new location: 
      • Seleccionar todo lo anterior: todas las acciones por encima de la acción seleccionada en todo el ancho del script se resaltan.
      • Seleccionar todo a continuación: se resaltan todas las acciones debajo de la acción seleccionada en todo el ancho del script.
      • Seleccionar todo a la derecha: se resaltan todas las acciones a la derecha de la acción seleccionada en toda la altura del script.
      • Seleccionar todo a la izquierda: se resaltan todas las acciones a la izquierda de la acción seleccionada en toda la altura del script.
  9. Verifique que no tenga callejones sin salida, donde el script está atascado y no tiene forma de terminar o pasar a la siguiente acción. You can DO this by script.
  10. Guarde el script.

Crear condiciones de rama variable

Permisos requeridos: Crear/Editar Scripts de studio

Las condiciones de rama variable le permiten crear condiciones personalizadas que deben cumplirse para que el script siga una rama en particular. Esto es útil al crear menús IVRClosed Interactive Voice Response. Automated phone menu contacts use via voice or key inputs to obtain information, route an inbound voice call, or both. Puede crear una rama para cada opción de menú y establecer la condición de cada una para que sea el número que el contacto debe ingresar para seleccionar esa opción.

  1. En Studio, cree o abra un script.
  2. Agregue al menos DOs acciones al lienzo.
  3. Coloque el cursor sobre la primera acción y, luego, haga clic y mantenga presionada la flecha An arrow pointing to the right right. que se encuentra en la esquina inferior derecha del icono de la acción para iniciar un conector.
  4. Conecte la primera acción con la segunda arrastrando el cursor fuera de la acción y colocándolo sobre la segunda acción. Aparece la ventana PickBranch .

  5. Haga clic en el ícono + en la ventana PickBranch .

  6. En el campo que aparece bajo condición de rama variable, ingrese el nombre de la condición que está creando. Por ejemplo, para crear una opción de menú para cuando el contacto presiona 3, escriba 3 en el campo.
  7. Haga clic en Aceptar. En el lienzo, el nombre del rectángulo de Variable aparece en un rectángulo sobre el conector. Puedes ver un ejemplo de esto en la siguiente imagen.

Eliminar un Conector

Permisos requeridos: Crear/Editar Scripts de studio

  1. En Studio, haga clic en la flecha en el conector que desea eliminar.
  2. Presione la tecla borrar en el teclado o haga clic en Editar > borrar.

Cambiar la forma de un Conector

Permisos requeridos: Crear/Editar Scripts de studio

Puede hacer que los conectores se doblen y curven para que encajen mejor en su script. Esto puede ayudarlo a mantener sus guiones ordenados y más fáciles de leer.

  1. En Studio, abre un script.
  2. Mantenga presionado CTRL + Shift en el teclado y coloque el cursor sobre el conector cuya forma desee cambiar hasta que la línea se vuelva azul.

  3. Mientras la línea aún esté en azul, haga clic con el botón derecho en el conector. Aparece un cuadrado azul pequeño. Este es un punto de anclaje.

  4. Haga clic y mantenga presionado el punto de anclaje y arrástrelo en cualquier dirección hasta que el conector tenga la forma que desea.

  5. Puede repetir los pasos 2 a 4 en el mismo conector para agregar más puntos de anclaje si desea agregar más curvas al conector.

  6. Haga clic en la flecha del conector para ver todos los puntos de anclaje en la línea.
  7. Elimine un único punto de anclaje presionando CTRL + Shift en el teclado y luego haciendo clic derecho en el punto de anclaje que desee eliminar. El punto de anclaje desaparece y la curva de la línea del conector se ajusta automáticamente.
  8. Si desea eliminar el conector completo, haga clic en la flecha del conector para que se ponga en rojo. Presione Suprimir.

Bloquear y desbloquear Scripts

Permisos necesarios: Vista Guiones de Studio, Crear/Editar

Si el bloqueo está habilitado para los Scripts Studio, puede bloquear y desbloquear los Scripts en los que está trabajando. Los Scripts desbloqueados SOn de solo lectura. Para editar un script, debe bloquearlo. Esto le permite trabajar en él, pero impide que otros usuarios guarden cambios en él.

Si intenta abrir un script que está bloqueado por otro usuario, Studio le notifica que el script está bloqueado. Puede anular un script bloqueado si su perfil de empleado NiCE CXone tiene el permiso correspondiente.

Según cómo esté configurado Studio, los Scripts se abren en modo bloqueado o en modo solo lectura de forma predeterminada. Cuando crea un nuevo script, no está ni bloqueado ni desbloqueado. Cuando guarda el script, este se bloquea automáticamente, incluso si el comportamiento predeterminado para Studio está configurado para abrir los scripts en modo de solo lectura.

  1. En Studio, abre un script. Si el bloqueo está habilitado, el script se abre en modo solo lectura (desbloqueado) o en modo bloqueado, según cómo esté configurado Studio. Si el bloqueo no está habilitado, la secuencia de comandos se abre con un fondo de lienzo blanco y el ícono en la pestaña de la secuencia de comandos no cambia a un candado.
  2. Para bloquear un script y poder editarlo, haga clic en el icono de bloqueo Icono de candado cerrado con cuerpo rojo anaranjado en la barra de herramientas. El lienzo cambia de gris a blanco y el ícono en la pestaña del script cambia a un candado.
  3. Para desbloquear un script y ponerlo en modo de solo lectura, haga clic en el ícono de desbloqueo Icon of open padlock with a red-orange body en la barra de herramientas. El lienzo cambia de blanco a gris y el ícono en la pestaña del script cambia al ícono correspondiente al tipo de script.

Anular un script bloqueado

Permisos necesarios: Bloquear anulación de guiones de Studio

Cuando abre un script que está bloqueado por otro usuario, Studio muestra una notificación. Puede anular el bloqueo en un script si necesita editarlo. Cuando usted anula un bloqueo de script, los cambios guardados del otro usuario se conservan. Studio muestra una notificación al usuario la próxima vez que inicia sesión. La notificación podría solicitarles que revisen los cambios realizados en el script. Puede revisar los cambios viendo una versión anterior del script o abriendo una versión anterior del script y comparándola con la versión actual.

  1. En Studio, haga clic en la pestaña bloqueado.
  2. Seleccione el script que desea anular y haga clic en Kick Icon of red arrow pointing out of the upper right of a gray square.
  3. Haga clic en Aceptar cuando se le solicite que confirme que desea expulsar al otro usuario de la edición del script.