管理提示

This help page is for Desktop Studio.This information is also available for CXone Studio.

提示是为联系人播放的消息。提示可以要求联系人输入信息,也可以传达信息而不要求输入。提示可以由自动话务员、交互式语音响应 (IVR关闭 自动电话菜单,允许呼叫者通过语音命令、按键输入或两者进行交互,以获得信息、路由呼入的语音呼叫或两者。) 系统以及其他语音处理工具播放。在 CXone 中,提示可以是预先录制的音频文件,也可以是通过文本到语音转换 (TTS关闭 允许用户将录制的提示作为文本输入,并使用计算机生成的语音来朗读内容。) 服务朗读的文本。

创建 TTS 提示。

所需权限ACD > Studio > 脚本 >创建/编辑 ACD > Studio > 录音提示 > 打开(在 Studio 中录制音频文件)

您可以使用序列编辑器或直接在支持提示的 Studio 操作的 Sequence 属性中输入提示来添加 TTS关闭 允许用户将录制的提示作为文本输入,并使用计算机生成的语音来朗读内容。 提示。

某些操作(如 Reqagent)有一个 Sequence 属性,但未链接到序列编辑器。如果想使用序列编辑器为这些操作创建提示,可以临时将 Play 添加到脚本中。通过 Play 访问序列编辑器并创建提示。将 Sequence 属性中的提示序列复制并粘贴到其他操作的 Sequence 属性中。完成后,删除 Play

  1. 添加 Voiceparams action到您的脚本中,使其在支持 TTS关闭 允许用户将录制的提示作为文本输入,并使用计算机生成的语音来朗读内容。 的操作之前,例如 MenuPlay 操作。如果支持 TTS 的操作设置的属性将传递给其他脚本,您可能还需要在子脚本中放置 Voiceparams 操作,以确保属性没有被忽视。

  2. Voiceparams 操作的属性中,单击 TTSVoice 字段中的下拉菜单,然后选择您想要说出提示的语言和语音。
  3. 使用序列编辑器将其输入到“序列”属性中创建提示。
  4. Phrase 字段中键入不带格式的提示文本。您可以通过此方式在一个位置查看整个提示,而不是在 Sequence 字段中分割的片段。Phrase 字段中的内容仅供参考。提示不会说出此文本。
  5. 单击应用,将提示保存至选中的操作。

在序列编辑器中创建 TTS 提示

序列编辑器允许您使用一个为您添加格式的界面创建 TTS 提示。使用序列编辑器时,将序列关闭 为联系人播放的一段音频提示。添加到Sequence字段。字段中出现的每个numbered 项目都是一个序列。这些项目会在单击a Play option on the left side of the editor window, such as Play a Date or Synthesize Text.

序列属性的字符数限制为 300 个。如果您需要播放的文本长度超过此长度,您可以在属性字段数量。例如,如果需要播放 540 个字符长的文本,可以添加两个文本转语音序列,并在其之间分割文本。

  1. Studio ,打开或创建脚本。如果需要,添加支持提示的操作,例如 Menu
  2. 双击您想要向其添加提示的操作。
  3. 在序列编辑器窗口中,单击 Synthesize Text。默认文本出现在 Sequence Sequence Value 字段中。Synthesize Text 的默认文本是 The little brown fox

  4. Sequence Value 字段中,删除默认值,然后输入提示所需的值。例如,删除 The little brown fox 并添加 Thank you for calling Classics, Inc. We're here to help you read more.
  5. 如果您要包含资金、日期、时间或希望逐字母拼写的文本(如联系人姓名),请使用序列编辑器中的其他序列选项。

  6. 如果要更改 Sequence 字段中分段的顺序,请选择要移动的序列,然后单击向上或向下箭头。当脚本播放提示时,将按从上到下的顺序读取其序列。

  7. 使用下列方法之一在单词或短语之间插入停顿:

    • 使用录制的沉默文件:使用序列编辑器创建一个 WAV 文件上传一个沉默的声音文件。单击 Play a Wave File ,选择沉默文件。必要时在 Sequence 字段中单击 WAV 文件并使用箭头键 将提示移动到所需的位置。
    • 使用等待操作:对于您想用沉默分开的提示片段使用一个 Play 操作,然后在它们之间添加 Wait 操作。使用此暂停的长度配置 Wait
  8. 如有必要,请修改 Sequence 字段中的条目。在 Sequence 字段中选择一个序列,然后在 Sequence Value 字段中更改内容。
  9. Phrase 字段中键入提示的全文,无需设置格式。您可以通过此方式在一个位置查看整个提示,而不是在 Sequence 字段中分割的序列。Phrase 字段中的内容仅供参考。TTS 服务不会说出此文本。
  10. 单击 Apply,保存提示。

在序列属性中创建 TTS 提示

在操作的 Sequence 属性中输入具有适当格式的序列,即可创建 TTS关闭 允许用户将录制的提示作为文本输入,并使用计算机生成的语音来朗读内容。 提示。序列是一系列字符、单词、短语或句子。TTS 服务可识别多种序列类型。您可以在 Sequence 属性中包含多个序列。每个序列必须:

  • 以双引号引起来。
  • 包含序列包含的信息类型所需的字符串引用字符。唯一不需要字符串引用字符的序列类型是音频文件序列
  • 遵循支持的信息格式,例如日期、时间和金钱。
  • 包含不超过 300 个字符。如果您需要包含超过 300 个字符的文本,请将其拆分为多个序列。

Classics, Inc.已决定重做其IVR关闭 自动电话菜单,允许呼叫者通过语音命令、按键输入或两者进行交互,以获得信息、路由呼入的语音呼叫或两者。菜单中的提示之一。管理团队为新提示编写脚本,并将其交给 Classics, Inc. 的 Studio 脚本编写者 Beowulf Herot。该提示适用于请求其帐户余额和下一张账单到期日的客户。当 Beowulf 完成提示时,它包含以下序列:

"%{firstName} {lastName} 帐户的当前余额为 "
“${accountBal}”
"%。您的下一次付款应于“
”到期“@{billDueDate}”
"%。重听请按 1。通过邮件发送付款的地址,请按 2。注册电子账单支付,请按 3。返回主菜单,请按星号键。"

创建动态 TTS 提示

您可以在 Snippet 操作中创建动态提示。如果您的提示不断改变,这会很有帮助。您可以直接在 Snippet 编辑器窗口中输入提示,也可以在序列编辑器中创建它,然后将其复制到 Snippet 操作中。

  1. In Studio, open an existing script or create a new one.
  2. 添加 Snippet 操作和将播放提示的操作,如 Play
  3. Snippet 放在 Play 之前并连接起来。
  4. Sequence Editor 中创建提示,然后复制操作的 Sequence 属性的内容。

    有些操作具有 Sequence 属性,但序列编辑器没有。如果需要使用的操作不支持序列编辑器,可在脚本中添加一个 Play 操作,创建提示,然后从 Sequence 属性复制。创建提示后删除额外的操作。

  5. Double-click the Snippet action.
  6. Snippet Editor 窗口中,创建动态对象,并使用以下语法为其分配序列:

    DYNAMIC [dynamic object name] = [sequence]

  7. 在序列定义的前面,第一个双引号之前添加一个美元符号字符 ($)。使用反斜杠字符转义提示符中的所有双引号。例如:

    ASSIGN promptList = $"\"{promptPath}YourAccountBalanceIs_{lang}.wav\" \"%{accountBalance}\" \"{promptPath}ToPayYourBillPress_{lang}.wav\"" 
  8. 在代码片段中添加完成提示所需的其他变量(如果脚本中还没有)。

    例如:

    ASSIGN env = "PROD"
    ASSIGN lang = "ENG"
    ASSIGN promptPath = "Prompts\{env}\"
    ASSIGN accountBalance = "$52.65"
    ASSIGN promptList = $"\"{promptPath}YourAccountBalanceIs_{lang}.wav\" \"%{accountBalance}\" \"{promptPath}ToPayYourBillPress_{lang}.wav\""
  9. 单击应用
  10. 在脚本的画布工作区中,选择将播放提示的操作。
  11. Sequence 属性中,输入在 Snippet 操作中保存提示的动态对象的名称。对于本节中使用的示例,您可以输入 {promptList}
  12. 单击应用

Studio 中录制语音提示

所需权限ACD > Studio > 脚本 >创建/编辑 ACD > Studio > 录音提示 > 打开

您可以通过 Studio 中的序列编辑器录制语音提示。这种方法要求您必须能使用手机来录制提示。您需要提供电话号码,然后会收到一个自动电话,它会记录您所说的话。

您在 Studio 中录制的音频文件将作为 WAV 文件存储在您的CXone租户关闭 用于管理 CXone环境的技术支持、计费和全局设置的高级组织分组中。您可以在任何支持序列的操作中将它们用作音频提示。您可以在浏览 ACD 文件页面CXone 中查看所有可用的音频文件。

  1. Studio 中,打开现有脚本或创建新脚本。

  2. 将支持序列编辑器的操作添加到该脚本中,例如 PlayWhisper
  3. 双击操作图标,打开序列编辑器。

  4. 单击 Play a Wave File 并选择 New

  5. Sequence 字段中选择 NewPrompt().wav,然后在 Sequence Value 字段中改写默认值,以重命名 WAV 文件。如果更改 Sequence Value 字段中的文件名时,序列列表中的文件名也会随之更改。

  6. 单击工具栏中的Connect Prompt Manager图标 ,打开“提示管理器登录”窗口。

  7. 输入您现在可以访问的电话的号码。您在该电话上将接到一个让您录制提示的电话。

  8. 单击 Connect,从录制服务接收呼叫。

  9. 应答电话呼叫。序列编辑器工具栏中的一些图标变得可用,并且该工具栏显示一条提示管理器就绪消息。现在可用的这些图标允许您在通话期间控制录音。

  10. 单击Record 图标 ,开始录制提示。

  11. 当您在通话中听到一声哔声提示音时,清楚地说出您的提示或消息。

  12. 完成录制时,单击Stop 图标 。在看完提示之前不要挂断电话。

  13. 要查看录音,请单击Play 图标

  14. 如果语音提示可以接受,则结束通话。如果不可接受,请单击 Record 图标,再次录制提示。

将音频提示分配给操作

所需权限ACD > Studio > 脚本 >创建/编辑

录制或上传新的语音提示后,您可以将其添加至您想要播放该提示的操作中。

您可以在操作的 Sequence 属性中,为录制、上传的音频提示输入文件名您也可以使用“提示管理器”,如本任务中所述。

  1. 在脚本中,双击要为其分配提示的操作。
  2. 在提示管理器中,单击 Play a Wave File 并选择 Browse
  3. 选择希望播放的提示并单击 OK
  4. 单击 Apply,保存选择并关闭提示管理器。

Studio 中编辑提示

所需权限ACD > Studio > 脚本 >创建/编辑

Wave 编辑器允许您修剪 WAV 文件起始和结束位置上不必要的音频内容。

  1. 双击某个支持提示的操作。如果您刚刚录制了提示,则提示管理器可能已打开。
  2. 单击工具栏中的Edit Wave图标 ,启动 Wave 编辑器。
  3. 从“提示”列中选择您想要编辑的 WAV 文件。
  4. 单击左侧鼠标按钮,突出显示您想剪掉的提示开头部分。
  5. 单击右侧鼠标按钮,突出显示您想剪掉的提示结尾部分。
  6. 单击绿色 Play 图标,播放要移除的突出显示部分的提示,检查是否已修剪适当数量的音频。
  7. 单击 Edit>Trim,移除 WAV 文件中突出显示的部分。
  8. 保存您的更改。

上传音频提示

所需权限ACD > Studio > 文件浏览器 > 编辑 ACD > Studio > 文件浏览器 > 创建

如果您使用第三方音频应用程序录制提示信息,则可以在 Studio 中上传提示信息。上传的所有提示均须为受支持的音频格式。

  • 比特率:64 kbps
  • 音频样本大小:8 位
  • 渠道数:1(单渠道)
  • 音频采样频率:8 kHz
  • 音频格式:CCITT μ-Law

您还可以在 CXone 中的浏览 ACD 文件页面上查看、上传和管理提示及其他文件。

  1. Studio 中的文件选项卡上,展开要上传文件的文件夹。如果要上传提示,请展开提示文件夹。

  2. 将提示文件从计算机上的文件浏览器拖到 Studio 中的文件窗口。
  3. 单击 Refresh 图标,并验证提示的 Date Modified 字段是否已更新。

下载或删除音频提示和其他文件

所需权限ACD > Studio > 文件浏览器 > 编辑 ACD > Studio > 文件浏览器 > 创建

您可以将提示和其他文件从 Studio 下载到计算机或从中删除。您也可以在 CXone 中的浏览 ACD 文件页面上执行此操作。

  1. Studio 中的文件选项卡上,展开文件所在的文件夹。

  2. 要下载提示,可将其从 Studio 文件浏览器拖到桌面或计算机的某个文件夹中。
  3. 要删除文件,请选择该文件并单击红色 X 图标 。单击 Yes,确认您要删除该文件。