Studio 用户界面

此页面适用于旧版 Studio 应用程序。如果您是针对 CXone Studio 的受控发布计划的一部分,并且想要了解该应用程序中的界面,请参阅开始使用 CXone Studio 帮助页面。

Studio 用户界面由中间的画布组成,在左边、右边和底部围绕了许多选项卡。这些选项卡提供了对 Studio 操作关闭 在 Studio 脚本中执行一个过程,如收集客户数据、播放消息或音乐或将联系人转接给坐席。的访问权限以及有关这些操作和脚本的信息。

Studio 菜单栏

主菜单包含以下七个不同的下拉菜单:文件、编辑、查看、验证、调试、窗口和帮助。许多菜单项都是常见的命令,比如保存文件或撤消更改。常用命令不在本节介绍。

文件菜单

除了通用文件菜单的常见命令,如新建、打开、保存和退出,Studio 文件菜单还包含这些额外的选项:

菜单选项 详细信息
导入/导出

允许您将脚本从XML文件导入到 Studio,或将脚本导出到 XML 文件。

最近

提供您最近为登录的租户关闭 用于管理 CXone环境的技术支持、计费和全局设置的高级组织分组而在 Studio 中打开的脚本列表。单击一个列示脚本,可在新的画布面板中将其打开。

注销并退出 选择注销 Studio 并关闭应用程序。即使在您关闭应用程序后,Studio 仍然会记得您的登录信息。如果需要完全注销,请使用此选项。

编辑菜单

“编辑”菜单包含“编辑”菜单的常用命令,包括“撤消”、“剪切”、“复制”和“粘贴”。您可以将这些选项与画布上的Studio 操作关闭 在 Studio 脚本中执行一个过程,如收集客户数据、播放消息或音乐或将联系人转接给坐席。一起使用。标准的键盘快捷键可以执行这些命令(Ctrl+Z、Ctrl+X、Ctrl+C 和 Ctrl+V)。Studio“编辑”菜单还包括以下选项:

菜单选项 详细信息
将脚本复制为图像

将当前脚本作为图像复制到剪贴板。您可以将图像粘贴到另一个位置,如电子邮件或文本文档。

查找

打开“在脚本中查找”窗口,您可以在打开的所有脚本中搜索特定的文本,或者在顶部“画布”选项卡中打开的脚本中搜索。

转至

搜索并立即导航到当前脚本中的操作 ID。您可以在操作选项卡ID 字段中查看操作 ID。

比较 支持您可以按标题、参数、分支或位置比较两个脚本。例如,一对脚本可能包含完全相同的操作和分支,但可能包含不同的参数。通过比较 2 个脚本,您可以在查找结果选项卡中查看不同之处(和相似之处)。

视图菜单

“查看”菜单提供以下选项:

菜单选项 详细信息
帮助 > 坐席信息 查看当前登录 StudioCXone 帐户信息。信息显示在属性选项卡上。
帮助 > 登录信息 Studio 中查看有关当前会话的信息。

浏览,
工具,
属性,
库,
文件,
导航,
搜索,
框架,
查找结果

单击选项卡名称可在Studio 中打开该选项卡。当您关闭了一个选项卡,需要重新打开时,这比较有用。

如果需要重新打开“脚本错误”、“操作”、“变量”或“依赖关系”选项卡,请参见“验证”菜单

工具栏 > 跟踪 单击可切换是否要在工具栏中显示跟踪选项。

“验证”菜单

菜单选项 详细信息
窗口

单击可打开以下任何选项卡:脚本错误、操作、变量和依赖关系。

如果需要打开不在此列表中的选项卡,请参阅“视图”菜单

语法检查

检查活动的脚本是否存在连接和属性错误,并在“脚本错误”选项卡中显示警告。这是测试和调试脚本的基本方法。

调试菜单

需要的权限ACD > Studio > 脚本 >调试

菜单选项 详细信息
捕获脚本

捕获一个脚本,在它运行时跟踪并记录它的进度您可以选择捕获 Next instance only ,也可以选择在其运行时进行 Continuous 捕获。当脚本中的每个操作触发时,产生的信息将出现在跟踪输出工具中。如果连续捕获一个脚本,跟踪文件将保存在 CXone 媒体服务器上。您可以使用 Debug > Load Remote Trace File 来查看这些跟踪文件。

启动即跟踪

启动活动的脚本并打开“跟踪输出”窗口,以显示脚本运行的结果。您还可以使用 Start with Trace 按钮从工具栏启动跟踪

加载调试跟踪文件

浏览跟踪文件并在“跟踪输出”窗口中将其打开。

加载远程跟踪文件

浏览 CXone 平台上的跟踪文件并在“跟踪输出”窗口中将其打开。

窗口菜单

“窗口”菜单支持您在 Studio 中打开的脚本之间导航。在该菜单中选择一个脚本会把它作为活动选项卡放在前面。如果只打开一个脚本,则该菜单中只有一个选项。

帮助菜单

“帮助”菜单提供了访问 Studio 在线帮助的选项,以及其他可以帮助您使用 Studio 的信息。

菜单选项 详细信息
NICE CXone Studio 文档

打开默认 Web 浏览器的新浏览器选项卡,并加载联机帮助的Studio概述页面。

上下文相关帮助      F1

显示画布上当前选择的操作的联机帮助主题。您还可以按下键盘上的F1 来访问所选操作的帮助主题。帮助主题在默认 web 浏览器的应新选项卡上加载。

业务单位配置

显示有关如何配置租户的信息。如果您不确定启用了哪些应用程序或功能(例如渠道类型),您可能需要参考此信息。

故障排除 > 手动下载 CefSharp 程序 开始一个新的 CefSharp 下载,这种 Studio 需要运行的一种插件。
故障排除 > 清除缓存 清除 Studio 的缓存,如果应用程序未按预期运行,则可以使用此选项。
关于

显示有关 Studio 的基本信息,例如版本。

Studio 工具栏

工具栏提供了打开或保存脚本等通用命令以及 Studio 专用命令的组合。

工具栏选项 详细信息
增加/减少空间

单击可增加或减少画布上操作之间的空间大小。每次单击都会少量改变空间大小。

启动即跟踪 可使您启动跟踪
跟踪脚本

跟踪脚本会启动活动的脚本并打开“跟踪输出”窗口,以显示脚本运行的结果。工具栏提供了 3 个与跟踪脚本相关的命令,即:启动跟踪;选择使用 ANI关闭 也称为呼叫者 ID。所列的语音来电的电话号码。 还是 DNIS关闭 识别联系人在呼入语音呼叫联系您时拨打的号码,以及坐席或系统在呼出语音呼叫时拨打的号码。 来跟踪脚本;选择跟踪并捕获脚本运行的下一个实例还是连续跟踪并捕获脚本运行时脚本的每一个实例(与生产脚本相关)。有关更多信息,请参阅 Debug Scripts 页面。

锁定/解锁脚本

单击以锁定或解锁脚本。锁定将脚本置于只读模式。解锁后,允许您编辑脚本,但其他Studio用户不得同时编辑。其他用户仅可在解锁或保存并关闭脚本后修改脚本。

当脚本被锁定后,画布背景显示为白色,选项卡上的脚本图标是一个锁定的挂锁。当脚本被解锁后,画布背景显示为灰色,图标显示为脚本类型图标。

仅当启用脚本锁定后,此选项才会显示在 Studio 中。您的CXone管理员可以启用此选项。

如果您拥有脚本锁定覆盖权限,则可以则可以覆盖其他用户对脚本的锁定,以便您可以对其进行编辑。您可以在“已锁定”选项卡中查看 租户关闭 用于管理 CXone环境的技术支持、计费和全局设置的高级组织分组 上所有锁定的脚本。

Studio 画布

画布是 Studio 界面中心的大空间。这是您创建脚本的地方。您可以将操作从“工具”或“框架”选项卡拖到画布上。脚本会作为新的画布选项卡打开,就像 Web 浏览器一样。

在画布上您可以:

  • 单击选项卡或使用 Window 菜单在打开的脚本之间切换。
  • 通过单击画布上的 X 来关闭脚本选项卡。X 不是在脚本的选项卡上,而是在一些 Web 浏览器中。它在画布窗口右上角。
  • 如果单击画布的空白区域,然后选择 Properties选项卡,就可以访问脚本的属性
  • 如果关闭所有脚本选项卡,则可以通过创建一个新脚本来替换画布。

Studio 选项卡

通过选项卡可以访问在 Studio 中工作时所需的各种不同信息。默认情况下,选项卡分为三组。这些小组位于画布的左侧、右侧和底部。默认情况下,所有选项卡均可见。如果您关闭选项卡,可以使用视图菜单验证 >窗口菜单来重新打开。请参阅本页顶部的图像,获取默认布局的视觉指南。

默认的选项卡组

默认选项卡组为:

  • 左侧:这些选项卡默认位于 Studio 窗口的左侧:
    • 导航
    • 依赖关系
    • 变量
    • 操作
  • 右侧:默认情况下,这些选项卡位于 Studio 窗口右侧:
    • 框架
    • 工具
    • 浏览
    • 属性
  • 底部:默认情况下,这些选项卡位于 Studio 窗口底部:
    • 查找结果
    • 文件
    • 脚本错误
    • 搜索

重新排列选项卡

选项卡的位置可自定义。您可以:

  • 拖放选项卡在彼此的顶部,将它们移动到 Studio 中的其他位置。如果您抓住一个选项卡的标题栏,整个选项卡堆栈就会移动。如果您只想移动一个选项卡,则抓住选项卡的另一端(实际上看起来像一个选项卡的部分)。
  • 通过单击选项卡右上角的大头针图标将一组选项卡固定到界面窗口的边缘。当您单击一个固定的选项卡时,它就会滑出以便使用。当您远离选项卡进行单击时,它会最小化回固定的边缘。

  • 使用放置区来放置选项卡。当您单击选项卡的标题栏并将其从当前位置拖离时,Studio 界面会显示所有可以停靠选项卡的位置的放置区图标。将光标悬停在一个放置区上,然后释放鼠标按钮。

“操作”选项卡

“操作”选项卡显示当前脚本中所有操作的列表。操作按添加到脚本的顺序列出。此选项卡显示了每个操作的以下信息:

  • 标题:这是出现在画布上的操作图标下方的文本。默认情况下,标题与操作名称相同。您可以在操作的属性中改变任何操作的标题。这是注释操作在脚本中要完成内容的一种有效手段。例如,对于每个 Snippet 操作,您可以更改标题以指示 Snippet 的实例在脚本中执行的任务。

  • Tool Name:操作名称。该名称无法修改。
  • ID:根据添加到画布的顺序分配给操作的操作 ID。指定脚本中操作的每个实例都有一个唯一编号。

“浏览”选项卡

“浏览”选项卡显示 Studio 文件夹,您可以在其中存储为此租户创建的所有脚本。您可以:

  • 通过双击脚本从此选项卡打开脚本。它会在画布选项卡中打开。
  • 通过右键单击脚本并将光标悬停在 History 上,可以查看脚本的历史记录。
  • 通过在“历史记录”列表中单击要查看的版本,打开旧版本的脚本。
  • 通过打开较早版本的脚本并单击 Save As,然后在列表中选择该脚本,可以恢复到该版本的脚本。

如果您拥有相应的权限,CXone ACD 应用 中的脚本页面还允许您恢复到该脚本的先前版本。

“依赖关系”选项卡

显示活动脚本中操作之间的关系。

“文件”选项卡

所需权限ACD > Studio > 文件浏览器 > 查看

“文件”选项卡包含脚本中使用的所有语音提示录音。这些文件存储在您的租户中。您可以看到提示文件的基本信息(上次修改日期、用途、描述、播放时长)。您可以从此选项卡上传新提示

“查找结果”选项卡

通过 Edit > Compare 选项显示比较的结果。

“框架”选项卡

包含所有 Studio 操作的综合列表。

由于此选项卡上的某些操作更为高级,因此默认情况下并非所有用户都可以使用它们。如果您在 Studio 中没有看到该选项卡,则说明您的 租户关闭 用于管理 CXone环境的技术支持、计费和全局设置的高级组织分组 尚未启用该选项卡。如果您的组织有可以通过使用“框架”操作来满足的需求,您的 CXone 客户代表 可以提供对“框架”选项卡的访问。

如果您有权访问“框架”选项卡,请谨慎使用不熟悉的操作。许多操作未记录在联机帮助中。您可以询问您的 CXone 客户代表 或向 CXone 客户社区提交问题,以了解有关操作的更多信息。

您可以在框架操作帮助页面上了解有关此选项卡上可用操作的更多信息。

“已锁定”选项卡

所需权限ACD > Studio > 脚本 >锁定覆盖

显示已锁定的脚本的列表。如果您的 CXone 用户帐户具有锁覆盖权限,您可以覆盖一个脚本锁定。右键单击脚本并选择 Kick <user> from editing script 或单击 Kick 按钮(由红色箭头指示),即可解锁脚本。

“导航”选项卡

使您可以快速地浏览较大的脚本,而不必使用滚动条。红色方框显示了您可以在画布上查看的内容。

“属性”选项卡

“属性”选项卡显示有关当前所选操作的信息。如果没有选择任何操作,此选项卡将显示关于整个脚本的信息。

每个操作都有一组唯一变量、分支和参数。您可以在操作的属性中对它们进行配置,以定义想要操作在脚本中如何运行。您还可以通过右键单击操作并选择 Properties 来查看操作属性。

脚本属性允许您模拟呼入呼叫来测试脚本。您还可以编校脚本中一个或多个变量。

脚本错误

“脚本错误”选项卡显示与脚本相关的任何警告和错误。在保存脚本或运行语法检查之前,该选项卡不会显示任何内容。警告不会阻止脚本的运行或保存,但错误会。

“搜索”选项卡

允许您搜索特定脚本。您可以使用部分脚本名称、业务单位、新旧版本以及脚本类型来缩小搜索范围。

“工具”选项卡

显示最常用的操作。单击类别图标 以更改操作的排列方式。您可以按类别或字母顺序显示它们。当操作按字母顺序排列时,您可以单击排序图标 来逆转列表的顺序。

默认类别的分组称为选项板。单击“工具”选项卡右上角的选项板图标 可以创建自己的 类别和选项板。默认选项板包含以下类别:

类别 描述
标准 任何脚本类型中使用的基本和一般操作。
语音附加 用于语音媒体类型脚本的常见操作。
高级 经验丰富的脚本编写者通常使用的高级操作。
数据访问 与从 inData 或客户数据库访问数据相关的操作。
系统 用于文件存储和操控的操作。
事件 CXone 触发的操作。
Web 由系统脚本使用的操作。系统脚本是 CXone 在内部使用的默认脚本。
语音 与自动语音识别 (ASR关闭 允许联系人通过说话、按手机按键或两者的结合来响应录制的语音提示。) 相关的操作。
WFO Workforce Engagement (WEM) 相关的操作。
Personal Connection CXone Personal Connection 相关的操作。
CXone 自定义身份验证 与客户身份验证相关的操作。
自动化和 AI 与自动化 AI 相关的操作,如坐席助理关闭 一款软件应用程序,为坐席提供特定于上下文的帮助。虚拟坐席机器人关闭 代替现场人工坐席处理客户交互的软件应用程序。

“变量”选项卡

显示活动脚本中可用的变量以及引用每个变量的操作。

键盘快捷方式

Studio 使用许多众所周知的键盘快捷方式(例如,CTRL + C 可复制某些内容),但同时也提供更多的快捷键来简化您的工作流程。

快捷方式 操作
CTRL + A 选择活动脚本中的所有操作图标。
CTRL + C 执行标准的 Windows 复制功能。
CTRL + E 打开“导出到文件”窗口。
CTRL + F 打开“在脚本中查找”对话框。
CTRL + G 转到特定脚本操作项(即,根据您输入的 ID 在活动脚本中选择一个操作图标)。
CTRL + I 打开“从文件导入…”窗口。
CTRL + N 打开“创建新脚本”窗口。
CTRL + O 打开“从…打开脚本”窗口。
CTRL + S 仅保存对活动脚本的更改。
CTRL + SHIFT + S 保存对所有打开脚本的更改。
CTRL + T 仅为下一次出现捕获脚本跟踪。
CTRL + SHIFT + T 开始在手动结束之前一直运行的连续脚本跟踪。
CTRL + V 执行标准的 Windows“粘贴”功能。
CTRL + X 执行标准的 Windows“剪切”功能。
CTRL + Y 将脚本还原到其在“撤销”之前的状态。
CTRL + Z 执行标准的 Windows“撤销”功能(即,使脚本回到其在上次更改之前的状态)。
Del Delete 删除选定的项目。
F1 启动选定操作的联机帮助。
CTRL + F2 打开“浏览”选项卡。
CTRL + SHIFT + F2 打开“框架”选项卡。
CTRL + F3 打开“工具”选项卡。
CTRL + SHIFT +F3 打开“查找结果”选项卡(请参阅“在脚本中查找”对话框)。
CTRL + F4 打开“属性”选项卡。
CTRL + SHIFT +F4 打开“已锁定”选项卡。
F5 打开“跟踪输出”窗口。
CTRL + F6 打开“文件”选项卡。
SHIFT + F6 检查活动脚本的语法,并打开“脚本错误”选项卡。
CTRL + F7 打开“导航”选项卡。
CTRL + F9 打开“搜索”选项卡。