Gérer les Scripts (Desktop Studio)

Cette page d'aide concerne Desktop Studio. Ces informations sont également disponibles pour Studio.

Cette page fournit des informations sur les tâches que vous pouvez être amené à effectuer lorsque vous travaillez avec des scripts. En plus des tâches décrites sur cette page, vous pouvez planifier l'exécution de Scripts sur la page Calendriers de Scripts dans NiCE CXone.

Afficher les Propriétés d'un script

Autorisations requises : Scripts studio Voir

L'onglet Propriétés du script affiche des informations sur le script en cours. À partir d'ici, vous pouvez voir ou modifier le type DE support du script, configurer un interaction entrante simulée pour les tests, ou configurer la rédaction de variable.

  1. Dans Studio, ouvrez un script.
  2. Cliquez n’importe où dans l’espace de travail du canevas pour vous assurer qu'aucune action n'est sélectionnée.
  3. Cliquez sur l'onglet Propriétés, qui affiche des informations sur le script.

  4. Dans la section Basique, vous pouvez :

    • Afficher l’unité d’exploitation où se trouve le script.

    • Voir ou modifier le MediaType du script.

    • Déterminer si le script a été modifié depuis sa dernière sauvegarde. Si la valeur est Vrai, le script a changé.

    • Afficher le nom du script.

  5. Dans la section Débogage, vous pouvez définir les propriétés utilisées lorsque vous déboguez le script avec une trace.Tu peux:

  6. Dans la section Bibliothèque, vous pouvez accéder aux paramètres spécifiques au script, le cas échéant. La plupart des types de script ne possèdent aucune propriété dans cette section.

  7. Dans la Section Rédaction, vous pouvez configurer la rédaction de variable. Celui-ci supprime les variables des traces et des journaux.

Affichage de l'historique d'un script

Autorisations requises : Scripts studio Voir

Le nombre de versions précédentes d'un script que Studio conserve est configurable par un administrateur de NiCE CXone .

  1. Dans Studio, cliquez sur l’onglet Parcourir.
  2. Faites un clic droit sur un script et cliquez sur Historique
  3. Cliquez sur la version que vous voulez afficher. Si le verrouillage est activé dans Studio, la version précédente du script s'ouvre en mode en lecture seule.

Changer le type de Média d'un script

Le type de média détermine le type d'interaction que le script peut gérer.

Autorisations requises : Scripts studio Créer/Modifier

  1. Dans Studio, ouvrez un script.
  2. Cliquez dans un espace vide du canevas de script pour vous assurer qu'aucune action n'est sélectionnée.
  3. Dans l'onglet Propriétés, cliquez sur la flèche déroulante en regard de la propriété MediaType et sélectionnez un nouveau type DE support pour le script.
  4. Enregistrez le script.

Mise en production d’un script

Autorisations requises : Points de Contact Modifier

Lorsqu'un script est entièrement testé et prêt à être utilisé dans NiCE CXone, vous pouvez le mettre en production. Pour ce faire, vous devez affecter un script à un point de contactClosed point d’entrée qu’un contact entrant utilise pour amorcer une interaction, comme un numéro de téléphone ou une adresse courriel. dans NiCE CXone ACD.

Si vous utilisez une convention de nommage pour identifier les scripts qui sont en développement ou en production, cela vous aide, vous et les autres développeurs de scripts de votre organisation, à savoir quels scripts sont prêts à être utilisés. Une convention de dénomination n'indique pas à NiCE CXone les scripts à utiliser.

N'attribuez des scripts aux points de contact que si vous êtes certain qu'ils sont entièrement testés et prêts pour la production. La mise en production d'un script qui n'est pas prêt peut avoir pour conséquence que les contacts ne sont pas acheminés vers le point de contact sélectionné.

  1. Cliquez sur le sélecteur d'applications icon of app selector et sélectionnez ACD.
  2. Accédez à Paramètres du contact > Point of Contact.

  3. Cliquez sur le point de contact auquel vous souhaitez attribuer un script.
  4. Cliquez sur Modifier.
  5. Sélectionnez le script que vous voulez que ce point de contact utilise.
  6. Cliquez sur Terminé.

Comparer les Scripts

Autorisations requises : Scripts studio Voir

Vous pouvez comparer deux scripts par légendes, paramètres, branches ou position. L'onglet Rechercher les Résultats affiche les différences et les similitudes entre les scripts sélectionnés.

  1. Ouvrez les deux scripts que vous souhaitez comparer. Assurez-vous d'enregistrer toutes les modifications que vous avez récemment apportées.
  2. Cliquez sur Modifier > Comparer pour ouvrir la fenêtre Compare Scripts.
  3. Sélectionnez un script dans le champ Left, et l'autre script dans le champ Right. Faites attention au script que vous sélectionnez, car tous les scripts actuellement ouverts dans Studio s’affichent dans ces listes déroulantes.
  4. Configurez les sections General Options et Compare Settings. Ces sections vous permettent de déterminer quels éléments des scripts vous souhaitez comparer. Notez que l'élément Position fait référence aux axes X et Y pour chaque action sur le canevas.

  5. Cliquer sur Comparer. Les résultats s’affichent dans l'onglet Résultats de la recherche. Si l'onglet Trouver des résultats n'est pas ouvert, cliquez sur Affichage > Trouver des résultats dans le menu.

Masquer les variables des traces et des journaux

Autorisations requises : Scripts studio Créer/Modifier

La rédaction des Variable élimine les valeurs des Variable des traces et des journaux générés par un script. Vous pouvez masquer des variables et des objets.

La rédaction est configurée au niveau du script dans le champ VariableRedaction d'un script. Les valeurs Masquées sont remplacées par une chaîne de X caractères. La longueur de la valeur de la variable déterminer combien de X sont utilisés, ce qui signifie qu'un mot de cinq lettres masqué résulterait en cinq X. La rédaction partielle de variable, comme une partie d'un numéro de carte de crédit, n'est pas prise en charge.

La rédaction de Variable a lieu au niveau du script. Ce n'est pas une propriété héréditaire. Si une variable masquée est transmise à d'autres Scripts, comme avec un RunScript ou RunSub, cette variable n'est pas automatiquement masquée dans les scripts suivants. Si vous souhaitez qu'une Variable soit toujours masquée, vous devez configurer la rédaction de la Variable dans tous les Scripts auxquels elle pourrait être transmise.

Les variables transmises à d'autres scripts ont une portée globale. Pour les masquer, vous devez inclure global: avant le nom DE variable dans le champ VariableRedaction pour garantir qu'elle sera masquée.

La meilleure pratique consiste à ne jamais conserver de données sensibles dans un script plus longtemps que nécessaire. En plus de rédiger les valeurs des Variable, vous pouvez supprimer les données de la Variable.

Pour masquer les variables :

  1. Dans NiCE CXone, cliquez sur le sélecteur d'application et sélectionnez Omnicanal Routing > Studio Trois flèches jointes à la base. L'une pointe tout droit vers le haut, une autre vers le haut et à droite, et la dernière vers le haut et à gauche. .
  2. Dans la page Scripts, localisez et double-cliquez pour ouvrir le script avec lequel vous souhaitez travailler avec . Le script s’ouvre dans un nouvel onglet.
  3. Dans le panneau des propriétés sur le côté droit du script, cliquez sur l’onglet variables.
  4. Cliquez sur Masqué Un œil barré par une ligne en diagonale. .

  5. Dans le champ de l'onglet variables, entrée le nom de chaque variable que vous souhaitez masquer.Appuyez sur la touche Entrée après chaque variable. Ces noms doivent correspondre aux variables créées dans les actions Assign ou SNIPPET du script.
  6. Cliquez de nouveau sur Masqué Un œil barré par une ligne en diagonale. pour masquer la liste des noms DE variables.

  7. Enregistrez votre script.

Supprimer les Données sensibles d'une Variable

Outre la configuration de la rédaction de variable, vous pouvez configurer votre script afin de supprimer les données sensibles d'une variable. Cela permet de garantir qu'elles ne persistent pas dans le script plus longtemps que nécessaire.

  1. Dans votre script, placez une action Extrait après que les données sensibles ont été utilisées et ne sont plus nécessaires.
  2. In the Snippet editor of the Snippet action, add the appropriate line for each variable you want to clear sensitive data from: 
    • Pour un objet de données dynamiques : DYNAMIC <object name>
    • Pour une variable ordinaire : ASSIGN <var name> = ""
  3. Enregistrez vos modifications.

Désactivation d’un script

Autorisations requises : ACD > Studio > Scripts > désactiver

Les scripts ne peuvent pas être supprimés de Studio. Vous pouvez plutôt les désactiver. Les scripts désactivés ne sont plus visibles dans Studio, mais ils peuvent être vus sur la page Scripts de l'application ACD NiCE CXone.

Vous n'avez pas besoin de désactiver un script pour empêcher NiCE CXone de l'utiliser. NiCE CXone utilise uniquement les scripts qui sont assignés à une compétenceClosed Utilisé pour automatiser la livraison des interactions en fonction des compétences, des aptitudes et des connaissances de l’agent. et à un point de contactClosed point d’entrée qu’un contact entrant utilise pour amorcer une interaction, comme un numéro de téléphone ou une adresse courriel..

  1. Dans l'onglet Parcourir de Studio, localisez le script que vous voulez désactiver.
  2. Sélectionnez le script et cliquez sur l'icône rouge X A large red X. Click to deactivate a script. en haut de l'onglet.
  3. Confirmez que vous voulez désactiver le script sélectionné.
  4. You can add notes to the script to explain why you deactivated the script:
    1. Dans NiCE CXone, cliquez sur le sélecteur d'application et sélectionnez ACD > Scripts.
    2. Sélectionnez Inactif dans la liste déroulante Afficher.
    3. Cliquez sur le script et ajoutez vos notes dans l'onglet Notes.

Réactivation d’un script

Autorisations requises : ACD > Studio > Scripts > désactiver

You can reactivate a script to make it visible in Studio again.

  1. Dans NiCE CXone, cliquez sur le sélecteur d'application et sélectionnez ACD > Scripts.
  2. Sélectionnez Inactif dans la liste déroulante Afficher.
  3. Cliquez sur le script que vous voulez réactiver.
  4. Cliquez sur Activer dans l’onglet Détails de la page du script.

Retour à la version précédente du script

Studio conserve les versions précédentes de tous les scripts. À chaque fois que vous enregistrez vos modifications, une autre version est ajoutée à l'historique du fichier de script. Vous pouvez revenir à une version précédente d'un fichier de script.

Si vous avez enregistré une copie d'un script sous un autre nom et que vous souhaitez revenir en arrière, ne suivez pas ces étapes. Au lieu de cela, ouvrez la copie sur laquelle vous voulez revenir et utilisez Enregistrer sous pour créer une nouvelle copie. Vous pouvez désactiver les copies de Scripts dont vous n'avez plus besoin, ou vous pouvez les déplacer dans un dossier distinct.

Revenir à une version précédente d'un script dans Studio

Autorisations requises : Scripts studio Créer/Modifier

  1. Dans l'onglet Parcourir de Studio, localisez le script que vous voulez revenir à une version précédente.
  2. Cliquez dessus avec le bouton droit de la souris et sélectionnez Historique, puis cliquez sur la version à laquelle vous souhaitez revenir. La version sélectionnée s'ouvre ; la date et l'heure de son enregistrement sont ajoutées à la fin de son nom. Par exemple, le nom d’un script qui a été enregistré le 2 Août 2022 à 9:32:08 se termine par 08022093208.
  3. Cliquez sur Fichier > Enregistrer sous et enregistrez une copie du fichier sous un nouveau nom. Les versions historiques des fichiers script s'ouvrent en mode lecture seule permanent.

Revenir à une version précédente d'un script à partir de NiCE CXone

Studio conserve les versions précédentes de tous les scripts. À chaque fois que vous enregistrez vos modifications, une autre version est ajoutée à l'historique du fichier de script. Vous pouvez revenir à une version précédente d'un fichier de script.

If you have saved a copy of a script under a different name as a backup and want to revert back to it, don't follow these steps. Instead, open the backup copy you want to revert to. You can work in the backup copy, or you can duplicate it to create a new working copy and leave the backup in place. You can deactivate copies of scripts that you don't want anymore.

Retour à une version précédente d’un script dans Studio

Autorisations requises : ACD > Studio > Scripts > Créer/Modifier

Vous devez fermer le script dans Studio avant de le rétablir. Si le script est ouvert, vous ne verrez pas les modifications, à moins que vous ne fermiez et rouvriez le script. Si vous laissez le script ouvert lorsque vous le rétablissez, puis apportez des modifications et enregistrez le script sans le fermer et le rouvrir, vous écrasez le rétablissement et vous devrez le rétablir à nouveau.

  1. Dans l'onglet Parcourir de Studio, localisez le script que vous souhaitez faire revenir à une version précédente.
  2. Cliquez dessus avec le bouton droit de la souris et sélectionnez Historique, puis cliquez sur la version à laquelle vous souhaitez revenir. La version sélectionnée s'ouvre ; la date et l'heure de son enregistrement sont ajoutées à la fin de son nom. Par exemple, le nom d’un script qui a été enregistré le 2 Août 2022 à 9:32:08 se termine par 08022093208.
  3. Cliquez sur Fichier > Enregistrer sous et enregistrez une copie du fichier sous un nouveau nom. Les versions antérieures des fichiers script s'ouvrent en mode en lecture seule permanent.

Revenir à une version précédente d'un script à partir de NiCE CXone

Autorisations requises : ACD > Paramètres du contact > Scripts > Modifier

Lorsque des scripts sont rétablis à partir de NiCE CXone, le nom du fichier ne change pas, comme c'est le cas lorsque vous faites un rétablissement à partir de Studio.

Vous devez fermer le script dans Studio avant de le rétablir. Si le script est ouvert, vous ne verrez pas les modifications, à moins que vous ne fermiez et rouvriez le script. Si vous laissez le script ouvert lorsque vous le rétablissez, puis apportez des modifications et enregistrez le script sans le fermer et le rouvrir, vous écrasez le rétablissement et vous devrez le rétablir à nouveau.

  1. Dans NiCE CXone, cliquez sur le sélecteur d'application et sélectionnez ACD > Scripts.
  2. Click the script you want to revert. If the script you want to revert is currently deactivated, you must reactivate it first.
  3. Dans l'onglet Historique des versions, sélectionnez la version vers laquelle vous souhaitez revenir dans la liste Previous Versions et cliquez sur Revert Back.

  4. Dans Studio, ouvrez le script que vous avez rétabli et continuez à travailler dessus.

Chargement de Fichiers dans Studio

Vous pouvez charger des fichiers dans NiCE CXone en utilisant Studio. Ceci comprend les fichiers audio pour les invites, les fichiers de grammaire ASRClosed Reconnaissance automatique de la Parole. Permet aux contacts de répondre aux invites en parlant, en appuyant sur des touches du téléphone, ou les deux., et plus encore. page Parcourir les fichiers ACD dans NiCE CXone.

  1. Dans l'onglet Fichiers de Studio, développez le dossier dans lequel vous souhaitez charger le fichier. Si vous chargez un Prompt, développez le dossier Invites.

  2. Cliquez sur Charger le(s) fichier(s) A rectangle with an up-pointing arrow in it. et sélectionnez un ou plusieurs fichiers à charger, puis cliquez sur Open. Le fichier est chargé et s’affiche dans la liste de l'onglet.

  3. Vous pouvez également faire glisser un fichier depuis l'explorateur de fichiers de votre ordinateur vers la fenêtre Fichiers dans Studio.