Travailler avec Scripts (Desktop Studio)

Cette page d'aide concerne Desktop Studio. Ces informations sont également disponibles pour Studio.

Cette page fournit des informations sur les tâches essentielles des scripts, telles que la création ou l'ouverture de scripts, l'ajout et la configuration d'actions, ainsi que le verrouillage ou le déverrouillage de scripts.

Créer un Nouveau script

Autorisations requises : Scripts studio Créer/Modifier

Si le verrouillage est activé pour Studio, votre nouveau script ne sera pas verrouillé jusqu'à ce que vous l'enregistriez.

  1. Dans Studio, cliquez sur Nouveau Une petite fenêtre de programme informatique avec un fichier devant elle et une étincelle. dans la barre d'outils.

  2. Sélectionnez le type de script que vous voulez créer dans la liste située à droite de la fenêtre. Si vous ne voyez pas les types de script sur le côté droit de la fenêtre, vérifiez que General Purpose Scripts est sélectionné sous Modèles disponibles.

  3. Cliquez sur OK. Un canevas de script vierge s'ouvre dans Studio.
  4. Cliquez sur enregistrer et donnez un nom à votre script. Choisissez le nom avec soin. Vous ne pouvez pas renommer les scripts une fois qu'ils ont été enregistrés.

Création d’un script à partir d’un Modèle

Autorisations requises : Scripts studio Créer/Modifier

Si le verrouillage est activé pour Studio, votre nouveau script ne sera pas verrouillé jusqu'à ce que vous l'enregistriez.

  1. Dans Studio, cliquez sur Nouveau Une petite fenêtre de programme informatique avec un fichier devant elle et une étincelle. dans la barre d'outils.

  2. Sélectionnez une catégorie de modèle sous Scripts spécialisés dans Modèles disponibles, puis cliquez sur le Modèle que vous voulez utiliser dans la liste de droite.

  3. Cliquez sur OK.
  4. Enregistrez le script. Choisissez le nom avec soin.Vous ne pouvez pas renommer les scripts une fois qu'ils ont été enregistrés.

Ouverture d’un script

Autorisations requises : Scripts studio Créer/Modifier

Vous pouvez ouvrir un script en procédant d’une des façons suivantes :

  • En cliquant sur File > Open, en sélectionnant un script, puis en cliquant sur Select.
  • En cliquant sur Ouvert An open manila file folder with an arrow moving out of it. dans la barre d'outils, en sélectionnant un script, puis en cliquant sur Sélectionner.
  • Recherchez un script dans l'onglet Recherche, puis double-cliquez sur celui que vous voulez ouvrir.
  • Utilisez l'onglet Parcourir pour localiser un script et double-cliquez sur celui que vous voulez ouvrir.

Ne modifiez jamais un script de production directement. Les modifications enregistrées entrent en vigueur immédiatement. Si une modification entraîne un problème avec un script, cela peut avoir un impact sur le bon fonctionnement de votre centre de contact. Si vous devez apporter des modifications, utilisez Enregistrer sous pour créer une copie du script et donnez-lui un nom pour indiquer qu'il est en cours de développement. Uniquement le mettre en production lorsqu'il est entièrement testé et prêt.

Importer un script

Autorisations requises : Importer/Exporter des Scripts studio

Vous pouvez importer un script à partir d'un fichier XML.

  1. Dans Studio, cliquez sur Fichier > Importer à partir d'un fichier.
  2. Accédez à l'emplacement du script que vous souhaitez importer, sélectionnez-le et cliquez sur Ouvert.
  3. Cliquez sur enregistrer.
  4. Dans la fenêtre enregistrer le script sous, choisissez le dossier dans lequel enregistrer le script.
  5. Entrée un nouveau Nom du fichier pour le script si vous souhaitez le modifier. Les scripts ne peuvent pas être renommés après avoir été enregistrés.
  6. Cliquez sur enregistrer.

Exporter un script

Autorisations requises : Scripts studio Importer/Exporter

Vous pouvez exporter un script sous forme de fichier XML.

  1. Dans Studio, cliquez sur Fichier > Exporter vers un fichier.
  2. Accédez à l'emplacement sur votre ordinateur où vous souhaitez enregistrer le script exporté.
  3. Entrez un Nom de fichier pour le script et cliquez sur sauvegarder.

Ajout et configuration d’une Action dans un script

Autorisations requises : Scripts studio Créer/Modifier

Les actions sont les éléments constitutifs de tous les scripts. La plupart des actions ont un ensemble de propriétés qui doivent être configurées afin de définir le comportement de l'action pour le script spécifique que vous créez. Reportez-vous à l'aide en ligne de chaque action pour obtenir des informations sur les propriétés de l'action. Sélectionnez l'action sur le canevas de script et appuyez sur la touche F1 du clavier. La page d'aide se charge dans votre navigateur par défaut.

Cette section décrit l'ajout d'une action à partir de l'onglet Instruments. Si l'onglet Framework est activé dans Studio, vous pouvez ajouter des actions à partir de celui-ci.

  1. Dans Studio, créez ou ouvrez un script.
  2. Dans l'onglet Instruments, localisez l’action que vous voulez ajouter Vous pouvez trouver des actions en effectuant l’une des opérations suivantes :

    • Le fait de saisir du texte dans le champ Filtre permet de rechercher une action. Vous pouvez effectuer une recherche en utilisant un nom complet ou partiel. Par exemple, si vous saisissez ai, la recherche trouve toutes les actions dont le nom contient ces lettres n'importe où dans leur nom.
    • Cliquez sur Catégories pour basculer entre l'affichage des actions par catégorie ou sous la forme d'une seule longue liste.
    • Cliquez sur Alphabétique pour basculer entre l'affichage des actions par ordre alphabétique ou dans leur ordre par défaut.
  3. Cliquez sur l’action que vous voulez ajouter Il n’est pas nécessaire de cliquer et de maintenir.
  4. Cliquez sur le canevas de script pour placer l'action.
  5. Sélectionnez l'action, puis effectuez un clic droit pour afficher la fenêtre Properties . Vous pouvez également cliquer sur l'onglet Propriétés.

  6. Remplacez la propriété Légende par un mot descriptif ou une courte phrase qui indique ce que fait cette action dans le script. Par exemple, pour une action lecture, remplacez la légende par le nom du fichier audio qu'elle lit.
  7. Configurez les autres propriétés selon vos besoins. Vous pouvez configurer les propriétés en procédant comme suit :

    • Sélection d'une option : Cliquez sur l'icône de flèche vers le bas Un chevron pointant vers le bas. qui apparaît sur le côté droit du champ, puis sélectionnez une option dans la liste déroulante.
    • Utilisation de la fenêtre de l'Éditeur d'expression : Cliquez sur l'icône d'ellipse Des points de suspension ou un groupe de trois points sur une rangée. qui apparaît sur le côté droit du champ, puis entrez du texte dans la fenêtre de l'Éditeur d'expression.
    • Entrer du texte directement : cliquez dans le champ et entrez du texte directement. Certaines propriétés nécessitent du texte statique ou des variables, mais de nombreuses propriétés peuvent accepter les deux.
    • Double-clic sur l'action : certaines actions ont des paramètres de configuration supplémentaires auxquels vous pouvez accéder de cette façon.
  8. Enregistrez vos modifications dans le script.

Ajout d’une action à partir de l'onglet cadre

Autorisations requises : Scripts studio Créer/Modifier

L'onglet cadre contient une liste complète de toutes les actions disponibles dans Studio. Certaines des actions de cet onglet sont des actions système ou internes qui ne peuvent être utilisées qu'après avoir consulté un représentant de compte. Utilisez avec prudence les actions non familières de cet onglet.

L'onglet Framework n'est visible que si un représentant de compte l'a activé pour vous. En savoir plus sur l'onglet Framework et les actions qu'il contient.

  1. Dans Studio, créez ou ouvrez un script.
  2. Dans l'onglet cadre, développez les dossiers afin de localiser l’action que vous voulez ajouter
  3. Cliquez sur l'action et faites-la glisser vers le canevas de script.

Connexion d'Actions et création de Branches

Autorisations requises : Scripts studio Créer/Modifier

  1. Dans Studio, créez ou ouvrez un script.
  2. Ajoutez au moins deux actions sur le canveas.
  3. Placez le curseur sur la première action, puis cliquez sur la flèche An arrow pointing to the right right. dans le coin inférieur droit de l'icône de l'action et maintenez-la enfoncée pour démarrer un connecteur.
  4. Connectez la première action à la seconde en faisant glisser le curseur loin de l'action et en le déposant sur la seconde action. Si la première action dispose de plusieurs conditions de branchement disponibles, la fenêtre PickBranch s'affiche.

  5. Dans la fenêtre PickBranch , sélectionnez la condition de branche que vous souhaitez utiliser pour cette connexion. Dans la plupart des cas, si l'action se connecte à une seule autre action, vous devez utiliser la branche Par défaut . Pour plus d'informations sur chacune des conditions de branche d'une action, reportez-vous à l'aide en ligne de l'action. Vous pouvez sélectionner une Action et appuyer sur F1 sur votre clavier pour ouvrir sa page d'aide.

  6. Cliquez sur OK.
  7. Répétez les étapes 3 à 5 pour connecter d’autres actions. Si vous connectez une action à plus d'une autre action, utilisez une condition de branche différente pour chaque connexion. Vous devez toujours créer une branche qui utilise la condition de branche Par défaut . Cela donne au script une option à suivre si aucune des autres branches ne s'applique.
  8. Rearrange actions on the canvas if you need to make space for connections. Attached connectors move with an action. If you want to move more than one action at a time, you can: 
    • Cliquez sur le canevas et faites glisser le curseur pour dessiner une zone de sélection autour des actions que vous souhaitez déplacer. Les actions sélectionnées sont mises en évidence en rouge. Cliquez sur une des actions sélectionnées pour faire glisser le groupe vers un nouvel emplacement.
    • Appuyez sur CTRL et cliquez sur chaque action que vous souhaitez déplacer, puis cliquez sur l'une des actions sélectionnées et faites glisser le groupe vers un nouvel emplacement.
    • Click an action, then click Edit > Selection in the Studio menu bar. Choose an option based on what you want to happen, then drag the highlighted actions to a new location: 
      • Sélectionner tout ce qui se trouve au-dessus : Toutes les actions situées au-dessus de l'action sélectionnée sur toute la largeur du script sont mises en évidence.
      • Sélectionner tout ci-dessous : toutes les actions situées sous l'action sélectionnée sur toute la largeur du script sont mises en évidence.
      • Sélectionner tout ce qui se trouve à droite : toutes les actions à droite de l'action sélectionnée sur toute la hauteur du script sont mises en évidence.
      • Sélectionner tout ce qui se trouve à gauche : Toutes les actions situées à gauche de l'action sélectionnée sur toute la hauteur du script sont mises en évidence.
  9. Vérifiez que vous n'avez pas d'impasses, des endroits où le script est bloqué et n'a aucun moyen de se terminer ou de passer à l'action suivante. Vous pouvez procéder ainsi en tests le script.
  10. Enregistrez le script.

Création de conditions de branchement variables

Autorisations requises : Scripts studio Créer/Modifier

Les conditions personnalisées de branche Variable vous permettent de créer des conditions personnalisées qui doivent être remplies pour que le script Suive une branche particulière. Ceci est utile lors de la création de menus IVRClosed Réponse vocale interactive. Menu téléphonique automatisé que les contacts utilisent par la Voix ou par des touches pour obtenir des informations, acheminer un appel vocal entrant, ou les deux. . Vous pouvez créer une branche pour chaque option de menu et définir comme condition pour chacune d'elles le numéro que le contact doit saisir pour sélectionner cette option.

  1. Dans Studio, créez ou ouvrez un script.
  2. Ajoutez au moins deux actions sur le canveas.
  3. Placez le curseur sur la première action, puis cliquez sur la flèche An arrow pointing to the right right. dans le coin inférieur droit de l'icône de l'action et maintenez-la enfoncée pour démarrer un connecteur.
  4. Connectez la première action à la seconde en faisant glisser le curseur loin de l'action, puis en le déposant sur la seconde action. La fenêtre PickBranch s'affiche.

  5. Cliquez sur l'icône + dans la fenêtre PickBranch .

  6. Dans le champ qui apparaît sous Variable Branch Condit, entrez le nom de la condition que vous créez. Par exemple, pour créer un menu option pour le cas où le contact appuie sur 3, entrez 3 dans le champ.
  7. Cliquez sur OK. Sur le canevas, le nom du rectangle de variable apparaît dans un rectangle en haut du connecteur. Vous pouvez en voir un exemple sur l’image suivante.

Suppression d'un Connecteur

Autorisations requises : Scripts studio Créer/Modifier

  1. Dans Studio, cliquez sur la flèche dans le connecteur que vous souhaitez supprimer.
  2. Appuyez sur la touche Delete du clavier ou cliquez sur Modifier > supprimer.

Modifier la forme d'un Connecteur

Autorisations requises : Scripts studio Créer/Modifier

Vous pouvez plier et courber les connecteurs pour qu'ils s'adaptent mieux à votre script. Cela peut vous aider à garder vos scripts en ordre et plus faciles à lire.

  1. Dans Studio, ouvrez un script.
  2. Maintenez les touches CTRL + Maj du clavier enfoncées et placez le curseur sur le connecteur dont vous voulez modifier la forme, jusqu'à ce que la ligne devienne bleue.

  3. Pendant que la ligne est encore bleue, effectuez un clic droit sur le connecteur. Un petit carré bleu apparaît. Il s’agit d’un point d'ancrage.

  4. Cliquez et maintenez le point d'ancrage, puis faites-le glisser dans n'importe quelle direction jusqu'à ce que le connecteur ait la forme souhaitée.

  5. Vous pouvez répéter les étapes 2-4 sur le même connecteur pour ajouter d'autres points d'ancrage si vous voulez ajouter d'autres courbes au connecteur.

  6. Cliquez sur la flèche du connecteur pour voir tous les points d'ancrage sur la ligne.
  7. Vous pouvez supprimer un seul point d'ancrage en appuyant sur les touches CTRL + Maj puis en faisant un clic droit sur le point d'ancrage que vous voulez supprimer. Le point d'ancrage disparaît et la courbe de la ligne du connecteur s'ajuste automatiquement.
  8. Si vous souhaitez supprimer l'ensemble du connecteur, cliquez dans la flèche du connecteur pour qu'elle devienne rouge. Appuyez sur supprimer.

Verrouillage et déverrouillage de scripts

Autorisations requises : Scripts studio Voir, Créer/Modifier

If le verrouillage est activé pour les scripts Studio, vous pouvez verrouiller et déverrouiller les scripts sur lesquels vous travaillez. Les scripts déverrouillés sont en lecture seule. Pour modifier un script, vous devez le verrouiller. Cela vous permet de travailler sur celui-ci, mais empêche les autres utilisateurs d'y enregistrer des modifications.

Si vous tentez d'ouvrir un script qui est verrouillé par un autre utilisateur, Studio vous informe que le script est verrouillé. Vous pouvez remplacer un script verrouillé si votre NiCE CXone profil employé dispose de l'autorisation appropriée.

Selon la configuration de Studio, les scripts s'ouvrent par défaut soit en mode verrouillé, soit en mode en lecture seule. Lorsque vous créez un nouveau script, il n'est ni verrouillé ni déverrouillé. Lorsque vous enregistrez le script, celui-ci est automatiquement verrouillé, même si le comportement par défaut pour Studio est défini pour ouvrir les scripts en lecture seule.

  1. Dans Studio, ouvrez un script. Si le verrouillage est activé, le script s'ouvre soit en mode en lecture seule (déverrouillé), soit en mode verrouillé, selon la configuration de Studio. Si le verrouillage n'est pas activé, le script s'ouvre sur un canevas blanc et l'icône de l'onglet du script ne se transforme pas en verrou.
  2. Pour verrouiller un script afin de pouvoir le modifier, cliquez sur l'icône de verrouillage dans la barre d'outils. Le canevas passe du gris au blanc et l'icône de l'onglet script se transforme en verrou.
  3. Pour déverrouiller un script et le mettre en mode lecture seule, cliquez sur l'icône de déverrouillage dans la barre d'outils. Le canevas passe du blanc au gris et l'icône de l'onglet script devient l'icône pour le type de script.

Contournement d’un script verrouillé

Autorisations requises : Scripts studio Déverrouiller

Lorsque vous ouvrez un script qui est verrouillé par un autre utilisateur, Studio affiche une notification. Vous pouvez contourner le verrouillage d'un script si vous avez besoin de le modifier. Lorsque vous remplacez un verrou de script, les modifications sauvegardées de l'autre utilisateur sont conservées. Studio affiche une notification à l'utilisateur la prochaine fois qu'il se connecte. Cette notification peut les inviter à examiner les modifications apportées au script. Vous pouvez examiner les modifications en visualisant une version antérieure du script, ou en ouvrant une version antérieure du script et en la comparant à la version actuelle.

  1. Dans Studio, cliquez sur l’onglet Verrouillé.
  2. Sélectionnez le script que vous souhaitez remplacer, puis cliquez sur Kick .
  3. Cliquez sur OK lorsque vous êtes invité à confirmer que vous voulez empêcher l'autre utilisateur de modifier le script.