Studio Interface utilisateur

Cette page concerne Desktop Studio. Vous pouvez en savoir plus sur l'interface Studio sur la Page d'aide Démarrer avec Studio.

La Studio interface utilisateur se compose d'un canevas au centre, entouré d'un certain nombre d'onglets à gauche, à droite et en bas. Ces onglets permettent d'accéder à Studio actionsClosed Exécute un processus dans un script Studio, comme la collecte de données clients ou la lecture de musique. ainsi qu'à des informations sur les actions et votre script.

Studio Barre de Menu

Le menu principal contient sept menus déroulants : Fichier, Édition, Affichage, validation, Déboguer, Fenêtre et Aide. De nombreux éléments DE menu sont des commandes courantes telles que l'enregistrement d'un fichier ou l'annulation d'une modification. Les commandes courantes ne sont pas décrites dans cette rubrique.

Menu Fichier

Outre les commandes courantes d'un menu Fichier générique, telles que Nouveau, Ouvrir, enregistrer et Quitter, lesStudio Le menu Fichier contient ces options supplémentaires :

Menu Option Détails
Importer/Exporter

Permet d'importer un script à partir d'un fichier XML dansStudio, ou exportez un script vers un fichier XML.

Récent

Fournit la liste des scripts que vous avez récemment ouverts dans Studio pour l'locataireClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone. auquel vous êtes connecté. Cliquez sur un script répertorié pour l'ouvrir dans un nouveauToile panneau.

Déconnexion et quitter Sélectionnez cette option pour vous déconnecter de Studio et fermer l'application. Studio se souvient de votre connexion même après la fermeture de l'application. Si vous devez vous déconnecter complètement, utilisez cette option.

Modifier le menu

Le menu Édition contient les commandes courantes des menus Édition, notamment Annuler, Couper, Copier et Coller. Vous pouvez utiliser ces options avec Studio actionsClosed Exécute un processus dans un script Studio, comme la collecte de données clients ou la lecture de musique. sur le canevas. Les raccourcis clavier par défaut fonctionnent pour ces commandes (Ctrl+Z, Ctrl+X, Ctrl+C et Ctrl+V). LaStudio Le menu Edition comprend également ces options :

Menu Option Détails
Copier le script en tant qu'image

Copie le script actuel dans votre presse-papiers sous forme d'image. Vous pouvez coller l'image à un autre emplacement, tel qu'un e-mail ou un document texte.

Trouver

Ouvre la fenêtre Rechercher dans le script, où vous pouvez rechercher du texte spécifique dans tous les scripts que vous avez ouverts ou uniquement dans le script ouvert dans l'onglet Canvas supérieur.

Aller à

Srecherchepour et accédez immédiatement à un ID d'action dans le script en cours. Vous pouvez consulter les id d’action dans le champ ID de l’onglet Actions.

Comparer Vous permet de comparer deux scripts par légendes, paramètres, Branches ou Position. Par exemple, une paire de scripts peut contenir exactement les mêmes actions et branches, mais peut contenir des paramètres différents. En comparant les 2 scripts, vous pouvez voir les différences (et les similitudes) dans leOnglet Rechercher les Résultats.

Afficher le menu

Le menu Affichage propose les options suivantes :

Menu Option Détails
Aide > Informations sur l’agent Afficher les informations sur leNiCE CXone compte auquel vous êtes actuellement connectéStudio avec. Des Informations apparaissent sur leOnglet Propriétés.
Aide > Infos de Connexion Afficher des informations sur votre session en cours dansStudio.

Navigateur,
Outils,
Propriétés,
Bibliothèque,
Fichiers,
Navigation,
Recherche,
Framework,
Trouver des résultats

Cliquez sur le nom de l'onglet pour ouvrir cet onglet dansStudio. Ceci est utile lorsque vous avez fermé un onglet et que vous devez le rouvrir.

Si vous devez rouvrir les onglets Erreurs de script, Actions, variables ou Dépendances, consultez leMenu validation.

Toolbars > Trace Cliquez pour basculer si vous souhaitez afficher leTrace option dans la barre d'outils.

Menu validation

Menu Option Détails
Windows

Cliquez pour ouvrir l'un de ces onglets : Erreurs de script, Actions, variables et Dépendances.

Si vous avez besoin d'ouvrir des onglets qui ne figurent pas dans cette liste, consultez leafficher le menu.

Vérification de la syntaxe

Vérifie un script actif pour détecter les erreurs de connexion et de propriété, et affiche des avertissements dans l'onglet erreurs de script. Il s'agit d'une méthode de base pour tester et déboguer votre script.

Menu déboguer

Autorisations requises : ACD > Studio > Scripts > Déboguer

Menu Option Détails
Script capturer

Capturer un script pour tracer et documenter son progrès pendant son exécution. Vous pouvez choisir de capturer l'Instance suivante uniquement ou de capturer en Continu pendant son exécution. Lorsque chaque action du script se déclenche, les informations résultantes apparaissent dans le Outil de Sortie de trace. Si vous capturez un script en continu, les fichiers de trace sont enregistrés sur leNiCE CXone Serveur multimédia. Vous pouvez utiliser Debug > Load Remote Trace File pour afficher ces fichiers de trace.

Démarrer avec Trace

Lance le script actif et ouvre la fenêtre Sortie de trace afin d'afficher les résultats de l'exécution du script. Vous pouvez également démarrer une trace à partir de la barre d'outils à l'aide du bouton Start with Trace .

Charger le fichier de trace de Déboguer

Recherchez un fichier de trace et ouvrez-le dans la fenêtre Sortie de trace.

Charger le fichier de trace Distant

Recherchez un fichier de trace sur la plate-forme NiCE CXone et ouvrez-le dans la fenêtre Sortie de trace.

Menu Fenêtre

Le menu Fenêtre vous permet de naviguer entre les scripts ouverts dansStudio. Sélectionner un script dans ce menu le fait passer au premier plan en tant qu'onglet actif. Si vous n'avez qu'un seul script ouvert, il n'y a qu'une seule option dans ce menu.

Menu d'aide

Le menu Aide fournit des options pour accéder auStudio l'aide en ligne, ainsi que d'autres informations pouvant vous aider àStudio.

Menu Option Détails
NiCE CXoneStudio Documentation

Ouvre un nouvel onglet de votre navigateur Web par défaut et charge la page vue d’ensemble de Studio de l’aide en ligne.

Aide contextuelle F1

Affiche la rubrique d'aide en ligne pour l'action actuellement sélectionnée sur le canevas. Vous pouvez également appuyer surF1 sur votre clavier pour accéder à la rubrique d'aide de l'action sélectionnée. Les rubriques d'aide se chargent dans un nouvel onglet de votre navigateur Web par défaut.

Configuration de l'unité commerciale

Affiche des informations sur la façon dont votrelocataire est configuré. Il peut être nécessaire de consulter ces informations en cas d'incertitude quant aux applications ou fonctionnalités activées, telles que les types DE canal.

Dépannage > Télécharger manuellement le programme CefSharp Démarre un nouveau téléchargement de CefSharp, un plug-in dont Studio a besoin pour s'exécuter.
Dépannage > Clear Cache EffaceStudio's cache, ce qui peut être utile si l'application ne fonctionne pas comme prévu.
À propos de

Affiche des informations de base surStudio, comme la version.

Barre d'outils Studio

La barre d'outils offre un mélange de commandes génériques, telles que l'ouverture ou l'enregistrement d'un script, etStudio-commandes spécifiques.

Option Toolbar Détails
Augmenter/Réduire l'Espace

Cliquez pour augmenter ou diminuer l'espace entre les actions sur le canevas. Chaque clic modifie légèrement la quantité d'espace.

Démarrer avec Trace Vous permet de lancer un traçage.
Tracer le script

Le fait de tracer un script lance le script actif et ouvre la fenêtre Sortie de la trace afin d'afficher les résultats de l'exécution du script. La barre d'outils propose 3 commandes liées au traçage d'un script : démarrer la trace, sélectionner un ANIClosed Aussi connu sous le nom d’id de l’appelant. numéro de téléphone listé d’un appel entrant, ou d’un appel vocal entrant. ou un DNISClosed Le numéro composé lors des appels vocaux entrants ou sortants. avec lequel tracer le script, ou les options permettant de tracer et de capturer l'instance suivante exécutée par le script ou de tracer et de capturer en continu chaque instance du script à mesure qu'il s'exécute (pertinent pour les scripts de production). Consultez la Page Débogage de scripts dans Desktop Studio pour plus d'informations.

Verrouiller/Déverrouiller les Scripts

Cliquez pour verrouiller ou déverrouiller un script. Le verrouillage place un script en mode en lecture seule. son déverrouillage permet de le modifier, mais aucun autre utilisateur Studio ne peut le modifier au même moment. D’autres utilisateurs peuvent modifier le script lorsque vous l’avez déverrouillé ou que vous l’enregistrez et le fermez.

Lorsqu'un script est verrouillé, l'arrière-plan du canevas apparaît en blanc et l'icône du script sur l'onglet est un cadenas verrouillé. Lorsqu'un script est déverrouillé, l'arrière-plan du canevas apparaît en gris et l'icône apparaît comme l'icône de type de script.

Cette option n’apparaît dans Studio que si le verrouillage de script est activé. Votre administrateur NiCE CXone doit activer cette option.

Si vous disposez de l'autorisation Scripts Contournement du verrou, vous pouvez forcer l'annulation du verrouillage d'un autre utilisateur sur un script afin de pouvoir le modifier. Vous pouvez afficher tous les scripts verrouillés de votre LocataireClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone. dans l'onglet Verrouillé.

Studio Toile

La toile est le grand espace au centre de laStudio interface. C'est là que vous créez un script. Vous pouvez faire glisser actions depuis les onglets Outils ou Framework sur le canevas. Les scripts s'ouvrent en tant que nouveaux onglets de canevas, tout comme un navigateur Web.

Sur la toile, vous pouvez :

  • Cliquez sur les onglets ou utilisez le menu Fenêtre pour basculer entre les scripts ouverts.
  • Fermez un onglet de script en cliquant sur leXsur la toile. Le X n'est pas sur l'onglet du script, comme c'est le cas dans certains navigateurs Web. Il se situe dans le coin supérieur droit de la fenêtre du canevas.
  • Si vous cliquez dans l'espace blanc du canevas puis sélectionnez l'onglet Propriétés, vous pouvez accéder aux propriétés du script.
  • Si vous fermez tous les onglets de script, vous pouvez remplacer le canevas parcréation d'un nouveau script.

Studio Onglets

Les onglets permettent d'accéder à de nombreuses informations différentes dont vous avez besoin lorsque vous travaillez dansStudio. Par défaut, les onglets sont divisés en trois groupes. Les groupes sont situés à gauche, à droite et en bas du canevas. Tous les onglets sont visibles par défaut. Si vous fermez un onglet, vous pouvez le rouvrir en utilisant soit le menu Affichage, soit le menu validation > Windows. Voir l'image en haut de cette Page pour un guide visuel de la disposition par défaut.

Groupes d'onglets par défaut

Les groupes d'onglets par défaut sont les groupes suivants :

  • Left side: These tabs are located on the left side of the Studio window by default:
    • Naviguer
    • Dépendances
    • Variables
    • Actions
  • Right side: These tabs are located on the right side of the Studio window by default: 
    • Framework
    • Outils
    • Bibliothèque
    • Parcourir
    • Propriétés
  • Bottom: These tabs are located at the bottom of the Studio window by default: 
    • Trouver des résultats
    • Fichiers
    • Erreurs de script
    • Search

Réorganiser les onglets

L'emplacement des onglets est personnalisable. Tu peux:

  • Faire glisser et déposer des onglets les uns sur les autres pour les déplacer vers d'autres emplacements dans Studio. Si vous saisissez la barre de titre d'un onglet, toute la pile d'onglets se déplace. Si vous souhaitez déplacer un seul onglet, saisissez l'autre extrémité de l'onglet (la partie qui ressemble en fait à un onglet).
  • Épinglez un groupe d'onglets au bord de la fenêtre de l'interface en cliquant sur l'icône d'épinglage dans le coin supérieur droit de l'onglet. Lorsque vous cliquez sur un onglet épinglé, il glisse pour que vous puissiez l'utiliser. Lorsque vous cliquez en dehors de celui-ci, il se réduit au bord épinglé.

  • Utilisez les zones d’ancrage pour placer les onglets. Lorsque vous cliquez sur la barre de titre d'un onglet et que vous le faites glisser hors de son emplacement actuel, l'interface Studio affiche des icônes de Zone d'abandon pour tous les endroits où vous pouvez ancrer l'onglet. Passez le curseur sur une zone d’ancrage et relâchez le bouton de la souris.

Onglet Actions

L'onglet Actions affiche une liste de toutes les actions actuellement dans le script. Les actions sont répertoriées dans l'ordre dans lequel elles ont été ajoutées au script. Cet onglet affiche les informations suivantes sur chaque action :

  • Légende : il s'agit du texte qui apparaît sous l'icône d'action sur le canevas. Par défaut, la légende est identique au nom de l'action. Vous pouvez modifier la légende de n'importe quelle Action dans l'Action propriétés. C'est un moyen utile de noter ce que l'action accomplit dans le script. Par exemple, pour chaqueFragmentaction, vous pouvez modifier la légende pour indiquer ce que cette instance de Fragmentfait dans le script.

  • Nom de l'outil : le nom de l'Action. Ce nom ne peut pas être modifié.
  • ID : l’id d’action attribué à l’action en fonction de l’ordre dans lequel elle a été ajoutée au canevas. Chaque instance d'une action dans un script donné a un numéro unique.

Onglet Parcourir

L'onglet Browse affiche les dossiers Studio, où vous stockez tous les scripts que vous créez pour cette locataire. Tu peux:

  • Ouvrez les scripts à partir de cet onglet en double-cliquant sur un script. Il s'ouvre dans un onglet de canevas.
  • Afficher l'historique du script en cliquant avec le bouton droit sur un script et en passant votre curseur dessusHistoire.
  • Ouvrez une ancienne version d'un script en cliquant sur la version que vous souhaitez voir dans la liste Historique.
  • Revenir à une version précédente d'un script en ouvrant la version précédente du script et en cliquant surEnregistrer sous, puis en choisissant le script dans la liste.

La Scripts page dans l'application NiCE CXone ACD vous permet également de revenir à une version antérieure d'un script si vous disposez des autorisations appropriées.

Onglet dépendances

Affiche les relations entre les actions dans le script actif.

Onglet fichiers

Autorisations requises : ACD > Studio > Explorateur de fichiers > afficher

L'onglet Fichiers contient tous les enregistrements d'invites vocales utilisés dans les scripts. Ces fichiers sont stockés dans votrelocataire. Vous pouvez voir des informations de base sur le fichier d'invite (date de dernière modification, objectif, description et durée du fichier lors de la lecture). You can charger de nouvelles invites à partir de cet onglet.

Onglet trouver des résultats

Affiche les résultats de la comparaison effectuée avec l'option Modifier > Comparer.

Onglet Framework

Contient une liste complète de tousStudio Actions.

Comme certaines des actions de cet onglet sont plus avancées, elles ne sont pas mises à la disposition de tous les utilisateurs par défaut. Si vous ne voyez pas l'onglet dans Desktop Studio, il n'a pas été activé pour votre unité commercialeClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone.. Si votre organisation a un besoin qui peut être satisfait en utilisant une action Framework, votre représentant de compte peut activer l'onglet Framework dans votre unité commerciale.

Si vous avez accès à l’onglet cadre, faites preuve de prudence si vous utilisez des actions non familières. De nombreuses actions ne sont pas documentées dans l’aide en ligne. Vous pouvez interroger votre représentant de compte ou soumettre une question à la NiCE CXone communauté client pour en savoir plus sur le fonctionnement d'une Action.

Vous pouvez en savoir plus sur les actions disponibles sous cet onglet sur la page d'aide Actions de cadre.

Onglet verrouillé

Autorisations requises : ACD > Studio > Scripts > Remplacement du verrouillage

Affiche une liste des scripts qui ont été verrouillés. Si votre compte d’utilisateur NiCE CXone possède l’autorisation Déverrouiller, vous pouvez remplacer un verrou de script. Déverrouillez un script en cliquant avec le bouton droit sur le script et en sélectionnant Kick <user> from editing script ou en cliquant sur le bouton Kick (indiqué par une flèche rouge).

Onglet Naviguer

Vous permet de naviguer rapidement dans des scripts plus volumineux sans utiliser les barres de défilement. La boîte rouge affiche ce que vous pouvez voir sur la toile.

Onglet propriétés

L'onglet Propriétés affiche des informations sur l'action actuellement sélectionnée. Si aucune action n'est sélectionnée, cet onglet affiche des informations sur l'ensemble du script.

Chaque action possède un ensemble unique de variables, de branches et de paramètres. Vous pouvez les configurer dans les propriétés de l'action pour définir comment vous souhaitez que l'action fonctionne dans le script. Vous pouvez également afficher les propriétés de l'action en cliquant avec le bouton droit sur l'action et en sélectionnantPropriétés.

Les propriétés du script vous permettent de simuler un appel entrant pour tester le script. Vous pouvez également masquer une ou plusieurs variables dans le script.

Erreurs de script

L'onglet Erreurs de script affiche les avertissements et les erreurs liés à votre script. L'onglet n'affiche rien jusqu'à ce que vous enregistriez le script ou que vous exécutiez une vérification de la syntaxe. Les Avertissements n'empêchent pas le script de s'exécuter ou de s'enregistrer, mais les erreurs si.

Onglet Recherche

Permet de rechercher un script spécifique. Vous pouvez affiner votre recherche en utilisant un nom du script partiel, une unité commerciale, les anciennes et nouvelles versions, ainsi que des types de script.

Onglet Outils

Affiche les actions les plus couramment utilisées. Cliquez sur l'icône des catégories pour modifier la manière dont les actions sont organisées. Vous pouvez les afficher par catégories ou par ordre alphabétique. Lorsque les actions sont triées par ordre alphabétique, vous pouvez cliquer sur l'icône de tri pour inverser l'ordre de la liste.

The grouping of default categories is called a palette. You can create your own categories and palettes by clicking the palette icon in the upper right corner of the Tools tab. The default palette contains these categories: 

Catégorie Description
Standard Actions de base et générales utilisées dans tout type de script.
Voix supplémentaire Actions courantes utilisées pour les scripts de type DE support voix.
Advanced Actions avancées généralement utilisées par les développeurs de script expérimentés.
Accès aux données Actions liées à l'accès aux données d'inData ou de bases de données clients.
Système Actions utilisées pour le stockage et la manipulation de fichiers.
Événements Actions déclenchées parNiCE CXone.
la toile Actions utilisées par les scripts système. Les scripts Système sont des scripts par défaut quiNiCE CXone utilise en interne.
Parole Actions liées à la reconnaissance automatique de la Parole (ASRClosed Reconnaissance automatique de la Parole. Permet aux contacts de répondre aux invites en parlant, en appuyant sur des touches du téléphone, ou les deux.).
WFO Actions liées àEngagement de la main-d'œuvre (WEM).
Connexion personnelle Actions liées àNiCE CXonePersonal Connection.
NiCE CXoneAuthentification personnalisée Actions liées à l'authentification du client.
Automatisation et AI Actions liées à l'automatisation de AI, telles que assistants d'agentClosed Application logicielle qui fournit une aide contextuelle à l'agent. et robots agents virtuelsClosed Une application logicielle qui traite les interactions avec les clients à la place d’un agent humain en direct..

Onglet variables

Affiche les variables disponibles dans le script actif et les actions qui font référence à chacune.

Raccourcis clavier

Studio utilise de nombreux raccourcis clavier couramment connus, tels que CTRL + C pour copier quelque chose, mais propose également de nombreux autres raccourcis pour optimiser votre flux de travail.

Raccourci Action
CTRL + A Sélectionne toutes les icônes d'action dans le script actif.
CTRL + C Exécute la fonction de copie standard de Windows.
CTRL + E Ouvre la fenêtre Exporter vers un fichier
CTRL + F Ouvre la boîte de dialogue Rechercher dans le script.
CTRL + G Va à un élément d'action de script spécifique (c'est-à-dire sélectionne une icône d'action dans le script actif en fonction de l'ID que vous entrez).
CTRL + I Ouvre la fenêtre Importer depuis un fichier...
CTRL + N Ouvre la fenêtre Créer un Nouveau script.
CTRL + O Ouvre la fenêtre Ouvrir le script depuis....
CTRL + S Enregistre les modifications dans le script actif uniquement.
CTRL + MAJ + S Enregistre les modifications apportées à tous les scripts ouverts.
CTRL + T Capture une trace de script pour l'occurrence suivante uniquement.
CTRL + MAJ + T Démarre une trace de script continue qui s'exécute jusqu'à ce qu'elle soit terminée manuellement.
CTRL + V Exécute la fonction "coller" standard de Windows.
CTRL + X Exécute la fonction Windows « couper » standard.
CTRL + Y Rétablit le script à son état antérieur à une "annulation".
CTRL + Z Exécute la fonction "annuler" de Windows (c'est-à-dire, renvoie le script à son état antérieur à votre dernière modification).
Del ou supprimer Supprime l'élément sélectionné.
F1 Lance l'aide en ligne pour une action sélectionnée.
CTRL + F2 Ouvre l'onglet Parcourir.
CTRL + MAJ + F2 Ouvre l'onglet cadre.
CTRL + F3 Ouvre l'onglet Outils.
CTRL + MAJ + F3 Ouvre l'onglet Résultats de la recherche (voir la boîte de dialogue Rechercher dans le script).
CTRL + F4 Ouvre l'onglet Propriétés.
CTRL + MAJ + F4 Ouvre l'onglet Verrouillé.
F5 Ouvre la fenêtre Sortie de trace.
CTRL + F6 Ouvre l'onglet Fichiers.
MAJ + F6 Vérifie la syntaxe du script actif et ouvre l'onglet Erreurs de script.
CTRL + F7 Ouvre l'onglet Naviguer.
CTRL + F9 Ouvre l'onglet Rechercher.