Gérer les invites (Desktop Studio)

Cette page d'aide concerne Desktop Studio. Ces informations sont également disponibles pour Studio.

Une invite est un message qui est lu au contact. Les Invites peuvent demander au contact d’entrer des informations ou fournir des informations sans demander d’entrée. Les Invites peuvent être lues par les standards automatiques, la réponse vocale interactive (RVIClosed Réponse vocale interactive. Menu téléphonique automatisé que les contacts utilisent par la Voix ou par des touches pour obtenir des informations, acheminer un appel vocal entrant, ou les deux.) et d'autres outils de traitement de la voix. Dans NiCE CXone, les invites peuvent être des fichiers audio préenregistrés ou du texte lu par un service de synthèse vocale (TTSClosed Permet aux utilisateurs d’entrer des invites enregistrées sous forme de texte et d’utiliser une voix générée par ordinateur pour prononcer le contenu.).

Création d’une invite TTS

Autorisations requises : ACD > Studio > Scripts > Créer/Modifier , ACD > Studio > enregistrer les Invites > Activé (pour enregistrer un fichier audio dans Studio)

Vous pouvez ajouter une invite TTSClosed Permet aux utilisateurs d’entrer des invites enregistrées sous forme de texte et d’utiliser une voix générée par ordinateur pour prononcer le contenu. en utilisant l'éditeur de séquence ou en saisissant l'invite directement dans la propriété Séquence d'une action Studio qui prend en charge les invites. Ces actions comprennent :

  • Play : Lit des fichiers audio WAV personnalisés ou des invites de TTSClosed Permet aux utilisateurs d’entrer des invites enregistrées sous forme de texte et d’utiliser une voix générée par ordinateur pour prononcer le contenu. (synthèse vocale). Si vous utilisez un fichier, le fichier entier est lu. Seul le contact peut entendre l'audio.
  • Reqagent : Lit des fichiers audio WAV personnalisés ou une invite de synthèse vocale que seul l'agent entend. Pour éviter que le contact entende un temps de silence, l’invite est lue avant que l’agent et le contact soient mis en relation.
  • Murmurer : lit des fichiers WAV personnalisés ou des invites de synthèse vocale. Vous pouvez déterminer que ces fichiers soit audibles par le contact uniquement, l'agent uniquement ou les deux. L’invite est lue après la mise en relation de l’agent et du contact ; par conséquent, si l’action lit l’invite uniquement à l’agent ou au contact, l’autre partie entend un silence pendant ce temps.

Certaines actions, comme Reqagent, possèdent une propriété Séquence, mais ne sont pas liées à l'éditeur de Séquence. Si vous souhaitez utiliser l'éditeur de Séquence pour créer un prompt pour ces actions, vous pouvez temporairement ajouter l'action Play à votre script. Accédez à l'éditeur de Séquence via Play et créez votre prompt. Copiez et collez les séquences de prompt de la propriété Séquence dans la propriété Séquence de l'autre action. Lorsque vous avez terminé, supprimez Play.

  1. Ajoutez une action Voiceparams action à votre script, avant l'action qui prend en charge TTSClosed Permet aux utilisateurs d’entrer des invites enregistrées sous forme de texte et d’utiliser une voix générée par ordinateur pour prononcer le contenu.. Si les propriétés définies par l'action prenant en charge TTS doivent être transmises à d'autres scripts, vous souhaiterez peut-être également placer une action Voiceparams dans les scripts secondaires afin de vous assurer que ces propriétés ne sont pas ignorées.

  2. Dans les propriétés de l'action Voiceparams, cliquez sur la liste déroulante du champ TTSVoice et sélectionnez la langue et la voix avec lesquelles vous souhaitez faire parler l'invite.
  3. Créez l’invite à l’aide de l’éditeur de séquence ou saisissez-la dans la propriété Séquence.
  4. Saisissez le texte de l'invite dans le champ Phrase sans mise en forme. Cela vous permet de voir l'intégralité du prompt en un seul endroit, au lieu qu'il soit divisé en segments dans le champ Séquence. Le contenu du champ phrase est fourni uniquement à titre informatif. L'invite ne prononce pas ce texte.
  5. Cliquez sur Appliquer pour enregistrer l'invite dans l'action sélectionnée.

Création d’une invite TTS dans l’Éditeur de séquence

L'éditeur de séquence vous permet de créer un prompt TTS à l'aide d'une interface qui ajoute la mise en forme pour vous. Lorsque vous utilisez l'éditeur de séquence, vous ajoutez des séquencesClosed Un segment d’une invite audio jouée pour le contact. au champ Sequence. Chaque élément numéroté qui apparaît dans le champ est une Séquence. Ces éléments apparaissent lorsque vous cliquez sur une option lecture sur le côté gauche de la fenêtre de l'éditeur, telle que Lire une date ou Synthétiser le texte.

Chaque séquence a une limite de 300 caractères. Vous pouvez ajouter des séquences supplémentaires si le texte que vous devez lire est plus long que cette limite. Par exemple, si vous devez lire un texte de 540 caractères, vous pouvez ajouter deux Text to Speech séquences avec le texte réparti entre elles.

  1. Dans Studio, ouvrez ou créez un script. Si nécessaire, ajoutez une action qui prend en charge les invites, par exemple Menu.
  2. Double-cliquez sur l'action à laquelle vous souhaitez ajouter une invite.
  3. Dans la fenêtre Éditeur de séquence, cliquez sur Synthesize Text. Un texte par défaut apparaît dans les champs Sequence et Sequence Value. Le texte par défaut de Synthesize Text est The little brown fox.

  4. Dans le champ Sequence Value, supprimez la valeur par défaut, puis entrez la valeur désirée pour l'invite. Par exemple, vous pouvez supprimer The little brown fox et ajouter Thank you for calling Classics, Inc. We're here to help you read more.
  5. Si vous incluez des valeurs monétaires, des dates, des heures ou du texte que vous voulez épeler lettre par lettre, comme le nom du contact, utilisez les autres options de séquence de l’Éditeur de séquence.

  6. Si vous voulez modifier l'ordre des éléments dans le champ Sequence, sélectionnez la séquence à déplacer et cliquez sur les flèches vers le haut ou vers le bas . Lorsque le script joue une invite, ses séquences sont lues dans l'ordre, de haut en bas.

  7. Insérez une pause entre des mots ou des phrases en utilisant l'une des méthodes suivantes :

    • Utiliser un fichier de silence enregistré : créez un fichier WAV ou chargez un fichier son de silence à l'aide de l’Éditeur de séquence . Cliquez sur Play a Wave File et sélectionnez le fichier de silence. Si nécessaire, cliquez sur le fichier WAV dans le champ Sequence et utilisez les touches fléchées pour déplacer l'invite à l’endroit désiré.
    • Utiliser une action Attendre : utilisez une action Play pour les segments de l'invite que vous voulez séparer par un silence, puis ajoutez une action Wait entre eux. Configurez Wait avec la durée de la pause.
  8. Modifiez les entrées dans le champ Sequence si nécessaire. Sélectionnez une séquence dans le champ Sequence et modifiez le contenu dans le champ Sequence Value.
  9. Tapez le texte brut de l'invite dans le champ Phrase sans mise en forme. Cela vous permet de voir l'intégralité de l'invite en un seul endroit, au lieu d'être divisée en séquences dans le champ Sequence. Le contenu du champ Phrase est destiné à vous seul. Le service TTS ne prononce pas ce texte.
  10. Cliquez sur Apply pour enregistrer l’invite.

Création d’une invite TTS dans la propriété de séquence

Vous pouvez créer un prompt TTSClosed Permet aux utilisateurs d’entrer des invites enregistrées sous forme de texte et d’utiliser une voix générée par ordinateur pour prononcer le contenu. dans la propriété Séquence d'une action en saisissant des séquences avec le formatage approprié. Une séquence est une série de caractères, de mots ou d’expressions, ou de phrases. Le service TTS reconnaît plusieurs types de séquences. Vous pouvez inclure plus d'une séquence dans la propriété Séquence. Chaque séquence doit :

  • Être délimitée par des guillemets doubles.
  • Incluez le caractère de référence de chaîne requis par le type d'informations que contient la séquence. Le seul type de séquence qui ne nécessite pas de caractère de référence de chaîne est une séquence de fichier audio.
  • Suivez les formats pris en charge pour les informations telles que les dates, les heures et l'argent.
  • Ne doit pas contenir plus de 300 caractères. Si vous devez inclure du texte dépassant 300 caractères, répartissez-le entre plusieurs séquences.

Vous pouvez utiliser la substitution de variable avec la propriété Séquence. Les invites transmises dans la variable doivent être correctement formatées.

Classics, Inc. a décidé de rétablir une des invites dans son menu IVRClosed Réponse vocale interactive. Menu téléphonique automatisé que les contacts utilisent par la Voix ou par des touches pour obtenir des informations, acheminer un appel vocal entrant, ou les deux.. L'équipe de gestion rédige le script pour la nouvelle invite et le remet à Beowulf Herot, le Studio développeur de script chez Classics, Inc. L’invite est destinée aux clients qui demandent le solde de leur compte et la date d’échéance de leur prochaine facture.Lorsque Beowulf achève l’invite, elle contient les séquences suivantes :

`"Le solde actuel du compte de {firstName} {lastName} est "
"${accountBal} "
"%. Votre prochain paiement est attendu le "
"@{billDueDate} "
"%. Pour réécouter ces informations, appuyez sur 1. Pour connaître l’adresse à laquelle envoyer votre paiement par courrier, appuyez sur 2. Pour adhérer au paiement électronique des factures, appuyez sur 3. Pour revenir au menu principal, appuyez sur la touche étoile. "

Création d’une invite TTS dynamique

Vous pouvez créer une invite dynamique dans une action Snippet. Ceci est utile si vous avez une invite qui change continuellement. Vous pouvez entrer l'invite directement dans la fenêtre de l'éditeur Snippet ou la créer dans l'Éditeur de séquence et la copier dans l'action Snippet.

  1. Dans Studio, ouvrez un script existant ou créez-en un nouveau.
  2. Ajoutez une action Snippet ainsi que l'action qui lira le prompt, telle que Play.
  3. Placez Snippet avant Play et connectez-les.
  4. Créez le prompt dans le sequence editor, puis copiez le contenu de la propriété séquence de l'action.

    Certaines actions possèdent une propriété Séquence, mais pas l'éditeur de séquence. Si l'action que vous devez utiliser ne prend pas en charge l'éditeur de séquence, ajoutez une action Play à votre script, créez votre Prompt, puis copiez-le à partir de la propriété Séquence. Supprimez l'action supplémentaire après la création de l'invite.

  5. Double-cliquez sur l'action Snippet.
  6. Dans la fenêtre Snippet editor, créez l'objet dynamique et affectez-lui la séquence à l'aide de la syntaxe suivante :

    DYNAMIC [dynamic object name] = [sequence]

  7. Ajoutez un signe dollar ( $ ) au début de la définition de la séquence, avant le premier guillemet double. Utilisez des caractères antislash pour échappez tous les guillemets doubles dans le Prompt. Par exemple :

    ASSIGN promptList = $"\"{promptPath}YourAccountBalanceIs_{lang}.wav\" \"%{accountBalance}\" \"{promptPath}ToPayYourBillPress_{lang}.wav\"" 
  8. Ajoutez au snippet toutes les autres variables nécessaires pour compléter l'invite, si elles ne se trouvent pas déjà dans votre script.

    Par exemple :

    ASSIGN env = "PROD"
    ASSIGN lang = "ENG"
    ASSIGN promptPath = "Prompts\{env}\"
    ASSIGN accountBalance = "$52.65"
    ASSIGN promptList = $"\"{promptPath}YourAccountBalanceIs_{lang}.wav\" \"%{accountBalance}\" \"{promptPath}ToPayYourBillPress_{lang}.wav\""
  9. Cliquez sur Apply.
  10. Dans l'espace de travail du canevas du script, sélectionnez l'action qui jouera l'invite.
  11. Dans la propriété Séquence, entrée le nom de l'objet dynamique qui contient l'invite dans l'action Snippet. Pour l'exemple utilisé dans cette section, vous devez entrer {promptList}.
  12. Cliquez sur Apply.

Enregistrer les invites audio dans Studio

Autorisations requises : ACD > Studio > Scripts > Créer/Modifier , ACD > Studio > enregistrer les Invites > Activé

Vous pouvez enregistrer une invite vocale via l’Éditeur de séquence dans Studio. Vous devez avoir accès à un téléphone pour enregistrer une invite avec cette méthode. Vous fournirez le numéro de téléphone, puis recevrez un appel automatisé qui enregistrera ce que vous dites.

Les fichiers audio que vous enregistrez dans Studio sont stockés sous forme de fichiers WAV dans votre locataireClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone. NiCE CXone. Vous pouvez les utiliser en tant qu'invites audio dans n'importe quelle action prenant en charge les séquences. Vous pouvez voir tous les fichiers audio disponibles dans la page Parcourir les fichiers ACD de NiCE CXone.

  1. Dans Studio, ouvrez un script existant ou créez-en un nouveau.

  2. Ajoutez au script une action qui prend en charge l'Éditeur de séquence, telle que Play ou Whisper.
  3. Double-cliquez sur l'icône d’action afin d'ouvrir l’Éditeur de séquence.

  4. Cliquez sur Play a Wave File et sélectionnez New.

  5. Sélectionnez NewPrompt().wav dans le champ Sequence, puis entrez la valeur par défaut dans le champ Sequence Value afin de renommer le fichier WAV. Lorsque vous modifiez le nom d'un fichier dans le champ Sequence Value, le nom change également dans la liste des séquences.

  6. Cliquez sur l'icône Connect Prompt Manager dans la barre d'outils pour ouvrir la fenêtre de connexion au gestionnaire d'invites.

  7. Entrez le numéro de téléphone d'un téléphone auquel vous avez accès en ce moment. Vous recevrez un appel sur ce téléphone afin que vous puissiez enregistrer l'invite.

  8. Cliquez sur Connect pour recevoir un appel du service d'enregistrement.

  9. Répondez à l'appel téléphonique. Certaines des icônes de la barre d'outils de l’Éditeur de séquence deviennent disponibles et la barre d'outils affiche un message Gestionnaire d’invites prêt. Les icônes sont désormais disponibles et permettent de contrôler l'enregistrement pendant l'appel.

  10. Cliquez sur l'icône Record pour commencer à enregistrer votre invite.

  11. Lorsque vous entendez un bip de l'appel, énoncez clairement votre invite ou un message.

  12. Lorsque vous avez terminé l'enregistrement, cliquez sur l'icône Stop . Ne raccrochez pas tant que vous n'avez pas lu l'invite.

  13. Pour vérifier votre enregistrement, cliquez sur l'icône Play .

  14. Si l’invite vocale est acceptable, mettez fin à l’appel. Si elle n'est pas acceptable, cliquez sur l'icône Record pour réenregistrer l'invite.

Attribution d’une invite audio à une action

Autorisations requises : ACD > Studio > Scripts > Créer/Modifier

Après avoir enregistré ou téléchargé une nouvelle invite audio, vous pouvez l'ajouter à l'action que vous souhaitez lire pour cette invite.

Vous pouvez entrer le nom de fichier d’une invite audio enregistrée et envoyée dans la propriété Sequence de l'action. Vous pouvez également utiliser l'éditeur de séquence, comme décrit dans cette tâche.

  1. Dans votre script, double-cliquez sur l'action à laquelle vous voulez attribuera le invite.
  2. Dans l'éditeur de séquence, cliquez sur Play a Wave File et sélectionnez Browse.
  3. Sélectionnez l'invite que vous souhaitez lire et cliquez sur OK.
  4. Cliquez sur Apply pour enregistrer votre sélection et fermer l’éditeur de séquence.

Modifier les invites dans Studio

Autorisations requises : ACD > Studio > Scripts > Créer/Modifier

L'éditeur Wave vous permet de couper l'audio indésirable du début et de la fin d'un fichier WAV.

  1. Double-cliquez sur une action prenant en charge les invites. L’éditeur de séquence est peut-être déjà ouvert si vous venez d'enregistrer une invite.
  2. Cliquez sur l'icône Edit Wave dans la barre d'outils pour lancer l'éditeur Wave.
  3. Sélectionnez le fichier WAV que vous souhaitez modifier dans la colonne Invites.
  4. Cliquez sur le bouton gauche de la souris pour mettre en surbrillance le début de l'invite que vous souhaitez supprimer.
  5. Cliquez sur le bouton droit de la souris pour mettre en surbrillance la fin de l'invite que vous souhaitez supprimer.
  6. Vous pouvez vérifier que vous avez coupé les quantités audio appropriées en cliquant sur le bouton vert Play afin de lire l'invite avec les sections en surbrillance que vous souhaitez supprimer.
  7. Cliquez sur Edit > Trim pour supprimer les sections en surbrillance du fichier WAV.
  8. Enregistrez vos modifications.

Chargement d'invites audio

Autorisations requises : ACD > Studio > Explorateur de fichiers > Modifier Créer

Si vous utilisez une application audio tierce pour enregistrer une invite, vous pouvez la télécharger dansStudio. Toute invite que vous chargez doit être dans le format audio pris en charge :

  • Débit binaire : 64 kbps
  • Taille de l'échantillon audio : 8 bits
  • Canaux : 1 (mono)
  • Fréquence d'échantillonnage audio : 8 kHz
  • Format audio : CCITT μ-Law

Vous pouvez également visualiser, charger et gérer des invites et d'autres fichiers sur la page Parcourir les fichiers ACD de NiCE CXone.

  1. Dans l'onglet Fichiers de Studio, développez le dossier dans lequel vous voulez charger le fichier. Si vous chargez une invite, développez le dossier Invites.

  2. Faites glisser un fichier du navigateur de fichiers de votre ordinateur vers la fenêtre Fichiers de Studio.
  3. Cliquez sur l'icône Refresh et assurez-vous que le champ Date Modified de l'invite a bien été mis à jour.

Téléchargement et suppression d'invites audio et d’autres fichiers

Autorisations requises : ACD > Studio > Explorateur de fichiers > Modifier Créer

Vous pouvez télécharger ou supprimer des invites et d'autres fichiers de Studio sur votre ordinateur. Vous pouvez également le faire sur la page Parcourir les fichiers ACD de NiCE CXone.

  1. Dans l'onglet Fichiers de Studio, développez le dossier qui contient le fichier.

  2. Pour télécharger un fichier, faites-le glisser depuis le navigateur de fichiers Studio vers le bureau ou un dossier sur votre ordinateur.
  3. Pour supprimer un fichier, sélectionnez-le et cliquez sur l'icône rouge X . Cliquez sur Yes pour confirmer que vous voulez supprimer le fichier.