Studio Interface utilisateur

Cette page s'adresse à Desktop Studio. Vous pouvez en apprendre davantage sur l'interface Studio dans la page d'aide Démarrer avec Studio.

L'interface utilisateur de Studio se compose d'un canevas au centre, entouré d'un certain nombre d'onglets à gauche, à droite et en bas. Ces onglets donnent accès aux actionsClosed Exécute un processus dans un script Studio, comme la collecte de données clients ou la lecture de musique. de Studio ainsi qu'à des informations sur les actions et sur votre script.

Studio Barre de menus

Le menu principal contient sept menus déroulants : Fichier, Édition, Affichage, Validation, Déboguer, Fenêtre et Aide. Bon nombre des éléments de menu sont des commandes courantes, comme l'enregistrement d'un fichier ou l'annulation d'une modification. Les commandes courantes ne sont pas décrites dans cette rubrique.

Menu Fichier

Outre les commandes courantes d'un menu Fichier générique, telles que Nouveau, Ouvrir, Enregistrer et Quitter, le Studio menu Fichier contient ces options supplémentaires :

Options de menus Détails
Importer/Exporter

Vous permet d'importer un script à partir d'un fichier XML dans Studio, ou d'exporter un script vers un fichier XML.

Récent

Fournit une liste des scripts que vous avez récemment ouverts dans Studio pour l'locataireClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone. à laquelle vous êtes connecté. Cliquez sur un script de la liste pour l'ouvrir dans un nouveau panneau Canevas.

Déconnexion & Quitter Sélectionnez cette option pour vous déconnecter de Studio et fermer l'application. Studio se souvient de votre connexion même après la fermeture de l'application. Si vous devez vous déconnecter complètement, utilisez cette option.

Modifier le menu

Le menu Édition contient les commandes courantes des menus Édition, notamment Annuler, Couper, Copier et Coller. Vous pouvez utiliser ces options avec les actionsClosed Exécute un processus dans un script Studio, comme la collecte de données clients ou la lecture de musique. de Studio sur le canevas. Les raccourcis clavier standards fonctionnent pour ces commandes (Ctrl+Z, Ctrl+X, Ctrl+C et Ctrl+V). Le menu Édition de Studio comprend également ces options :

Options de menus Détails
Copier le script sous forme d'image

Copie le script actuel dans votre presse-papiers sous forme d'image. Vous pouvez coller l'image à un autre emplacement, comme un courriel ou un document texte.

Trouver

Ouvre la fenêtre Rechercher dans le script, où vous pouvez search pour un texte spécifique dans tous les scripts que vous avez ouverts ou uniquement dans le script ouvert dans l'onglet Canevas supérieur.

Accéder à

Recherchezearch un id d’action dans le script actuel et accédez-y immédiatement. Vous pouvez consulter les id d’action dans le champ ID de l’onglet Actions.

Comparer Vous permet de comparer deux scripts selon les légendes, les paramètres, les branches ou la position. Par exemple, une paire de scripts peut contenir exactement les mêmes actions et branches, mais des paramètres différents. En comparant les 2 scripts, vous pouvez afficher les différences (et les similitudes) dans l’onglet Trouver des Résultats.

Menu Affichage

Le menu Affichage propose les options suivantes :

Options de menus Détails
Aide > informations sur l’agent Affichez les informations sur le compte NiCE CXone auquel vous êtes actuellement connecté avec Studio. Les Informations apparaissent dans l’onglet Properties (propriétés).
Aide > informations de Connexion Afficher des informations sur votre session en cours dans Studio.

Navigateur,
Outils,
propriétés,
Bibliothèque,
Fichiers,
Navigation,
Recherche,
Cadre,
Trouver des Résultats

Cliquez sur le nom de l’onglet pour ouvrir cet onglet dans Studio. Ceci est utile lorsque vous avez fermé un onglet et que vous devez le rouvrir.

Si vous devez rouvrir les onglets Erreurs de script, Actions, Variables ou Dépendances, consultez le Menu validation.

Barres d’outils > Trace Cliquez pour basculer si vous souhaitez afficher l'option Trace dans la barre d'outils.

Menu Validation

Options de menus Détails
Windows

Cliquez pour ouvrir l'un de ces onglets : Erreurs de script, Actions, Variables et Dépendances.

Si vous avez besoin d'ouvrir des onglets qui ne figurent pas dans cette liste, consultez leAfficher le menu.

Contrôle de syntaxe

Vérifie un script actif pour les erreurs de connexion et de propriété et affiche des avertissements dans l’onglet Erreurs de script. Il s’agit d’une méthode élémentaire pour tester et déboguer votre script.

Menu Déboguer

autorisations requises :ACD > Studio > Scripts > Déboguer

Options de menus Détails
Capturer script

Capturez un script pour tracer et documenter son progrès pendant son exécution. Vous pouvez choisir de capturer l'Instance suivante uniquement ou de capturer sur une base Continue pendant son exécution. Au fur et à mesure que chaque action du script se déclenche, l'information résultante apparaît dans l'outil Trace Output. Si vous capturez un script en continu, les fichiers de trace sont sauvegardés sur le serveur multimédia NiCE CXone. Vous pouvez utiliser Déboguer > Charger le fichier de trace Distant pour visualiser ces fichiers de trace.

Démarrer avec Trace

Lance le script actif et ouvre la fenêtre Trace Output pour afficher les résultats de l'exécution du script. Vous pouvez également démarrer une trace à partir de la barre d'outils en utilisant le bouton Démarrer avec Trace .

Charger fichier de Trace de débogage

Recherchez un fichier de trace et ouvrez-le dans la fenêtre Trace Output.

Charger fichier Trace Distant

Recherchez un fichier de trace sur la plateforme NiCE CXone et ouvrez-le dans la fenêtre Sortie de trace.

Menu Fenêtre

Le menu Fenêtre vous permet de naviguer entre les scripts ouverts dans Studio. La sélection d'un script dans ce menu le place au premier plan en tant qu'onglet actif. Si vous n'avez qu'un seul script ouvert, il n'y a qu'une seule option dans ce menu.

Menu Aide

Le menu Aide fournit des options pour accéder à la Studio en ligne, ainsi que d'autres informations pouvant vous aider à Studio.

Options de menus Détails
Documentation NiCE CXone Studio

Ouvre un nouvel onglet de votre navigateur Web par défaut et charge la page vue d'ensemble de Studio de l'aide en ligne.

Aide contextuelle F1

Affiche le sujet d'aide en ligne pour l'action actuellement sélectionnée sur le canevas. Vous pouvez également appuyer sur F1 sur votre clavier pour accéder au sujet d'aide de l'action sélectionnée. Les sujets d'aide se chargent dans un nouvel onglet de votre navigateur Web par défaut.

Configuration de l'unité commerciale

Affiche des informations sur la configuration de votre locataire. Vous devrez peut-être consulter ces informations si vous n'êtes pas certain des applications ou fonctionnalités activées, comme les types de canaux.

Dépannage > Télécharger manuellement le programme CefSharp Démarre un nouveau téléchargement de CefSharp, un plug-in dont Studio a besoin pour s'exécuter.
Dépannage > Vider le cache Efface Studio's cache, ce qui peut être utile si l'application ne fonctionne pas comme prévu.
À propos de

Affiche des informations de base sur Studio, comme la version.

Barre d'outils Studio

La barre d'outils offre un mélange de commandes génériques, telles que l'ouverture ou l'enregistrement d'un script, et Studio-commandes spécifiques.

Options de la barre d'outils Détails
Augmenter / réduire l'espace

Cliquez pour augmenter ou diminuer l'espace entre les actions sur le canevas. Chaque clic modifie légèrement la quantité d'espace.

Démarrer avec Trace Permet de démarrer une trace.
Tracer le script

Le traçage d'un script lance le script actif et ouvre la fenêtre Sortie de trace pour afficher les résultats du script en cours d'exécution. La barre d'outils fournit 3 commandes liées au traçage d'un script : démarrer le traçage, sélectionner un ANIClosed Aussi connu sous le nom d’id de l’appelant. numéro de téléphone listé d’un appel entrant, ou d’un appel vocal entrant. ou DNISClosed Le numéro composé lors des appels vocaux entrants ou sortants. avec lequel tracer le script, ou les options permettant de tracer et de capturer l'instance suivante de l'exécution du script, ou de tracer et de capturer continuellement chaque instance du script au fur et à mesure de son exécution (pertinent pour les scripts en production). Consultez la page Scripts de débogage dans Desktop Studio pour plus d'informations.

Verrouiller / déverrouiller des scripts

Cliquez pour verrouiller ou déverrouiller un script. Le verrouillage place un script en mode en lecture seule. Le déverrouillage vous permet de le modifier, mais aucun autre utilisateur Studio ne peut le modifier en même temps. D'autres utilisateurs peuvent modifier le script après que vous l'ayez déverrouillé ou après l'avoir enregistré et fermé.

Lorsqu'un script est verrouillé, l'arrière-plan du canevas apparaît en blanc et l'icône de script sur l'onglet est un cadenas verrouillé. Lorsqu'un script est déverrouillé, l'arrière-plan du canevas apparaît en gris et l'icône apparaît comme l'icône du type de script.

Cette option apparaît dans Studio uniquement si le verrouillage des scripts est activé. Votre administrateur NiCE CXone peut activer cette option.

Si vous disposez de l'autorisation Contournement du verrou des scripts, vous pouvez outrepasser le verrou d'un autre utilisateur sur un script afin de pouvoir le modifier. Vous pouvez voir tous les scripts verrouillés sur votre locataireClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone. dans l'onglet Verrouillé.

Canevas Studio

Le canevas est le grand espace situé au centre de l'interface Studio. C'est là que vous créez un script. Vous pouvez faire glisser des actions depuis les onglets Outils ou Framework vers le canevas. Les scripts s'ouvrent dans de nouveaux onglets de canevas, comme dans un navigateur Web.

Sur la toile, vous pouvez :

  • Cliquez sur les onglets ou utilisez le menu Fenêtre pour basculer entre les scripts ouverts.
  • Fermez un onglet de script en cliquant sur le X sur le canevas. Le X ne se trouve pas sur l'onglet du script, comme c'est le cas dans certains navigateurs Web. Il est situé dans le coin supérieur droit de la fenêtre du canevas.
  • Si vous cliquez dans l'espace blanc du canevas, puis sélectionnez l'onglet propriétés, vous pouvez accéder aux propriétés du script.
  • Si vous fermez tous les onglets de script, vous pouvez remplacer le canevas par la création d'un nouveau script.

Onglets Studio

Les onglets donnent accès à de nombreuses informations différentes dont vous avez besoin lorsque vous travaillez dans Studio. Par défaut, les onglets sont répartis en trois groupes. Les groupes sont situés à gauche, à droite et en bas du canevas. Tous les onglets sont visibles par défaut. Si vous fermez un onglet, vous pouvez le rouvrir à l'aide du menu Affichage ou du menu Validation > Windows. Consultez l'image en haut de cette page pour un guide visuel de la disposition par défaut.

Groupes d'onglets par défaut

Les groupes d'onglets par défaut sont :

  • Left side: These tabs are located on the left side of the Studio window by default:
    • Onglet Naviguer
    • Dépendances
    • Variables
    • Actions
  • Right side: These tabs are located on the right side of the Studio window by default: 
    • Onglet Cadre
    • Outils
    • Bibliothèque NICE
    • Parcourir
    • Properties (propriétés)
  • Bottom: These tabs are located at the bottom of the Studio window by default: 
    • Trouver des Résultats
    • Fichiers
    • Erreurs de script
    • Rechercher

Réorganiser les onglets

L'emplacement des onglets est personnalisable. Vous pouvez :

  • Faire glisser et déposer les onglets les uns sur les autres pour les déplacer vers d'autres emplacements dans Studio. Si vous saisissez la barre de titre d'un onglet, toute la pile d'onglets se déplace. Si vous souhaitez déplacer un seul onglet, saisissez l'autre extrémité de l'onglet (la partie qui ressemble en fait à un onglet).
  • Épingler un groupe d'onglets au bord de la fenêtre d'interface en cliquant sur l'icône d'épingle dans le coin supérieur droit de l'onglet. Lorsque vous cliquez sur un onglet épinglé, il se déploie pour que vous puissiez l'utiliser. Lorsque vous cliquez en dehors de celui-ci, il se réduit au bord épinglé.

  • Utilisez les zones de dépôt pour placer les onglets. Lorsque vous cliquez sur la barre de titre d'un onglet et que vous le faites glisser hors de son emplacement actuel, l'interface Studio affiche les icônes de zones de dépôt pour tous les endroits où vous pouvez ancrer l'onglet. Placez le curseur sur une zone de dépôt et relâchez le bouton de la souris.

Onglet Actions

L'onglet Actions affiche une liste de toutes les actions actuellement présentes dans le script. Les actions sont répertoriées dans l'ordre dans lequel elles ont été ajoutées au script. Cet onglet affiche les informations suivantes sur chaque action :

  • Légende : Il s'agit du texte qui apparaît sous l'icône de l'action sur le canevas. Par défaut, la légende est identique au nom de l'action. Vous pouvez modifier la légende de n'importe quelle action dans les propriétés de l'action. C'est un moyen utile de noter ce que l'action accomplit dans le script. Par exemple, pour chaque action Snippet , vous pourriez changer la légende pour indiquer ce que cette instance de Snippet fait dans le script.

  • Nom de l'outil : Le nom de l'action. Ce nom ne peut pas être modifié.
  • ID : L'ID d'action attribué à l'action selon l'ordre dans lequel elle a été ajoutée au canevas. Chaque instance d'une action dans un script donné possède un numéro unique.

Onglet Parcourir

L'onglet Parcourir affiche les dossiers Studio, dans lesquels vous stockez tous les scripts que vous créez pour cette locataire. Vous pouvez :

  • Ouvrez les scripts à partir de cet onglet en double-cliquant sur un script. Il s'ouvre dans un onglet de canevas.
  • Afficher l'historique du script en cliquant avec le bouton droit sur un script et en passant votre curseur dessusHistoire.
  • Ouvrez une ancienne version d'un script en cliquant sur la version que vous souhaitez voir dans la liste Historique.
  • Revenir à une version précédente d'un script en ouvrant la version précédente du script et en cliquant sur Enregistrer sous, puis en choisissant le script dans la liste.

La page Scripts de l'application NiCE CXone ACD vous permet également de revenir à une version antérieure d'un script si vous disposez des autorisations appropriées.

Onglet Dépendances

Affiche les relations entre les actions dans le script actif.

Onglet Fichiers

autorisations requises : ACD > Studio > Explorateur de fichiers > Afficher

L'onglet Fichiers contient tous les enregistrements d'invites vocales utilisés dans les scripts. Ces fichiers sont stockés dans votre locataire. Vous pouvez voir des informations de base sur le fichier d'invite (date de dernière modification, objectif, description et durée du fichier lors de la lecture). Vous pouvez téléverser de nouvelles invites à partir de cet onglet.

Onglet Trouver des Résultats

Affiche les résultats de la comparaison effectuée avec l'option Edit > Compare .

Onglet Cadre

Contient une liste complète de toutes Studio Actions.

Étant donné que certaines des actions de cet onglet sont plus avancées, elles ne sont pas offertes à tous les utilisateurs par défaut. Si vous ne voyez pas l'onglet dans Desktop Studio, il n'a pas été activé pour votre unité commercialeClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone.. Si votre organisation a un besoin qui peut être satisfait par l'utilisation d'une action Framework, votre représentant de compte peut activer l'onglet Framework dans votre unité commerciale.

Si vous avez accès à l'onglet Framework, soyez prudent lorsque vous utilisez des actions qui ne vous sont pas familières. Bon nombre de ces actions ne sont pas documentées dans l'aide en ligne. Vous pouvez demander à votre représentant de compte ou soumettre une question à la NiCE CXone communauté des clients pour en savoir plus sur ce que fait une action.

Vous pouvez en savoir plus sur les actions disponibles dans cet onglet sur la page d'aide Actions du cadre.

Onglet verrouillé

autorisations requises : ACD > Studio > Scripts > Substitution de verrouillage

Affiche une liste des scripts qui ont été verrouillés. Si votre compte utilisateur NiCE CXone dispose de l'autorisation Contournement du verrou, vous pouvez contourner le verrouillage d'un script. Déverrouillez un script en cliquant avec le bouton droit sur le script et en sélectionnant Expulser <user> de la modification du script ou en cliquant sur le bouton Expulser (indiqué par une flèche rouge).

Onglet Naviguer

Vous permet de naviguer rapidement dans les scripts volumineux sans utiliser les barres de défilement. Le cadre rouge affiche ce que vous pouvez voir dans le canevas.

Onglet propriétés

L'onglet propriétés affiche des informations sur l'action actuellement sélectionnée. Si aucune action n'est sélectionnée, cet onglet affiche des informations sur l'ensemble du script.

Chaque action possède un ensemble unique de variables, de branches et de paramètres. Vous pouvez les configurer dans les propriétés de l'action pour définir la façon dont vous souhaitez que l'action fonctionne dans le script. Vous pouvez également afficher les propriétés de l'action en cliquant avec le bouton droit sur l'action et en sélectionnant propriétés.

Les propriétés du script vous permettent de simuler un appel entrant pour tester le script. Vous pouvez également masquer une ou plusieurs variables dans le script.

Erreurs de script

L'onglet Script Errors affiche tous les avertissements et erreurs liés à votre script. L'onglet n'affiche rien tant que vous n'avez pas enregistré le script ou exécuté une vérification de la syntaxe. Les Avertissements n'empêchent pas le script de s'exécuter ou d'être enregistré, mais les erreurs si.

Onglet Recherche

Vous permet de rechercher un script spécifique. Vous pouvez affiner votre recherche en utilisant un nom de script partiel, l'unité commerciale, les anciennes et nouvelles versions, ainsi que les types de scripts.

Onglet Outils

Affiche les actions les plus couramment utilisées. Cliquez sur l'icône des catégories pour changer la façon dont les actions sont organisées. Vous pouvez les afficher par catégories ou par ordre alphabétique. Lorsque les actions sont classées par ordre alphabétique, vous pouvez cliquer sur l'icône de tri pour inverser l'ordre de la liste.

Le regroupement des catégories par défaut est appelé palette. Vous pouvez créer vos propres catégories et palettes en cliquant sur l'icône de palette dans le coin supérieur droit de l'onglet Outils. La palette par défaut contient ces catégories :

Catégorie Description
Standard Actions de base et générales utilisées dans tout type de script.
Voice Extra Actions communes utilisées pour les scripts de type de support voix.
Avancée Actions avancées généralement utilisées par des développeurs de scripts expérimentés.
Accès aux données Actions liées à l'accès aux données à partir d'inData ou des bases de données clients.
Système Actions utilisées pour le stockage et la manipulation de fichiers.
Événements Actions déclenchées par NiCE CXone.
la toile Actions utilisées par les scripts système. Les scripts Système sont des scripts par défaut que NiCE CXone utilise en interne.
Parole Actions liées à la reconnaissance vocale automatique (RSAClosed Reconnaissance automatique de la Parole. Permet aux contacts de répondre aux invites en parlant, en appuyant sur des touches du téléphone, ou les deux.).
WFO Actions liées à Engagement de la main-d’œuvre (WEM).
Personal Connection Actions liées à NiCE CXone Personal Connection.
NiCE CXone Authentification personnalisée Actions liées à l'authentification du client.
Automatisation et IA Actions liées à l'IA automatisée, telles que les assistants agentsClosed Application logicielle qui fournit une aide contextuelle à l'agent. et les robots agents virtuelsClosed Une application logicielle qui traite les interactions avec les clients à la place d’un agent humain en direct..

Onglet Variables

Affiche les variables disponibles dans le script actif et les actions qui font référence à chacune.

Raccourcis clavier

Studio utilise plusieurs des raccourcis clavier couramment connus, comme CTRL + C pour copier un élément, mais offre également de nombreux autres raccourcis pour simplifier votre flux de travail.

Raccourci Action
CTRL + A Sélectionne toutes les icônes d'action du script actif.
CTRL + C Exécute la fonction de copie standard de Windows.
CTRL + E Ouvre la fenêtre Exporter vers un fichier.
CTRL + F Ouvre la boîte de dialogue Rechercher dans le script.
CTRL + G Passe à un élément d’action de script spécifique (c'est-à-dire qu'il sélectionne une icône d'action dans le script actif en fonction de l'ID que vous saisissez).
CTRL + I Ouvre la fenêtre Importer depuis un fichier...
CTRL + N Ouvre la fenêtre Créer un nouveau script.
CTRL + O Ouvre la fenêtre Ouvrir le script depuis....
CTRL + S Enregistre les modifications dans le script actif seulement.
CTRL + MAJ + S Enregistre les changements dans tous les scripts ouverts.
CTRL + T Capture une trace de script pour la prochaine occurrence seulement.
CTRL + MAJ + T Démarre une trace de script continue qui s'exécute jusqu'à ce qu'elle se termine manuellement.
CTRL + V Exécute la fonction standard Windows « coller ».
CTRL + X Exécute la fonction standard Windows « couper ».
CTRL + Y Rétablit le script dans son état avant une « annulation ».
CTRL + Z Exécute la fonction « annuler » de Windows (c'est-à-dire qu'elle ramène le script dans l'état dans lequel il était avant votre dernière modification).
Del ou Supprimer Supprime l'élément sélectionné.
F1 Lance l'aide en ligne pour une action sélectionnée.
CTRL + F2 Ouvre l'onglet Parcourir.
CTRL + MAJ + F2 Ouvre l'onglet Cadre.
CTRL + F3 Ouvre l'onglet Outils.
CTRL + MAJ + F3 Ouvre l'onglet Résultats de la recherche (voir la boîte de dialogue Rechercher dans le script).
CTRL + F4 Ouvre l'onglet propriétés.
CTRL + MAJ + F4 Ouvre l'onglet Verrouillé.
F5 Ouvre la fenêtre Trace Output.
CTRL + F6 Ouvre l'onglet Fichiers.
SHIFT + F6 Vérifie la syntaxe du script actif et ouvre l'onglet Erreurs de script.
CTRL + F7 Ouvre l'onglet Naviguer.
CTRL + F9 Ouvre l'onglet Rechercher.