Travailler avec les scripts (Desktop Studio)

Cette Page d'aide concerne Desktop Studio. Ces informations sont également disponibles pour Studio.

Cette page fournit des informations sur les tâches de script essentielles, telles que la création ou l'ouverture de scripts, l'ajout et la configuration d'actions et le verrouillage ou le déverrouillage de scripts.

Créer un Nouveau script

Autorisations requises : Créer/Modifier des scripts studio

Si le verrouillage est activé pour Studio, votre nouveau script ne sera pas verrouillé tant que vous ne l'aurez pas sauvegardé.

  1. Dans Studio, cliquez sur Nouveau Une petite fenêtre de programme informatique avec un fichier devant elle et une étincelle. dans la barre d'outils.

  2. Sélectionnez le type de script que vous souhaitez créer dans la liste à droite de la fenêtre. Si vous ne voyez pas les types de script à droite de la fenêtre, vérifiez que General Purpose Scripts est sélectionné sous Modèles disponibles.

  3. Cliquez sur OK. Une toile de script vierge s'ouvre dans Studio.
  4. Cliquez sur Sauvegarder et indiquez un nom pour votre script. Choisissez le nom avec soin. Vous ne pouvez pas renommer les scripts une fois qu'ils sont sauvegardés.

Créer un script à partir d'un modèle

Autorisations requises : Créer/Modifier des scripts studio

Si le verrouillage est activé pour Studio, votre nouveau script ne sera pas verrouillé tant que vous ne l'aurez pas sauvegardé.

  1. Dans Studio, cliquez sur Nouveau Une petite fenêtre de programme informatique avec un fichier devant elle et une étincelle. dans la barre d'outils.

  2. Sélectionnez une catégorie de modèle sous Scripts spécialisés dans Modèles disponibles, puis cliquez sur le modèle que vous souhaitez utiliser dans la liste de droite.

  3. Cliquez sur OK.
  4. Sauvegardez le script. Choisissez le nom avec soin. Vous ne pouvez pas renommer les scripts une fois qu'ils sont sauvegardés.

Ouvrir un script

Autorisations requises : Créer/Modifier des scripts studio

Vous pouvez ouvrir un script en :

  • En cliquant sur Fichier > Ouvrir, en sélectionnant un script, puis en cliquant sur Sélectionner.
  • En cliquant sur Ouvrir Un dossier de fichiers manille ouvert avec une flèche qui en sort. dans la barre d'outils, en sélectionnant un script, puis en cliquant sur Sélectionner.
  • Searching un script sous l'onglet Rechercher, puis double-cliquez sur celui que vous souhaitez ouvrir.
  • Utilisez l’onglet Parcourir pour localiser un script et double-cliquez sur celui que vous souhaitez ouvrir.

Ne modifiez jamais directement un script de production. Les modifications Sauvegardées prennent effet immédiatement. Si un changement cause un problème avec un script, cela pourrait avoir une incidence sur la capacité de votre centre de contact à fonctionner. Si vous devez apporter des modifications, utilisez Enregistrer sous pour créer une copie du script et lui donner un nom qui indique qu'il est en cours de développement. Uniquement mettez-le en production lorsqu'il est entièrement testé et prêt.

Importer un script

Autorisations requises : Importer/Exporter des scripts dans Studio

Vous pouvez importer un script à partir d'un fichier XML.

  1. Dans Studio, cliquez sur Fichier > Importer à partir d'un fichier.
  2. Accédez à l'emplacement du script que vous souhaitez importer, sélectionnez-le et cliquez sur Ouvert.
  3. Cliquez sur Enregistrer.
  4. Dans la fenêtre Enregistrer le script sous, choisissez le dossier dans lequel vous souhaitez enregistrer le script.
  5. Entrez un nouveau Nom du fichier pour le script si vous souhaitez le modifier. Les scripts ne peuvent pas être renommés une fois sauvegardés.
  6. Cliquez sur Enregistrer.

Exporter un script

Autorisations requises : Importer/Exporter des scripts dans Studio

Vous pouvez exporter un script sous forme de fichier XML.

  1. Dans Studio, cliquez sur Fichier > Exporter vers un fichier.
  2. Accédez à l'emplacement sur votre ordinateur où vous souhaitez enregistrer le script exporté.
  3. Entrez un Nom de fichier pour le script et cliquez sur Sauvegarder.

Ajouter et configurer une action dans un script

Autorisations requises : Créer/Modifier des scripts studio

Actions sont les éléments constitutifs de tous les scripts. La plupart des actions possèdent un ensemble de propriétés qui doivent être configurées pour définir le comportement de l'action pour le script spécifique que vous créez. Consultez l'aide en ligne de chaque action pour obtenir des informations sur les propriétés de celle-ci. Sélectionnez l'action sur le canevas du script et appuyez sur F1 sur votre clavier. La page d'aide se charge dans votre navigateur par défaut.

Cette section décrit l'ajout d'une action à partir de l'onglet Outils. Si l'onglet Framework est activé dans Studio, vous pouvez ajouter des actions à partir de celui-ci.

  1. Dans Studio, créez ou ouvrez un script.
  2. Sous l'onglet Outils, localisez l'action que vous souhaitez ajouter. Vous pouvez trouver des actions en :

    • Entrant du texte dans le champ Filtre pour rechercher une action. Vous pouvez effectuer une recherche en utilisant un nom complet ou partiel. Par exemple, si vous entrez ai, la recherche trouve toutes les actions dont les noms contiennent ces lettres n'importe où dans leur nom.
    • Cliquant sur Catégories pour basculer entre l'affichage des actions par catégorie ou dans une seule longue liste.
    • Cliquant sur Alphabétique pour basculer entre l'affichage des actions en ordre alphabétique ou dans leur ordre par défaut.
  3. Cliquez sur l'action que vous souhaitez ajouter. Vous n'avez pas besoin de cliquer et de maintenir.
  4. Cliquez sur le canevas de script pour placer l'action.
  5. Sélectionnez l'action et faites un clic droit pour faire apparaître la fenêtre Properties . Vous pouvez également cliquer sur l'onglet propriétés.

  6. Modifiez la propriété Caption par un mot descriptif ou une courte phrase indiquant ce que fait cette action dans le script. Par exemple, pour une action Play, changez la légende pour le nom du fichier audio qu'elle lit.
  7. Configurez les autres propriétés selon vos besoins. Vous pouvez configurer les propriétés en :

    • sélection d'une option : Cliquez sur l'icône de la flèche vers le bas Un chevron pointant vers le bas. qui apparaît à droite du champ, puis sélectionnez une option dans la liste déroulante.
    • Utilisation de la fenêtre Éditeur d'expression : Cliquez sur l'icône d'ellipse Une ellipse ou une série de trois points alignés. qui apparaît à droite du champ, puis entrez du texte dans la fenêtre Éditeur d'expression.
    • Saisie directe de texte : Cliquez dans le champ et entrez le texte directement. Certaines propriétés nécessitent du texte statique ou des variables, mais de nombreuses propriétés peuvent accepter les deux.
    • Double-cliquer sur l’action : Certaines actions ont des paramètres de configuration supplémentaires auxquels vous pouvez accéder de cette manière.
  8. Enregistrez vos modifications dans le script.

Ajouter une action à partir de l'onglet Cadre

Autorisations requises : Créer/Modifier des scripts studio

L'onglet Cadre contient une liste complète de toutes les actions disponibles dans Studio. Certaines des actions de cet onglet sont des actions système ou internes qui ne peuvent être utilisées qu'après avoir consulté un représentant de compte. Utilisez avec prudence les actions inconnues de cet onglet.

L'onglet Cadre n'est visible que si un représentant de compte l'a activé pour vous. En savoir plus sur l'onglet Cadre et sur les actions qu'il contient.

  1. Dans Studio, créez ou ouvrez un script.
  2. Sous l'onglet Cadre, agrandissez les dossiers pour localiser l'action que vous souhaitez ajouter.
  3. Cliquez et faites glisser l'action vers le canevas du script.

Connecter des actions et créer des branches

Autorisations requises : Créer/Modifier des scripts studio

  1. Dans Studio, créez ou ouvrez un script.
  2. Ajoutez au moins deux actions au canevas.
  3. Passez le curseur sur la première action, puis cliquez et maintenez la flèche Une flèche pointant vers la droite. dans le coin inférieur droit de l'icône de l'action pour démarrer un connecteur.
  4. Connectez la première action à la deuxième en faisant glisser le curseur loin de l'action et en le déposant sur la deuxième action. Si la première action a plus d'une condition de branche disponible, la fenêtre PickBranch apparaît.

  5. Dans la fenêtre PickBranch , sélectionnez la condition de branche que vous voulez utiliser pour cette connexion. Dans la plupart des cas, si l'action se connecte à une seule autre action, vous devriez utiliser la branche Default. Pour plus d'informations sur chacune des conditions de branche d'une action, reportez-vous à l'aide en ligne de l'action. Vous pouvez sélectionner une action et appuyer sur F1 sur votre clavier pour ouvrir sa page d'aide.

  6. Cliquez sur OK.
  7. Répétez les étapes 3 à 5 pour connecter d'autres actions. Si vous connectez une action à plus d'une autre action, utilisez une condition de branche différente pour chaque connexion. Vous devriez toujours créer une branche qui utilise la condition de branche Default. Cela donne au script une option à suivre si aucune des autres branches ne s'applique.
  8. Rearrange actions on the canvas if you need to make space for connections. Attached connectors move with an action. If you want to move more than one action at a time, you can: 
    • Cliquez sur le canevas et faites glisser le curseur pour dessiner un cadre de sélection autour des actions que vous voulez déplacer. Les actions sélectionnées sont surlignées en rouge. Cliquez sur l'une des actions sélectionnées pour faire glisser le groupe vers un nouvel emplacement.
    • Appuyez sur CTRL et cliquez sur chaque action que vous voulez déplacer, puis cliquez sur l'une des actions sélectionnées et faites glisser le groupe vers un nouvel emplacement.
    • Click an action, then click Edit Selection in the Studio menu bar. Choose an option based on what you want to happen, then drag the highlighted actions to a new location: 
      • Sélectionner tout ci-dessus : Toutes les actions au-dessus de l'action sélectionnée sur toute la largeur du script sont mises en surbrillance.
      • Sélectionner tout ci-dessous : Toutes les actions au-dessous de l'action sélectionnée sur toute la largeur du script sont mises en surbrillance.
      • Sélectionner tout à la droite—Toutes les actions à la droite de l'action sélectionnée sur toute la hauteur du script sont mises en surbrillance.
      • Sélectionner tout à gauche—Toutes les actions à la gauche de l'action sélectionnée sur toute la hauteur du script sont mises en surbrillance.
  9. Vérifiez que vous n'avez pas d'impasses, où le script est bloqué et n'a aucun moyen de se terminer ou de passer à l'action suivante. Vous pouvez le faire en testant le script.
  10. Enregistrez le script.

Créer des conditions de branche variables

Autorisations requises : Créer/Modifier des scripts studio

Les conditions de branche variables vous permettent de créer des conditions personnalisées qui doivent être remplies pour que le script suive une branche particulière. Cela est utile lors de la création de menus IVRClosed Réponse vocale interactive. Menu téléphonique automatisé que les contacts utilisent par la Voix ou par des touches pour obtenir des informations, acheminer un appel vocal entrant, ou les deux.. Vous pouvez créer une branche pour chaque option de menu et définir la condition de chacune comme étant le nombre que le contact doit entrer pour sélectionner cette option.

  1. Dans Studio, créez ou ouvrez un script.
  2. Ajoutez au moins deux actions au canevas.
  3. Placez le curseur sur la première action, puis cliquez et maintenez la flèche An arrow pointing to the right right. dans le coin inférieur droit de l'icône de l'action pour démarrer un connecteur.
  4. Connectez la première action à la deuxième en faisant glisser le curseur loin de l'action et en le déposant sur la deuxième action. La fenêtre PickBranch apparaît.

  5. Cliquez sur l'icône + dans la fenêtre PickBranch .

  6. Dans le champ qui apparaît sous Variable Branch Condit, entrez le nom de la condition que vous créez. Par exemple, pour créer une option de menu pour le cas où le contact appuie sur 3, entrez 3 dans le champ.
  7. Cliquez sur OK. Sur la zone de travail, le nom du rectangle variable apparaît dans un rectangle au-dessus du connecteur. Vous pouvez voir un exemple de ceci dans l'image suivante.

Supprimer un Connecteur

Autorisations requises : Créer/Modifier des scripts studio

  1. Dans Studio, cliquez sur la flèche dans le connecteur que vous souhaitez supprimer.
  2. Appuyez sur la touche supprimer du clavier ou cliquez sur Édition > supprimer.

Modifier la forme d'un Connecteur

Autorisations requises : Créer/Modifier des scripts studio

Vous pouvez faire plier et courber les connecteurs afin qu'ils s'intègrent mieux dans votre script. Cela peut vous aider à garder vos scripts ordonnés et plus faciles à lire.

  1. Dans Studio, ouvrez un script.
  2. Appuyez et maintenez CTRL + Maj sur le clavier et placez le curseur sur le connecteur dont vous souhaitez modifier la forme jusqu’à ce que la ligne devienne bleue.

  3. Pendant que la ligne est encore bleue, faites un clic droit sur le connecteur. Un petit carré bleu apparaît. Il s'agit d'un point d'ancrage.

  4. Cliquez et maintenez le point d'ancrage et faites-le glisser dans n'importe quelle direction jusqu'à ce que le connecteur ait la forme souhaitée.

  5. Vous pouvez répéter les étapes 2 à 4 sur le même connecteur pour ajouter plus de points d'ancrage si vous souhaitez ajouter plus de courbes au connecteur.

  6. Cliquez sur la flèche du connecteur pour voir tous les points d'ancrage sur la ligne.
  7. Supprimez un seul point d'ancrage en appuyant sur CTRL + Shift sur le clavier, puis en cliquant avec le bouton droit sur le point d'ancrage que vous souhaitez supprimer. Le point d'ancrage disparaît et la courbe de la ligne du connecteur s'ajuste automatiquement.
  8. Si vous souhaitez supprimer l'ensemble du connecteur, cliquez sur la flèche du connecteur pour qu'elle devienne rouge. Appuyez sur Delete.

Verrouiller et déverrouiller des scripts

autorisations requises : Affichage, création et modification des scripts Studio

Si le verrouillage est activé pour les scripts Studio, vous pouvez verrouiller et déverrouiller les scripts sur lesquels vous travaillez. Les scripts déverrouillés sont en lecture seule. Pour modifier un script, vous devez le verrouiller. Cela vous permet de travailler dessus, mais empêche les autres utilisateurs d'enregistrer des modifications qui y sont apportées.

Si vous tentez d'ouvrir un script verrouillé par un autre utilisateur, Studio vous avise que le script est verrouillé. Vous pouvez remplacer un script verrouillé si votre profil NiCE CXone employé dispose de l'autorisation appropriée.

Selon la configuration de Studio, les scripts s'ouvrent soit en mode verrouillé, soit en mode lecture seule par défaut. Lorsque vous créez un nouveau script, il n'est ni verrouillé ni déverrouillé. Lorsque vous enregistrez le script, il est automatiquement verrouillé, même si le comportement par défaut de Studio est configuré pour ouvrir les scripts en mode lecture seule.

  1. Dans Studio, ouvrez un script. Si le verrouillage est activé, le script s'ouvre soit en mode lecture seule (déverrouillé), soit en mode verrouillé, selon la configuration de Studio. Si le verrouillage n'est pas activé, le script s'ouvre avec un arrière-plan de zone de travail blanc et l'icône de l'onglet du script ne se transforme pas en cadenas.
  2. Pour verrouiller un script afin de pouvoir le modifier, cliquez sur l'icône de verrouillage dans la barre d'outils. La zone de travail passe du gris au blanc et l'icône de l'onglet du script se transforme en cadenas.
  3. Pour déverrouiller un script et le mettre en mode lecture seule, cliquez sur l'icône de déverrouillage dans la barre d'outils. La zone de travail passe du blanc au gris et l'icône de l'onglet du script se transforme en icône du type de script.

Remplacer un script verrouillé

autorisations requises : Contournement du verrouillage des scripts Studio

Lorsque vous ouvrez un script verrouillé par un autre utilisateur, Studio affiche une notification. Vous pouvez remplacer le verrouillage d'un script si vous devez le modifier. Lorsque vous remplacez le verrouillage d'un script, les modifications enregistrées par l'autre utilisateur sont conservées. Studio affiche une notification à l'utilisateur lors de sa prochaine connexion. La notification peut l'inviter à revoir les modifications apportées au script. Vous pouvez revoir les modifications en affichant une version précédente du script, ou en ouvrant une version précédente du script et en la comparant à la version actuelle.

  1. Dans Studio, cliquez sur l’onglet Verrouillé .
  2. Sélectionnez le script que vous souhaitez remplacer et cliquez sur Éjecter .
  3. Cliquez sur OK lorsque vous êtes invité à confirmer que vous souhaitez exclure l'autre utilisateur de la modification du script.