Gérer les scripts (Desktop Studio)

Cette page d'aide s'applique à Desktop Studio. Ces informations sont aussi disponibles pour Studio.

Cette page fournit des informations sur les tâches que vous pourriez avoir à effectuer lorsque vous travaillez avec des scripts. En plus des tâches décrites sur cette page, vous pouvez planifier l'exécution de scripts sur la page Script Schedules dans NiCE CXone.

Afficher les propriétés d’un script

Autorisations requises : Affichage des scripts Studio

L'onglet Properties du script vous montre des informations sur le script actuel. À partir d'ici, vous pouvez afficher ou modifier le type de support du script, configurer une interaction entrante simulée à des fins de test, ou configurer la rédaction de variables.

  1. Dans Studio, ouvrez un script.
  2. Cliquez n’importe où dans l’espace vide de l’espace de travail du canevas pour vous assurer qu’aucune action n’est sélectionnée.
  3. Cliquez sur l’onglet propriétés, qui affiche des informations sur le script.

  4. Dans la section informations de base, vous pouvez :

    • Afficher unité commerciale où se trouve le script.

    • Afficher ou modifier le MediaType du script.

    • Afficher si le script a été Modifié depuis sa dernière sauvegarde. Si la valeur est True, le script a été modifié.

    • Afficher le ScriptName.

  5. Dans la section Debug, vous pouvez définir les propriétés utilisées lorsque vous déboguez le script à l'aide d'une trace. Vous pouvez :

  6. Dans la section Library, vous pouvez accéder aux paramètres propres au script, le cas échéant. La plupart des Types de script n'ont aucune propriété dans cette section.

  7. Dans la section Rédaction, vous pouvez configurer la rédaction des variables. Cela permet de supprimer les variables des traces et des journaux.

Afficher l'historique d'un script

Autorisations requises : Affichage des scripts Studio

Le nombre de versions précédentes d'un script que Studio keep est configurable par un administrateur NiCE CXone .

  1. Dans Studio, Cliquer sur L’onglet Parcourir .
  2. Faites un clic droit sur un de script et sélectionnez Historique
  3. Cliquez sur la version que vous souhaitez afficher. Si le verrouillage est activé dans Studio, la version précédente du script s'ouvre en mode lecture seule.

Modifier le Type de support d'un script

Le type de support détermine le type d’interaction que le script peut gérer.

Autorisations requises : Création/modification de scripts Studio

  1. Dans Studio, ouvrez un script.
  2. Cliquez dans un espace vide du canevas de script pour vous assurer qu’aucune action n’est sélectionnée.
  3. Dans l'onglet Properties (propriétés), cliquez sur la flèche déroulante en regard de la propriété MediaType et sélectionnez un nouveau type de support pour le script.
  4. Enregistrez le script.

Mettre un script en production

Autorisations requises : Modification de Points d’accès

Lorsqu'un script est entièrement testé et prêt à être utilisé dans NiCE CXone, vous pouvez le mettre en production. Pour ce faire, vous devez attribuer un script à un point de contactClosed point d’entrée qu’un contact entrant utilise pour amorcer une interaction, comme un numéro de téléphone ou une adresse courriel. dans NiCE CXone ACD.

Si vous utilisez une convention de nommage pour identifier les scripts en développement ou en production, cela aide les autres développeurs de scripts de votre organisation à savoir quels scripts sont prêts à être utilisés. Une convention de nommage n'indique pas à NiCE CXone quels scripts utiliser.

N'attribuez des scripts aux points de contact que si vous êtes certain qu'ils sont entièrement testés et prêts pour la production. La mise en production d'un script qui n'est pas prêt peut entraîner un non-acheminement des contacts vers le point de contact sélectionné.

  1. Cliquez sur le sélecteur d'applications icon of app selector et sélectionnez ACD.
  2. Accédez à Paramètres du contact > Point d'accès.

  3. Cliquez sur le point de contact auquel vous souhaitez attribuer un script.
  4. Cliquez sur Modifier.
  5. Sélectionnez le Script que vous souhaitez que ce point de contact utilise.
  6. Cliquez sur Terminé.

Comparer les scripts

Autorisations requises : Affichage des scripts Studio

Vous pouvez comparer deux scripts par légendes, paramètres, Branches ou Position. L'onglet Résultats de la recherche affiche les différences et les similitudes entre les scripts sélectionnés.

  1. Ouvrez les deux scripts que vous souhaitez comparer. Veillez à enregistrer toutes les modifications que vous avez apportées récemment.
  2. Cliquez sur Modifier > Comparer pour ouvrir la fenêtre Compare Scripts.
  3. Sélectionnez un script dans le champ Gauche, et l'autre script dans le champ Droite. Faites attention au script que vous sélectionnez, car tous les scripts actuellement ouverts dans Studio apparaissent dans ces menus déroulants.
  4. Configurez les sections Options générales et Paramètres de comparaison. Ces sections vous permettent de déterminer quels éléments des scripts vous souhaitez comparer. Notez que l'élément Position fait référence aux axes X et Y pour chaque action sur le canevas.

  5. Cliquez sur Comparer. Les résultats s'affichent dans l'onglet Trouver des Résultats. Si l'onglet Trouver des Résultats n'est pas ouvert, cliquez sur Affichage > Trouver des Résultats dans le menu.

Masquer les Variables des traces et des journaux

Autorisations requises : Création/modification de scripts Studio

La rédaction de variable élimine les valeurs de variable des traces et des journaux générés par un script. Vous pouvez masquer des variables et des objets.

La rédaction est configurée au niveau du script dans le champ VariableRedaction des propriétés du script. Les valeurs Masquées sont remplacées par une chaîne de X caractères. La longueur de la valeur de la variable détermine le nombre de X utilisés, ce qui signifie qu'un mot masqué de cinq lettres entraînerait cinq X. La rédaction partielle de variable, comme une partie d'un numéro de carte de crédit, n'est pas prise en charge.

La rédaction de variable se produit au niveau du script. Ce n'est pas une propriété héréditaire. Si une variable masquée est transmise à d'autres scripts, par exemple avec une action RunScript ou RunSub, cette variable n'est pas automatiquement masquée dans les scripts suivants. Si vous souhaitez qu'une variable soit toujours masquée, vous devez configurer la rédaction de variable dans tous les scripts auxquels elle pourrait être transmise.

Les variables transmises à d'autres scripts ont une portée globale. Pour les masquer, vous devez inclure global: avant le nom de variable dans le champ VariableRedaction pour vous assurer qu'elle est masquée.

La meilleure pratique consiste à ne jamais conserver des données sensibles dans un script plus longtemps que nécessaire. En plus de masquer les valeurs de variable, vous pouvez supprimer les données de la variable.

Pour masquer des variables :

  1. Dans NiCE CXone, cliquez sur le sélecteur d'applications et sélectionnez Omnicanal Routing > Studio Three arrows joined at the base. One points straight up, one up and to the right, and one up and to the left. .
  2. Sur la page Scripts, repérez et double-cliquez pour ouvrir le script que vous voulez utiliser. Le script s'ouvre dans un nouvel onglet.
  3. Dans le panneau de propriétés situé à droite du script, cliquez sur l’onglet Variables.
  4. Cliquez sur Masqué Un œil traversé par une ligne diagonale. .

  5. Dans le champ de l'onglet Variables, entrez le nom de chaque variable que vous souhaitez masquer. Appuyez sur entrée après chaque variable. Ces noms doivent correspondre aux variables créées dans les actions Assign ou SNIPPET du script.
  6. Cliquez de nouveau sur Masqué Un œil traversé par une ligne diagonale. pour masquer la liste des noms de variable.

  7. Enregistrez votre script.

Supprimer des Données sensibles d'une variable

En plus de configurer la rédaction de variable, vous pouvez configurer votre script pour supprimer les données sensibles d'une variable. Cela permet de s'assurer qu'elles ne persistent pas dans le script plus longtemps que nécessaire.

  1. Dans votre script, placez une action Snippet après que les données sensibles ont été utilisées et ne sont plus nécessaires.
  2. In the Snippet editor of the Snippet action, add the appropriate line for each variable you want to clear sensitive data from: 
    • Pour un objet de données dynamiques : DYNAMIC <object name>
    • Pour une variable régulière : ASSIGN <var name> = ""
  3. Enregistrez vos modifications.

Désactiver un script

autorisations requises : ACD > Studio > Scripts > Désactiver

Il est impossible de supprimer des scripts de Studio. Vous pouvez toutefois les désactiver. Les scripts désactivés ne sont plus visibles dans Studio, mais ils peuvent être consultés sur la page Scripts dans l'application NiCE CXone ACD.

Vous n'avez pas besoin de désactiver un script pour empêcher NiCE CXone de l'utiliser. NiCE CXone utilise uniquement les scripts qui sont assignés à une compétenceClosed Utilisé pour automatiser la livraison des interactions en fonction des compétences, des aptitudes et des connaissances de l’agent. et à un point de contactClosed point d’entrée qu’un contact entrant utilise pour amorcer une interaction, comme un numéro de téléphone ou une adresse courriel..

  1. Sous l'onglet Parcourir de Studio, localisez le script que vous souhaitez désactiver.
  2. Sélectionnez le script, puis cliquez sur l'icône rouge X A large red X. Click to deactivate a script. en haut de l'onglet.
  3. Confirmez que vous souhaitez désactiver le script sélectionné.
  4. You can add notes to the script to explain why you deactivated the script:
    1. Dans NiCE CXone, cliquez sur le sélecteur d'applications et sélectionnez ACD > Scripts.
    2. Sélectionnez Inactifs dans la liste déroulante Afficher.
    3. Cliquez sur le script et ajoutez vos notes sous l’onglet Notes.

Réactiver un script

autorisations requises : ACD > Studio > Scripts > Désactiver

Vous pouvez réactiver un script pour le rendre à nouveau visible dans Studio.

  1. Dans NiCE CXone, cliquez sur le sélecteur d'applications et sélectionnez ACD > Scripts.
  2. Sélectionnez Inactifs dans la liste déroulante Afficher.
  3. Cliquez le script que vous souhaitez réactiver.
  4. Cliquez sur Activer dans l’onglet Détails de la page du script.

revenir à la version précédente du script

Studio conserve les versions précédentes de tous les scripts. Chaque fois que vous sauvegardez vos modifications, une nouvelle version est ajoutée à l'historique du fichier de script. Vous pouvez revenir à une version précédente d'un fichier de script.

Si vous avez sauvegardé une copie d'un script sous un nom différent et que vous voulez y revenir, ne suivez pas ces étapes. Ouvrez plutôt la copie à laquelle vous voulez revenir et utilisez Enregistrer sous pour créer une nouvelle copie. Vous pouvez désactiver les copies de scripts dont vous n'avez plus besoin, ou vous pouvez les déplacer dans un dossier distinct.

revenir à une version précédente d'un script dans Studio

Autorisations requises : Créer/Modifier des scripts studio

  1. Dans l'onglet Parcourir de Studio, localisez le script que vous souhaitez rétablir.
  2. Faites un clic droit dessus et sélectionnez Historique, puis cliquez sur la version à laquelle vous voulez revenir. La version sélectionnée s'ouvre avec la date et l'heure de sa sauvegarde ajoutées à la fin de son nom. Par exemple, pour un script sauvegardé le 2 Août 2022 à 9 h 32 min 8 s, la fin du nom du script est 08022022093208.
  3. Cliquez sur Fichier > Enregistrer sous et sauvegardez une copie du fichier sous un nouveau nom. Les versions historiques des fichiers de script s'ouvrent de façon permanente en mode en lecture seule.

Revenir à une version précédente d'un script à partir de NiCE CXone

(missing or bad snippet)

Téléverser des Fichiers dans Studio

Vous pouvez téléverser des fichiers vers NiCE CXone à l'aide de Studio. Cela comprend les fichiers audio pour les invites, les fichiers grammaire ASR et plus encore. Vous pouvez aussi afficher, téléverser et gérer les invites et d'autres fichiers sur la page Browse ACD Files dans NiCE CXone.

  1. Dans l'onglet Fichiers de Studio, développez le dossier dans lequel vous voulez téléverser le fichier. Si vous téléversez une invite, développez le dossier Invites.

  2. Cliquez sur téléverser des fichiers Un rectangle avec une flèche pointant vers le haut. et sélectionnez un ou plusieurs fichiers à téléverser, puis cliquez sur Ouvrir. Le fichier est téléversé et apparaît dans la liste de l'onglet.

  3. Vous pouvez également faire glisser un fichier depuis le navigateur de Fichiers de votre ordinateur vers la fenêtre fichiers de Studio.