NiCE CXone Studio

Studio est un outil de script que vous pouvez utiliser pour personnaliser le flux de routage de votre centre de contact afin de répondre aux besoins de votre organisation. Les scripts vous permettent de définir la façon dont les contacts sont acheminés vers les agents les mieux placés pour les aider. Par exemple, vous pouvez utiliser des menus ASRClosed Reconnaissance automatique de la Parole. Permet aux contacts de répondre aux invites en parlant, en appuyant sur des touches du téléphone, ou les deux. ou IVRClosed Réponse vocale interactive. Menu téléphonique automatisé que les contacts utilisent par la Voix ou par des touches pour obtenir des informations, acheminer un appel vocal entrant, ou les deux., ou des agents virtuelsClosed Une application logicielle qui traite les interactions avec les clients à la place d’un agent humain en direct..

Studio possède une interface visuelle de type faire-glisser-abandonner, de sorte que vous n'avez pas besoin d'une vaste expérience en script pour créer des scripts de base. Vous pouvez créer des scripts plus complexes en incluant du code de script personnalisé.

La Studio aide en ligne fournit des informations sur :

Intégrations avec des Systèmes tiers

Studio vous permet d'intégrerNiCE CXone avec des applications et systèmes tiers, y compris :

De plus, Integration Hub vous permet de gérer les intégrations basées sur des API avec des systèmes tiers. Cette fonctionnalité vous permet également de gérer les informations qui nécessitent une sécurité accrue, comme les secrets ou les mots de passe.

Compatibilité des scripts entre Studio et Desktop Studio

Les scripts Studio et Desktop Studio sont compatible. Tout script sauvegardé sur les serveurs NiCE CXone peut être ouvert dans l’une ou l’autre application.

Les scripts ne peuvent pas être exportés d’une application et importés dans l’autre. C’est parce que les scripts Desktop Studio sont XML et les scripts Studio sont JSON. La fonction d’importation ne peut pas convertir entre les formats.

La plupart des actions Studio sont disponibles dans les deux versions de l’application. Si une action n’est pas disponible dans la version de Studio que vous utilisez, vous pouvez tout de même la voir dans le script. Toutefois, il se peut que vous ne puissiez pas modifier les propriétés de ces actions. Vous pouvez ouvrir le script dans la version de Studio que vous avez utilisée à l’origine si vous devez modifier ces actions.

Parité des fonctionnalités avec Desktop Studio

La version de Studio basée sur le navigateur offre une parité des fonctionnalités avec Desktop Studio. Si vous débutez avec Studio, la page d'aide Démarrage avec Studio présente une introduction. Elle décrit également les options disponibles dans l'interface.

Le tableau suivant indique où se trouvent, dans Studio, les fonctionnalités de Desktop Studio que vous avez l'habitude d'utiliser.

Fonctionnalité Desktop Studio Fonctionnalité Studio
Actions: ajoutez des fonctionnalités à votre script.

Toutes les actions sont disponibles dans Studio.

Les actions se trouvent sur deux palettes situées sur la barre d'outils, à gauche du canevas du script :

  • Palette Actions Icon of a square, triangle, and circle : contient toutes les actions disponibles pour votre NiCE CXone système. Les actions disponibles sont déterminées par les produits sous licence activés dans NiCE CXone et par le type de support du script.

  • Palette Actions API Icon of a window with < > inside. : contient les actions qui appellent les API de NiCE CXone. La documentation de ces actions se trouve dans le portail développeur Icon of a square with an arrow point from the center through the top right corner.. En savoir plus sur l'utilisation des Actions API dans vos scripts.

Éditeur d'action Windows : permet d'accéder à des options de configuration supplémentaires.

Pour les actions qui possèdent des fenêtres d'éditeur, il existe deux façons de les ouvrir :

  • Sélectionnez l’action et cliquez sur Éditeur au centre de l’icône de l’action.
  • Sélectionnez l’action et cliquez sur Ouvrir l’Éditeur dans le volet des propriétés de l’action.

La conception et la fonction des fenêtres de l’éditeur continueront d’être améliorées dans les prochaines versions.

Onglet Parcourir: affiche une liste complète des scripts dans l’unité commerciale.

Dans Studio, la page qui se charge lorsque vous accédez à l’application s’appelle la page Scripts. Cette page affiche les scripts disponibles dans votre NiCE CXone système. Vous pouvez filtrer la liste pour afficher uniquement les scripts actifs, uniquement les scripts inactifs, ou tous les scripts.

La page Scripts fournit des informations sur chaque script et vous permet d’effectuer certaines tâches avec les scripts sans quitter la page. Vous pouvez :

  • Créer un nouveau script.
  • Rechercher des scripts. Les Critères sont le nom du script, les actions dans le script, les mots dans la légende, les variables et le type de supportClosed Un moyen, tel que la voix, les courriels et les clavardages, à travers lequel un contact se connecte au destinataire voulu..
  • Afficher le type de support du script, son nom, la date de sa dernière modification, s’il est verrouillé pour l’édition et s’il est actif ou inactif.
  • Exporter un script vers un fichier JSON.
  • Dupliquer un script pour en créer une copie.
  • Désactiver un script.
  • Remplacer un script verrouillé.
  • Copier le chemin d’un script.
  • Charger un fichier de script ou un fichier de trace de script.
Comparer des scripts (Edit > Compare): vous permet de comparer deux scripts par légendes, paramètres, branches ou position. Les Résultats s’affichent dans l’onglet Trouver des Résultats. Vous pouvez comparer deux scripts dans Studio en les ouvrant, puis en sélectionnant Compare dans le menu en haut du canevas de script. Vous pouvez également comparer des versions antérieures du même script. Les Résultats s’affichent au bas de la page.
Connecteurs: Connectez les actions les unes aux autres sur le canevas du script.

Vous pouvez connecter des actions avec des lignes à angle droit, des lignes courbes et des lignes linéaires. Vous pouvez connecter des actions directement à d’autres actions ou à des points d’ancrage de connexion sur l’action. Vous pouvez ajouter des points de sommet aux lignes à angle droit ou courbes en double-cliquant sur le connecteur. Les points de sommet ajoutent des courbures ou des sinuosités supplémentaires au connecteur.

Copier et coller des actions sur le canevas: Vous permet de sélectionner et de copier des actions, puis de les coller à nouveau sur le canevas du script.

Dans Studio, vous pouvez copier et coller une ou plusieurs actions dans le même script ou entre des scripts. Vous pouvez également annuler et rétablir des actions antérieures. Les raccourcis clavier Standard sont pris en charge pour ces tâches.

Créer et modifier des scripts: Vous permet de créer de nouveaux scripts et de modifier ceux existants.

 

Vous pouvez créer et modifier des scripts. Chaque script existe dans un onglet distinct de votre navigateur.
Désactiver: Vous permet de désactiver un script afin qu’il ne puisse plus être utilisé.

Vous pouvez désactiver des scripts à partir du menu Options situé à côté de chaque script sur la page Scripts dans Studio. Vous pouvez également ouvrir le script et sélectionner Désactiver dans le menu central en haut du script.

Vous pouvez réactiver des scripts sur la page Scripts dans l’application ACD. La réactivation des scripts n’est pas prise en charge dans Desktop Studio, mais elle sera ajoutée à Studio dans une version future.

Erreurs et Avertissements (onglet Erreurs du script): Affiche une liste des erreurs ou avertissements dans le script actuel. Les erreurs et avertissements du script s’affichent dans le panneau des propriétés situé du côté droit du canevas du script.
Onglet fichiers: Donne accès aux fichiers de l’unité commercialeClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone.. Vous permet de téléverser des fichiers et d’enregistrer des messages d’invite audio.

Vous pouvez afficher et téléverser des fichiers sur la page Parcourir les fichiers ACD dans la plateforme NiCE CXone. Dans Studio, vous pouvez afficher et téléverser les types de fichiers suivants :

Actuellement, la page Invites ne prend pas encore en charge l’enregistrement de messages d’invite audio, comme le fait l’onglet Fichiers dans Desktop Studio. Dans Studio, vous pouvez enregistrer des messages d’invite audio avec des actions telles que PLAY.

Onglet Framework : affiche une liste complète des actions disponibles dans Studio.

Le côté gauche du canevas du script propose des options pour afficher la palette Actions et la palette API Actions. Ces palettes donnent accès à toutes les actions Studio concédées sous licence à votre NiCE CXone système. La disponibilité de certaines actions dépend du type de support du script.

Importation et exportation de Scripts (Fichier > Importer et Fichier > Exporter) : permet d’enregistrer des copies d’un script en tant que fichier sur votre ordinateur, et d’ajouter une copie sauvegardée d’un script à Studio.

L’Importation et l’exportation fonctionnent de la même façon que dans Desktop Studio. Toutefois, dans Studio, l’importation est appelée chargement et l’exportation est appelée téléchargement.

De plus, les scripts de Studio sont en JSON. Les scripts de Desktop Studio sont en XML. Le processus d’importation ne convertit pas entre les formats. Cela signifie que vous ne pouvez pas importer un script dans Studio qui a été exporté précédemment de Desktop Studio, et vice versa. Toutefois, vous pouvez contourner ce problème en important le script dans l’application à partir de laquelle il a été exporté, puis en l’ouvrant dans l’application désirée.

Multiple instances de Studio : permet d’avoir plus qu’une instance de l’application en cours d’exécution à la fois.

Chaque navigateur peut exécuter deux instances de Studio : une en mode normal et une en mode navigation privée. Vous pouvez exécuter jusqu’à quatre instances en même temps en utilisant Chrome et Microsoft Edge.

Cette fonctionnalité est utile si vous devez vous connecter à plusieurs unités commercialesClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone. en même temps. Vous pouvez ouvrir plus qu’un script dans une seule instance de Studio. Chaque script s’ouvre dans un onglet distinct dans la même fenêtre de navigateur.

Naviguer visuellement dans le canevas du script (onglet Navigate) : affiche une vue miniature du canevas du script que vous pouvez faire défiler pour voir rapidement différentes parties du script. Dans Studio, vous pouvez naviguer dans le canevas du script à l’aide de l’aperçu du canevas. Vous pouvez également utiliser les options situées au bas du panneau des propriétés. Des options supplémentaires vous permettent d’adapter le script à l’écran, d’effectuer un zoom avant et arrière, et de saisir et déplacer le canevas du script à l’aide du curseur.

Onglet Properties (Propriétés de l’action et du script) : affiche les propriétés de l’action sélectionnée ou du script actuel et vous permet de les configurer.

Les propriétés de l’action sélectionnée apparaissent dans le panneau situé à droite du canevas de script. Vous pouvez voir :

  • Le nom de l’action et l’id d’action.

  • Un champ pour modifier l’étiquette de légende de l’action. Vous pouvez également faire un clic droit sur l’icône de l’action sur le canevas du script et sélectionner Ajouter une légende.

  • Un Ouvrir l’Éditeur bouton pour accéder à la fenêtre d’éditeur de l’action. Cette option est disponible uniquement pour les actions qui ont des fenêtres d’éditeur.

  • Properties (Propriétés) pour configurer l’action. Vous pouvez appuyer sur F1 pour ouvrir la page d’aide de l’action sélectionnée.

L'onglet Propriétés Desktop Studio affiche d'autres informations lorsqu'aucune action n'est sélectionnée sur le canevas du script. Ces informations sont disponibles à d'autres endroits dans Studio :

Revenir à la version précédente des scripts: Vous permet de sauvegarder une version précédemment sauvegardée du script et de continuer à y travailler. L'option permettant d'afficher les versions précédentes d'un script, de copier des versions ou de revenir à des versions précédentes d'un script est disponible à partir du menu central en haut du canevas du script. Lorsqu'une version précédente est affichée pour consultation, elle se charge en mode lecture seule. Des Boutons permettant de copier ou de revenir à cette version sont disponibles dans le coin supérieur droit de la page.
Verrouillage et déverrouillage des scripts: Permet de mettre le script en mode lecture seule et en mode modifiable.

Actuellement dans Studio, vous pouvez verrouiller un script pour le modifier et le déverrouiller pour le mettre en mode lecture seule. Vous pouvez outrepasser le verrouillage d'un script verrouillé par un autre utilisateur.

Sur la Page Scripts dans Studio, l'état Verrouillé est affiché pour chaque script. Actuellement, vous ne pouvez pas filtrer la liste des scripts par état de verrouillage ni trier le tableau par la colonne Verrouillé. Cela signifie que vous ne pouvez pas facilement afficher une liste de tous les scripts verrouillés. Cette fonctionnalité sera incluse dans une version future.

Traçage des scripts: Vous permet de tester et de déboguer des scripts.

Actuellement dans Studio, lorsque vous tracez un script, vous pouvez :

Rechercher des Scripts (onglet Scripts): Vous permet de rechercher des scripts dans l'unité commerciale à l'aide du nom du script, de la version et du type de support du script.

Vous pouvez rechercher des scripts sur la Page Scripts dans Studio. Vous pouvez effectuer une recherche par nom du script, par les variables qu'ils contiennent ou par valeur de variable, légende d'action et type de support du script.

Action SNIPPET: Contient une fenêtre d'éditeur qui permet un codage personnalisé.

Actuellement, la fenêtre de l'éditeur de l'action SNIPPET prend en charge le code d'Extrait personnalisé avec coloration syntaxique. Vous pouvez déboguer des extraits depuis la fenêtre de l'éditeur.

L'amélioration de la fonctionnalité de l'éditeur se poursuit.

Modifications non enregistrées: Stocke les modifications du script qui n'ont pas été sauvegardées avant la fermeture de l'onglet du script. Les modifications non enregistrées du script sont sauvegardées dans votre navigateur. Si vous ouvrez un script comportant des modifications non enregistrées, Studio vous invite à choisir si vous voulez ouvrir la version comportant les modifications non enregistrées. Comme les modifications sont sauvegardées dans votre navigateur, l'effacement du cache supprime les modifications non enregistrées. De plus, les modifications stockées sont propres à l'utilisateur et au navigateur.
Onglet Variables: Répertorie les variables du script et les actions qui font référence à chacune d'elles. Une liste des variables du script en cours est disponible dans l’onglet Variables du panneau des propriétés.
Rédaction de variable: Vous permet de préciser les variables d'un script dont les valeurs doivent être omises des traces et des journaux. Vous pouvez masquer les valeurs des variables dans l’onglet Variables du panneau des propriétés.

Historique de vérification et sauvegardes de Script

Lors de la sauvegarde d'un script dans Studio, le système effectue une rotation de version :

  1. Une nouvelle version est créée.

  2. La version précédemment active est définie comme inactive.

  3. La nouvelle version est activée.

Au cours de ce processus, le rapport Historique de vérification peut attribuer la désactivation de la version précédente au dernier utilisateur ayant modifié cette version, plutôt qu'à l'utilisateur effectuant l'enregistrement actuel.