Studio Interfaz de usuario

Esta página es para Desktop Studio. Puede obtener más información sobre la interfaz de Studio en la página de ayuda Cómo Comenzar a usar Studio.

La interfaz de usuario de Studio consta de un lienzo en el centro, rodeado de varias pestañas a la izquierda, a la derecha y en la parte inferior. Estas pestañas brindan acceso a las accionesClosed Realiza un proceso dentro de un script de Studio, como recopilar datos del cliente o reproducir música. de Studio e información tanto sobre las acciones como sobre su script.

Barra de Menú de Studio

El menú principal contiene siete menús desplegables: Archivo, Edición, Ver, Validación, Depurar, Ventana y Ayuda. Muchos de los elementos del menú son comandos comunes, como guardar un archivo o deshacer un cambio. Los comandos comunes no se describen en este tema.

Menú Archivo

Además de los comandos comunes para un menú Archivo genérico, como Nuevo, Abrir, Guardar y Salir, elStudio El menú Archivo contiene estas opciones adicionales:

Opción de menú Detalles
Importación y exportación

Le permite importar un script desde un archivo xml a Studio, o exportar un script a un archivo xml.

Reciente

Proporciona una lista de los scripts que abrió recientemente en Studio para la abonadoClosed Agrupación organizativa de alto nivel utilizada para administrar el soporte técnico, la facturación y la configuración global de su sistema NiCE CXone. en la que inició sesión. Haga clic en un script de la lista para abrirlo en un nuevo panel de lienzo.

Desconectarse y salida Seleccione esta opción para desconectarse de Studio y cerrar la aplicación. Studio recuerda su inicio de sesión incluso después de cerrar la aplicación. Si necesita desconectarse por completo, use esta opción.

Menú de edición

El menú Edición contiene los comandos comunes para los menús Edición, incluidos Deshacer, Cortar, Copiar y Pegar. Puede usar estas opciones con las accionesClosed Realiza un proceso dentro de un script de Studio, como recopilar datos del cliente o reproducir música. de Studio en el lienzo. Los atajos de teclado estándar funcionan para estos comandos (Ctrl+Z, Ctrl+X, Ctrl+C y Ctrl+V). El menú Edición de Studio también incluye estas opciones:

Opción de menú Detalles
Copiar script como Imagen

Copia el script actual a su portapapeles como una imagen. Puede pegar la imagen en otra ubicación, como un correo electrónico o un documento de texto.

Encontrar

Abre la ventana Buscar en script, donde puede search para un texto específico en todos los scripts que tiene abiertos o solo en el script que está abierto en la pestaña superior del Lienzo.

Ir a

Search para y navegar inmediatamente a un id de acción dentro del script actual. Puede ver los id de acciones en el campo ID de la pestaña Actions.

Comparar Permite comparar dos scripts por leyendas, parámetros, ramas o posición. Por ejemplo, un par de scripts puede contener exactamente las mismas acciones y ramas, pero puede contener parámetros diferentes. Al comparar los 2 scripts, puede ver las diferencias (y similitudes) en la pestaña Buscar Resultados.

Ver Menú

El menú Ver proporciona las siguientes opciones:

Opción de menú Detalles
Ayuda > información de Agente Vea información sobre la cuenta NiCE CXone con la que inició sesión actualmente en Studio. La Información aparece en la pestaña propiedades.
Ayuda > información de Inicio de sesión Ver información sobre su sesión actual enStudio.

Navegador,
Instrumentos,
propiedades,
Biblioteca,
Archivos,
Navegación,
Buscar,
Marco de trabajo,
Buscar Resultados

Haga clic en el nombre de la pestaña para abrir esa pestaña en Studio. Esto es útil cuando ha cerrado una pestaña y necesita volver a abrirla.

Si necesita volver a abrir las pestañas Errores de script, Acciones, Variables o Dependencias, consulte lamenú de validación.

Las barras de herramientas > Trace Haga clic para alternar si desea mostrar elRastro opción en la barra de herramientas.

Menú de validación

Opción de menú Detalles
Windows

Haga clic para abrir cualquiera de estas pestañas: Errores de script, Acciones, Variables y Dependencias.

Si necesita abrir pestañas que no están en esta lista, consulte laVer menú.

Verificación de sintaxis

Comprueba un script activo en busca de errores de conexión y propiedad, y muestra advertencias en la pestaña Errores de script. Este es un método básico para probar y depurar su script.

Menú Depurar

permisos requeridos:ACD > Studio > Scripts > Depurar

Opción de menú Detalles
Capturar guión

Capturar un script para rastrear y documentar su progreso mientras se ejecuta. Puede elegir capturar solo la Siguiente instancia o capturar de manera continua a medida que se ejecuta. A medida que se activa cada acción en el script, la información resultante aparece en la herramienta de Salida de seguimiento. Si captura un script de manera continua, los archivos de seguimiento se guardan en el servidor de medios NiCE CXone. Puede usar Depurar > Cargar archivo de seguimiento Remoto para ver estos archivos de seguimiento.

Comience con Trace

Inicia el script activo y abre la ventana de Salida de seguimiento para mostrar los resultados de la ejecución del script. También puede comenzar un seguimiento desde la barra de herramientas usando el botón Comience con Trace .

Cargar archivo de seguimiento de depuración

Busque un archivo de seguimiento y ábralo en la ventana Salida de seguimiento.

Cargar archivo de seguimiento Remoto

Busque un archivo de seguimiento en la plataforma NiCE CXone y ábralo en la ventana de Salida de Seguimiento.

Menú de ventana

El menú Ventana le permite navegar entre los scripts abiertos en Studio. Seleccionar un script en este menú lo trae al frente como la pestaña activa. Si solo tiene un script abierto, hay una sola opción en este menú.

Menú de ayuda

El menú Ayuda proporciona opciones para acceder a laStudio ayuda en línea, así como otra información que puede ayudarlo conStudio.

Opción de menú Detalles
NiCE CXoneStudio Documentación

Abre una nueva pestaña del navegador en su navegador predeterminado y carga la página perspectiva general de Studio de la ayuda en línea.

Ayuda sensible al contexto F1

Muestra el tema de ayuda en línea para la acción que está seleccionada actualmente en el lienzo. También puede presionar F1 en el teclado para acceder al tema de ayuda de la acción seleccionada. Los temas de ayuda se cargan en una nueva pestaña del navegador predeterminado.

Configuración de unidad de negocio

Muestra información sobre cómo está configurada su abonado. Es posible que deba consultar esta información si no está seguro de qué aplicaciones o funciones están habilitadas, como los tipos de canal.

Solución de problemas > Descargar manualmente el programa CefSharp Inicia una nueva descarga de CefSharp, un complemento que requiere Studio para ejecutarse.
Solución de problemas > borrar caché BorraStudiocaché de, que puede ser útil si la aplicación no funciona como se esperaba.
Sobre

Muestra información básica sobreStudio, como la versión.

Barra de herramientas de Studio

La barra de herramientas ofrece una combinación de comandos genéricos, como abrir o guardar un script, yStudio-comandos específicos.

Opción de barra de herramientas Detalles
Aumentar / reducir el espacio

Haga clic para aumentar o disminuir la cantidad de espacio entre las acciones en el lienzo. Cada clic cambia la cantidad de espacio en una pequeña cantidad.

Comience con Trace Le permite iniciar un seguimiento.
Guión de seguimiento

El seguimiento de una secuencia de comandos inicia la secuencia de comandos activa y abre la ventana de Salida de seguimiento para mostrar los resultados de la secuencia de comandos en ejecución. La barra de herramientas proporciona 3 comandos relacionados con el seguimiento de una secuencia de comandos: comenzar el seguimiento, seleccionar un ANIClosed También conocido como id de llamada. número de teléfono listado de una llamada de voz entrante. o DNISClosed El número marcado en llamadas de voz entrantes o salientes. con el cual hacer el seguimiento de la secuencia de comandos, o las opciones para hacer el seguimiento y capturar la siguiente instancia en que se ejecuta la secuencia de comandos, o hacer el seguimiento y capturar continuamente cada instancia de la secuencia de comandos a medida que se ejecuta (importante para las secuencias de comandos de producción). Consulte la página Depurar Scripts en Desktop Studio para obtener más información.

Bloquear / Desbloquear Scripts

Haga clic para bloquear o desbloquear un script. Bloquear coloca un script en modo de solo lectura. Desbloquearlo le permite editarlo, pero ningún otro usuario de Studio puede editarlo al mismo tiempo. Otros usuarios pueden modificar el script después de que usted lo desbloquee o lo guarde y cierre.

Cuando una secuencia de comandos está bloqueada, el fondo del lienzo aparece en blanco y el icono de secuencia de comandos en la pestaña es un candado cerrado. Cuando una secuencia de comandos está desbloqueada, el fondo del lienzo aparece en gris y el icono se muestra como el icono del tipo de secuencia de comandos.

Esta opción aparece en Studio solo si el bloqueo de scripts está habilitado. Su administrador de NiCE CXone puede habilitar esta opción.

Si tiene el permiso Bloquear anulación de Scripts, puede anular el bloqueo de otro usuario en un script para poder editarlo. Puede ver todos los scripts bloqueados en su AbonadoClosed Agrupación organizativa de alto nivel utilizada para administrar el soporte técnico, la facturación y la configuración global de su sistema NiCE CXone. en la pestaña Bloqueados.

Lienzo de Studio

El lienzo es el espacio grande en el centro de la intefaz de Studio. Es donde se crea un script. Puede arrastrar acciones desde las pestañas Herramientas o Marco tabs hacia el lienzo. Los scripts se abren como nuevas pestañas del lienzo, al igual que un navegador web.

En el lienzo puedes:

  • Haga clic en las pestañas o use el menú Ventana para cambiar entre guiones abiertos.
  • Cierre una pestaña de script haciendo clic en X en el lienzo. La X no se encuentra en la pestaña del script, como en algunos navegadores web. Está ubicada en la esquina superior derecha de la ventana del lienzo.
  • Si hace clic en el espacio en blanco del lienzo y luego selecciona la pestaña Properties tab, puede acceder a las propiedades del script.
  • Si cierra todas las pestañas del script, puede reemplazar el lienzo porcreando un nuevo guión.

Fichas de Studio

Las fichas brindan acceso a mucha información diferente que usted necesita mientras trabaja en Studio. De forma predeterminada, las fichas se dividen en tres grupos. Los grupos se ubican a la izquierda, a la derecha y en la parte inferior del lienzo. Todas las fichas son visibles de forma predeterminada. Si cierra una ficha, puede volver a abrirla utilizando el menú Ver o el menú Validación > Windows. Consulte la imagen en la parte superior de esta página para obtener una guía visual del diseño predeterminado.

Grupos de pestañas predeterminados

Los grupos de pestañas predeterminados son:

  • Left side: These tabs are located on the left side of the Studio window by default:
    • Navegar
    • Las dependencias
    • Variables
    • Acciones
  • Right side: These tabs are located on the right side of the Studio window by default: 
    • Marco
    • Instrumentos
    • Biblioteca
    • Buscar
    • Propiedades
  • Bottom: These tabs are located at the bottom of the Studio window by default: 
    • Buscar Resultados
    • Archivos
    • Errores de secuencia de comandos
    • Búsqueda

Reorganizar pestañas

La ubicación de las pestañas es personalizable. Puede:

  • Arrastre y suelte pestañas una encima de otra para moverlas a otras ubicaciones en Studio. Si toma la barra de título de una pestaña, se mueve toda la pila de pestañas. Si desea mover solo una pestaña, tome el otro extremo de la pestaña (la parte que en realidad parece una pestaña).
  • Fije un grupo de pestañas al borde de la ventana de la interfaz haciendo clic en el icono de fijar en la esquina superior derecha de la pestaña. Cuando hace clic en una pestaña fijada, esta se desliza para que pueda usarla. Cuando hace clic fuera de él, se minimiza de nuevo al borde anclado.

  • Use las zonas de descarte para colocar las pestañas. Cuando hace clic en la barra de título de una pestaña y la arrastra fuera de su ubicación actual, la interfaz de Studio muestra iconos de zona de descarte para todos los lugares donde puede anclar la pestaña. Coloque el cursor sobre una zona de descarte y suelte el botón del mouse.

Pestaña Acciones

La pestaña Acciones muestra una lista de todas las acciones que se encuentran actualmente en el script. Las acciones se enumeran en el orden en que se agregaron al script. Esta pestaña muestra la siguiente información sobre cada Acción:

  • Subtítulo: Este es el texto que aparece debajo del icono de la acción en el lienzo. De forma predeterminada, el subtítulo es el mismo que el nombre de la acción. Puede cambiar el subtítulo de cualquier acción en las propiedades de la acción. Esta es una forma útil de anotar lo que la Acción está logrando en el script. Por ejemplo, para cada acción Snippet , podría cambiar el subtítulo para indicar lo que esa instancia de Snippet está haciendo en el script.

  • Nombre de la herramienta: El nombre de la acción. Este nombre no se puede modificar.
  • ID: El id de acción asignado a la acción según el orden en que se agregó al lienzo. Cada instancia de una acción en un script dado tiene un número único.

Pestaña Examinar

La pestaña Examinar muestra las carpetas Studio, donde se almacenan todos los scripts que crea para esta abonado. Puede hacer lo siguiente:

  • Abra los scripts desde esta pestaña haciendo doble clic en un script. Se abre en una pestaña del lienzo.
  • Vea el historial de la secuencia de comandos haciendo clic con el botón derecho en una secuencia de comandos y pasando el cursor sobreHistoria.
  • Abra una versión anterior de un script haciendo clic en la versión que desea ver en la lista Historial.
  • Vuelva a una versión anterior de una secuencia de comandos abriendo la versión anterior de la secuencia de comandos y haciendo clic enGuardar como, luego eligiendo el script en la lista.

La página Scripts en la aplicación NiCE CXone ACD también le permite revertir a una versión anterior de un script si cuenta con los permisos adecuados.

Pestaña Dependencias

Muestra las relaciones entre las acciones del guión activo.

Ficha Archivos

permisos requeridos: ACD > Studio > Explorador de archivos > Ver

La ficha Archivos contiene todas las grabaciones de indicaciones de voz utilizadas en los scripts. Estos archivos se almacenan en su abonado. Puede ver información básica sobre el archivo de indicación (fecha de la última modificación, propósito, descripción y duración del archivo al reproducirse). Puede cargar nuevos avisos desde esta pestaña.

Pestaña Buscar Resultados

Muestra los resultados de comparar con la opción Editar > Comparar .

Pestaña Marco

Contiene una lista completa de todosStudio comportamiento.

Because some of the actions on this tab are more advanced, they're not made available to all users by default. If you don't see the tab in Desktop Studio, it hasn't been enabled for your business unitClosed Agrupación organizativa de alto nivel utilizada para administrar el soporte técnico, la facturación y la configuración global de su sistema NiCE CXone.. If your organization has a need that can be met by using a Framework action, your account representative can enable the Framework tab in your business unit.

If you have access to the Framework tab, be cautious about using unfamiliar actions. Many of the actions aren't documented in the online help. You can ask your account representative or submit a question to the NiCE CXone customer community to learn more about what an action does.

Obtenga más información sobre las acciones disponibles en esta pestaña en la página de ayuda Acciones de marco.

Pestaña bloqueada

permisos requeridos: ACD > Studio > Scripts > Anular bloqueo

Muestra una lista de los scripts que se han bloqueado. Si su cuenta de usuario de NiCE CXone tiene el permiso Bloquear anulación, puede anular el bloqueo de un script. Desbloquee un script haciendo clic con el botón derecho en el script y seleccionando Expulsar a <usuario> de la edición del script o haciendo clic en el botón Expulsar (indicado con una flecha roja).

Pestaña Navegar

Permite desplazarse rápidamente por scripts más grandes sin usar las barras de desplazamiento. El cuadro rojo muestra lo que puede ver en el lienzo.

Ficha propiedades

La ficha propiedades muestra información sobre la acción que está seleccionada actualmente. Si no hay ninguna acción seleccionada, esta ficha muestra información sobre todo el script.

Cada acción tiene un conjunto único de variables, ramas y parámetros. Puede configurarlos en las propiedades de la acción para definir cómo desea que funcione la acción en el script. También puede ver las propiedades de la acción haciendo clic con el botón derecho en la acción y seleccionando propiedades.

Las propiedades del script le permiten simular una llamada entrante para probar el script. También puede redactar una o más variables en el script.

Errores de secuencia de comandos

La pestaña Errores de secuencia de comandos muestra cualquier advertencia y error relacionado con su secuencia de comandos. La pestaña no mostrará nada hasta que guarde el script o ejecute una comprobación de sintaxis. Las advertencias no evitan que se ejecute o se guarde el script, pero los errores sí.

Pestaña de búsqueda

Permite buscar un script específico. Puede acotar la búsqueda usando un nombre de script parcial, unidad de negocio, versiones antiguas y nuevas, y tipos de script.

Pestaña de herramientas

Muestra las acciones más utilizadas. Haga clic en el icono de categorías para cambiar cómo se organizan las acciones. Puede hacer que se muestren por categorías o en orden alfabético. Cuando las acciones están en orden alfabético, puede hacer clic en el icono de ordenar para invertir el orden de la lista.

La agrupación de categorías predeterminadas se llama paleta. Puede crear sus propias categorías y paletas haciendo clic en el icono de paleta en la esquina superior derecha de la ficha Herramientas. La paleta predeterminada contiene estas categorías:

Categoría Descripción
Estándar Acciones básicas y generales utilizadas en cualquier tipo de script.
Voz extra Acciones comunes utilizadas para scripts de tipo de soporte de medios de voz.
Avanzado Acciones avanzadas utilizadas normalmente por desarrolladores de scripts experimentados.
Acceso a los datos Acciones relacionadas con el acceso a datos de inData o bases de datos de clientes.
System Acciones utilizadas para el almacenamiento y manipulación de archivos.
Eventos Acciones provocadas porNiCE CXone.
Web Acciones utilizadas por scripts de sistema. Los scripts de Sistema son scripts predeterminados que NiCE CXone usa internamente.
Habla Acciones relacionadas con el reconocimiento automático de Voz (ASRClosed Reconocimiento automático de Voz. Permite a los contactos responder a los avisos hablando, presionando teclas del teléfono o ambas opciones.).
WFO Acciones relacionadas conCompromiso de la fuerza laboral (WEM).
Personal Connection Acciones relacionadas conNiCE CXonePersonal Connection.
NiCE CXoneAutenticación personalizada Acciones relacionadas con la autenticación del cliente.
Automatización e AI Acciones relacionadas con AI automatizada, como asistentes de agentesClosed aplicación de software que proporciona ayuda específica según el contexto para el agente. y bots de agentes virtualesClosed Una aplicación de software que maneja las interacciones del cliente en lugar de un agente humano en vivo..

Pestaña Variables

Muestra las variables disponibles en el script activo y las acciones que hacen referencia a cada una.

Atajos de teclado

Studio utiliza muchos de los atajos de teclado más conocidos, como CTRL + C para copiar algo, pero también ofrece muchos más atajos para optimizar su flujo de trabajo.

Atajo Acción
CTRL + A Selecciona todos los iconos de acción en la secuencia de comandos activa.
CTRL + C Realiza la función de copia estándar de Windows.
CTRL + E Abre la ventana de Exportar a Archivo.
CTRL + F Abre el cuadro de diálogo Buscar en secuencia de comandos.
CTRL + G Va a un elemento de acción de secuencias de comandos específicos (es decir, se selecciona un icono de acción en la secuencia de comandos activa basada en la ID que entrar).
CTRL + I Abre la ventana Importar desde archivo....
CTRL + N Abre la ventana Crear nuevo script.
CTRL + O Abre la ventana Abrir guión desde....
CTRL + S Guarda los cambios en la secuencia de comandos activa solamente.
CTRL + MAYÚS + S Guarda los cambios realizados en todos los scripts abiertos.
CTRL + T Captura traza un script para la siguiente aparición solamente.
CTRL + MAYÚS + T Comienza un continuo seguimiento de script que se ejecuta manualmente hasta que terminó.
CTRL + V Estándar de Windows realiza la función "pegar".
CTRL + X Estándar de Windows realiza la función "cortar".
CTRL + Y Revierte el script a su estado antes de un "deshacer".
CTRL + Z Realiza la función "undo" de Windows (es decir, devuelve el script a su estado antes de su último cambio).
Del o Borrar Elimina el elemento seleccionado.
F1 Inicia la ayuda en línea de una acción seleccionada.
CTRL + F2 Abre la pestaña Examinar.
CTRL + MAYÚS + F2 Abre la pestaña Marco.
CTRL + F3 Abre la pestaña Herramientas.
CTRL + MAYÚS + F3 Abre la pestaña Buscar Resultados (consulte el cuadro de diálogo Buscar en secuencia de comandos).
CTRL + F4 Abre la pestaña propiedades.
CTRL + MAYÚS + F4 Abre la pestaña Bloqueado.
F5 Abre la ventana Salida de seguimiento.
CTRL + F6 Abre la pestaña Archivos.
SHIFT + F6 Comprueba la sintaxis del script activo y abre la pestaña Errores de script.
CTRL + F7 Abre la pestaña Navegar.
CTRL + F9 Abre la pestaña Buscar.