Administrar Scripts (Desktop Studio)

This help page is for Desktop Studio. This information is also available for Studio.

Esta página proporciona información sobre las tareas que puede necesitar realizar al trabajar con scripts. Además de las tareas descritas en esta página, puede programar la ejecución de scripts en la página programación de Scripts en NiCE CXone.

Ver las propiedades de un Script

Permisos necesarios: Vista Scripts de Studio

La pestaña propiedades del script le muestra información sobre el script actual. Desde aquí, puede ver o cambiar el tipo de soporte de medios del script, configurar una interacción entrante simulada para pruebas, o configurar la modificación de variables.

  1. En Studio, abre un script.
  2. Haga clic en cualquier lugar del espacio en blanco del espacio de trabajo del lienzo para asegurarse de que no estén seleccionadas acciones.
  3. Haga clic en la pestaña propiedades, que muestra información sobre el script.

  4. En la sección Básica, puede:

    • Ver la UnidadNegocio adonde su ubica el script.

    • Ver o cambiar el MediaType del script.

    • Ver si el script se ha Modificado desde la última vez que se guardó. Si es True, el script ha cambiado.

    • Ver el NombreScript.

  5. En la sección Depurar, puede definir las propiedades que se usan al depurar el script con un seguimiento. Puede:

  6. En la sección Biblioteca, puede acceder a la configuración específica del script, si la hay. La mayoría de los tipos de script no tienen propiedades en esta section.

  7. En la sección Modificación, puede configurar la modificación de variables. Esto elimina variables de los seguimientos y registros.

Ver el historial de un script

Permisos necesarios: Vista Scripts de Studio

El número de versiones anteriores de un script queStudio mantiene es configurable por un NiCE CXone administrador.

  1. En Studio, haga clic en la pestaña Navegar.
  2. Haga clic con el botón derecho en un script y haga clic en Historia
  3. Haga clic en la versión que desea ver. Si el bloqueo está habilitado en Studio, la versión anterior del script se abre en modo de solo lectura.

Cambiar el Tipo de soporte de medios de un script

El tipo de medio determina el tipo de interacción que puede manejar el script.

Permisos necesarios: Crear/Editar Scripts de Studio

  1. En Studio, abre un script.
  2. Haga clic en un espacio vacío en el lienzo del script para asegurarse que no se seleccione ninguna acción.
  3. En la pestaña propiedades, haga clic en la flecha desplegable junto a la propiedad MediaType y seleccione un nuevo tipo de soporte de medios para el script.
  4. Guarde el script.

Poner un script en producción

Permisos necesarios:Editar Puntos de contacto

Cuando un script está completamente probado y listo para usarse en NiCE CXone, puede ponerlo en producción. Para hacerlo, debe asignar un script a un punto de contactoClosed punto de entrada que utiliza un contacto entrante para iniciar una interacción, como un número de teléfono o una dirección de correo electrónico. en NiCE CXone ACD.

Si utiliza una convención de nomenclatura para identificar los scripts que están en desarrollo o en producción, esto le ayuda a usted y a otros desarrolladores de scripts de su organización a saber cuáles scripts están listos para usarse. Una convención de nomenclatura no le indica a NiCE CXone qué scripts utilizar.

Asigne scripts a los puntos de contacto solo si está seguro de que están completamente probados y listos para producción. Poner en producción un script que no está listo puede ocasionar que los contactos no se enruten para el punto de contacto seleccionado.

  1. Haga clic en el selector de aplicaciones icon of app selector y seleccioneACD.
  2. Vaya a Configuración del contacto > Punto de contacto.

  3. Haga clic en el punto de contacto al que desea asignar un script.
  4. Hacer clicEditar.
  5. Seleccione el Script que desea que utilice este punto de contacto.
  6. Haga clic en Terminado.

Comparar scripts

Permisos necesarios: Vista Scripts de Studio

Puede comparar dos scripts por leyendas, parámetros, ramas o posición. La pestaña Resultados de búsqueda muestra las diferencias y similitudes entre los scripts seleccionados.

  1. Abra ambos scripts que desea comparar. Asegúrese de guardar cualquier cambio que haya realizado recientemente.
  2. Haga clic en Editar > Comparar para abrir la ventana Compare Scripts.
  3. Seleccione un script en el campo Left y el otro script en el campo Right. Preste atención a qué script selecciona, ya que todos los scripts actualmente abiertos en Studio aparecen en estos menús desplegables.
  4. Configure las secciones Opciones generales y Configuración de comparación. Estas secciones le permiten determinar qué elementos de los scripts desea comparar. Tenga en cuenta que el elemento Posición se refiere a los ejes X y Y de cada acción en el lienzo.

  5. Haga clic en Comparar. Los resultados aparecen en la pestaña Buscar Resultados. Si no tiene abierta la pestaña Buscar Resultados, haga clic en Ver > Buscar Resultados en el menú.

Ocultar variables de los seguimientos y registros

Permisos necesarios: Crear/Editar Scripts de Studio

La redacción de variables elimina los valores de las variables de los seguimientos y registros generados por un script. Puede redactar variables y objetos.

La redacción se configura en el nivel de script en el campo VariableRedaction de las propiedades del script. Los valores redactados se reemplazan con una cadena de caracteres X. La longitud del valor de la variable determina cuántas X se utilizan, lo que significa que una palabra redactada de cinco letras daría como resultado cinco X. No es posible la eliminación parcial de una variable, como una parte de un número de tarjeta de crédito.

Redacción variable se produce en el nivel de script. No es una propiedad heredable. Si se transmite una variable modificada a otros scripts, por ejemplo con una acción RunScript o RunSub, esa variable no se modifica automáticamente en los scripts posteriores. Si desea que una variable se elimine siempre, debe configurar la redacción de variables en todos los scripts a los que se pueda pasar.

Las variables que se pasan a otros scripts tienen un alcance global. Para eliminarlas, debe incluir global: antes del nombre de la variable en el campo VariableRedaction para asegurarse de que se elimine.

La mejor práctica es no mantener nunca datos confidenciales en un script por más tiempo del necesario. Además de redactar valores de variables, puede eliminar los datos de la variable.

Para redactar variables:

  1. En NiCE CXone, haga clic en el selector de aplicaciones y seleccione Omnicanal Routing > Studio Tres flechas unidas por la base. Una apunta directamente hacia arriba, otra hacia arriba y a la derecha, y otra hacia arriba y a la izquierda. .
  2. En la página Scripts, ubique y haga doble clic para abrir el script con el que desea trabajar. Se abre el script en una nueva pestaña.
  3. En el panel de propiedades del lado derecho del script, haga clic en la pestaña de Variables.
  4. Haga clic en Ocultar Un ojo con una línea diagonal que lo cruza.

  5. En el campo de la pestaña de Variables, ingrese el nombre de cada variable que desee ocultar.  Presione Intro después de cada variable. Estos nombres deberían corresponderse con las variables creadas en las acciones Assign o SNIPPET en el script.
  6. Haga clic nuevamente en Ocultar Un ojo con una línea diagonal que lo cruza. para esconder la lista con los nombres de las variables.

  7. Guarde su script.

Eliminar datos confidenciales de una variable

Además de configurar la redacción de variables, puede configurar su script para eliminar datos confidenciales de una variable. Esto ayuda a garantizar que no persista en el script más tiempo del necesario.

  1. En su script, coloque una acción Snippet después de que se hayan utilizado los datos confidenciales y ya no sean necesarios.
  2. En el Snippet editor de la acción Snippet, agregue la línea adecuada para cada variable de la que desea borrar datos confidenciales:
    • Para un objeto dinámico de datos: DYNAMIC <object name>
    • Para una variable regular: ASSIGN <var name> = ""
  3. Guarde sus cambios.

Desactivar un script

Permisos necesarios: ACD > Studio > Scripts > desactivar

Los scripts no se pueden eliminar de Studio. En su lugar, puede desactivarlos. Los scripts desactivados ya no son visibles en Studio, pero se pueden ver en la página de Scripts en la aplicación NiCE CXone ACD.

No necesita desactivar un script para evitar que NiCE CXone lo use. NiCE CXone únicamente utiliza scripts que se asignan a una habilidadClosed Se usa para automatizar la entrega de interacciones según las habilidades, capacidades y conocimientos del agente. y a un punto de contactoClosed punto de entrada que utiliza un contacto entrante para iniciar una interacción, como un número de teléfono o una dirección de correo electrónico..

  1. On the Browse tab in Studio, locate the script you want to deactivate.
  2. Select the script and click the red X icon A large red X. Click to deactivate a script. at the top of the tab.
  3. Confirm that you want to deactivate the selected script.
  4. You can add notes to the script to explain why you deactivated the script:
    1. En NiCE CXone, haga clic en el selector de aplicaciones y seleccione ACD > Scripts.
    2. Select Inactive from the Show drop-down.
    3. Click the script and add your notes on the Notes tab.

Reactivar un Script

Permisos necesarios: ACD > Studio > Scripts > desactivar

Puede reactivar un script para que sea visible en Studio otra vez.

  1. En NiCE CXone, haga clic en el selector de aplicaciones y seleccione ACD > Scripts.
  2. Seleccione Inactivo desde el desplegable Espectáculo.
  3. Haga clic en el script que desea reactivar.
  4. Haga clic en Activar en la pestaña de Detalles de la página del script.

Revertir a la Versión anterior del script

Studio conserva las versiones anteriores de todos los scripts. Cada vez que guarda los cambios, se agrega otra versión al historial del archivo del script. Puede revertir a una versión anterior de un archivo de script.

Si ha guardado una copia de un script con un nombre diferente y desea revertir a ella, no siga estos pasos. En su lugar, abra la copia a la que desea revertir y use Guardar como para crear una nueva copia. Puede desactivar las copias de scripts que ya no desee, o puede moverlas a una carpeta separada.

Revertir a una Versión anterior de un script en Studio

Permisos requeridos:Studio Scripts Crear/Editar

  1. En la pestaña Examinar en Studio, busque la secuencia de comandos que desea revertir.
  2. Haga clic con el botón derecho en él y seleccione Historial, luego haga clic en la versión a la que desea volver. La versión seleccionada se abre con la fecha y la hora en que se guardó agregadas al final de su nombre. Por ejemplo, para un script que se guardó el 2 de Agosto de 2022 a las 9:32:08, el final del nombre del script es 08022022093208.
  3. Haga clic en Archivo > Guardar como y guarde una copia del archivo con un nuevo nombre. Las versiones históricas de los archivos de script se abren en modo de solo lectura permanente.

Regresar a una Versión anterior de un script desde NiCE CXone

Studio keeps previous versions of all scripts. Each time you save your changes, another version is added to the script file's history. You can revert to a previous version of a script file.

If you have saved a copy of a script under a different name as a backup and want to revert back to it, don't follow these steps. Instead, open the backup copy you want to revert to. You can work in the backup copy, or you can duplicate it to create a new working copy and leave the backup in place. You can deactivate copies of scripts that you don't want anymore.

Revert to a Previous Version of a Script in Studio

Permissions required:  ACD > Studio > Scripts > Crear/Editar

You must close the script in Studio before you revert it. If the script is open, you won't see the changes unless you close and reopen the script. If you leave the script open when you revert it, then make changes and save the script without closing and reopening it, you overwrite the reversion and must revert it again.

  1. On the Browse tab in Studio, locate the script you want to revert.
  2. Right-click on it and select History, then click the version you want to go back to. The selected version opens with the date and time it was saved appended to the end of its name. For example, a script that was saved on August 2, 2022 at 9:32:08, the end of the script name is 08022022093208.
  3. Click File > Save As and save a copy of the file with a new name. Historical versions of script files open in permanent read-only mode.

Revert to a Previous Version of a Script from NiCE CXone

Permissions required:  ACD > Configuración del contacto > Scripts > Editar

When scripts are reverted from NiCE CXone, the name of the file doesn't change as it does when you revert from Studio.

You must close the script in Studio before you revert it. If the script is open, you won't see the changes unless you close and reopen the script. If you leave the script open when you revert it, then make changes and save the script without closing and reopening it, you overwrite the reversion and must revert it again.

  1. En NiCE CXone, haga clic en el selector de aplicaciones y seleccione ACD > Scripts.
  2. Click the script you want to revert. If the script you want to revert is currently deactivated, you must reactivate it first.
  3. On the Version History tab, select the version you want to revert to from the Previous Versions list and click Revert Back.

  4. In Studio, open the script you reverted and continue working on it.

Cargar Archivos en Studio

Puede cargar archivos a NiCE CXone mediante Studio. Esto incluye archivos de audio para avisos, archivos de gramática de ASRClosed Reconocimiento automático de Voz. Permite a los contactos responder a los avisos hablando, presionando teclas del teléfono o ambas opciones., entre otros. También puede ver, cargar y administrar avisos y otros archivos en la página Explorar Archivos de ACD en NiCE CXone.

  1. En la pestaña Archivos en Studio, expanda la carpeta en la que desea cargar el archivo. Si está cargando un aviso, expanda la carpeta Avisos.

  2. Haga clic en Cargar archivo(s) Un rectángulo con una flecha que apunta hacia arriba. y seleccione uno o más archivos para cargar, luego haga clic en Abrir. El archivo se carga y aparece en la lista de la pestaña.

  3. También puede arrastrar un archivo desde el explorador de Archivos de su computadora a la ventana archivos en Studio.