NiCE CXone Studio

Studio est un outil de script que vous pouvez utiliser pour personnaliser le flux de routage de votre centre de contact afin de répondre aux besoins de votre organisation. Le script vous permet de définir la manière dont les contacts sont routés vers les agents les mieux placés pour les aider. Par exemple, vous pouvez utiliser des menus ASRClosed Reconnaissance automatique de la Parole. Permet aux contacts de répondre aux invites en parlant, en appuyant sur des touches du téléphone, ou les deux. ou IVRClosed Réponse vocale interactive. Menu téléphonique automatisé que les contacts utilisent par la Voix ou par des touches pour obtenir des informations, acheminer un appel vocal entrant, ou les deux., ou des agents virtuelsClosed Une application logicielle qui traite les interactions avec les clients à la place d’un agent humain en direct..

Studio dispose d'une interface visuelle à faire glisser et déposer, de sorte que vous n'avez pas besoin d'une expérience approfondie en scripting pour créer des scripts de base. Vous pouvez créer des scripts plus complexes en incluant du code de scripting personnalisé.

La Studio aide en ligne fournit des informations sur :

Intégrations avec des Systèmes tiers

Studio vous permet de vous intégrerNiCE CXone avec des applications et systèmes tiers, y compris :

De plus, Integration Hub vous permet de gérer des intégrations basées sur l'API avec des systèmes tiers. Il vous permet également de gérer des informations qui nécessitent une sécurité supplémentaire, telles que des secrets ou des mots DE passe.

Compatibilité des scripts entre Studio et Desktop Studio

Les scripts Studio et Desktop Studio sont compatibles. Tout script sauvegardé sur les serveurs NiCE CXone peut être ouvert dans l'une ou l'autre application.

Les scripts ne peuvent pas être exportés d’une application et importés dans l’autre. En effet, les scripts Desktop Studio sont au format XML alors que les scripts Studio sont au format JSON. La fonction d'importation ne peut pas convertir les fichiers d'un format à l'autre.

La plupart des actions Studio sont disponibles dans les deux versions de l'application. Si une action n’est pas disponible dans la version de l’Studio que vous utilisez, vous la voyez quand même dans le script. Cependant, il se peut que vous ne puissiez pas modifier les propriétés de ces actions. Vous pouvez ouvrir le script dans la version de Studio que vous avez utilisée à l'origine si vous devez modifier ces actions.

Parité des fonctionnalités avec Desktop Studio

La version navigateur de Studio offre une parité fonctionnelle avec Desktop Studio. Si vous découvrez Studio, la page d'aide Prise en main de Studio propose une introduction. Elle décrit également les options disponibles dans l'interface.

Le tableau suivant indique l'emplacement des fonctionnalités Desktop Studio que vous connaissez dans Studio.

Fonctionnalité Desktop Studio Fonctionnalité Studio
Actions: ajoutez des fonctionnalités à votre script.

Toutes les actions sont disponibles dans Studio.

Les Actions se trouvent sur deux palettes situées dans la barre d'outils sur le côté gauche du canevas de script.

Éditeur Action Windows : Autoriser l'accès à des options de configuration supplémentaires.

Pour les actions disposant de fenêtres d'éditeur, il existe deux façons de les ouvrir :

  • Sélectionnez l'action et cliquez sur Éditeur au centre de l'icône de l'action.
  • Sélectionnez l'action et cliquez sur Ouvrir l’éditeur dans le volet des propriétés de l'action.

La conception et la fonction des éditeurs vont être améliorées dans les versions à venir.

Onglet Parcourir : affiche une liste complète des scripts de l'unité commerciale.

Dans Studio, la page qui se charge lorsque vous accédez à l’application est la page Scripts. Cette page affiche les scripts disponibles dans votre NiCE CXone système. Vous pouvez filtrer la liste pour afficher uniquement les scripts actifs, uniquement les scripts inactifs, ou tous les scripts.

La Page Scripts fournit des informations sur chaque script. Il vous permet d'effectuer certaines tâches avec Scripts sans quitter la Page. Tu peux:

  • Créez un nouveau script.
  • Recherchez des scripts. Les Critères sont le nom du script, les actions dans le script, les mots dans la légende, les variables, et le type DE supportClosed Un moyen, tel que la voix, les courriels et les clavardages, à travers lequel un contact se connecte au destinataire voulu..
  • Affichez le type DE support de chaque script, son nom, la date de sa dernière modification, s'il est verrouillé pour l'édition et s'il est actif ou inactif.
  • Exporter un script vers un fichier JSON.
  • Dupliquer un script pour en créer une copie.
  • Désactiver un script.
  • Outrepasser un script verrouillé.
  • Copier le chemin d'un script.
  • Chargez un fichier script ou un fichier de trace de script.
Compare Scripts (Edit > Compare): Allows you to compare two scripts by captions, parameters, branches, or position. Results display on the Find Results tab. Vous pouvez comparer deux scripts dans Studio en les ouvrant, puis en sélectionnant Compare dans le menu en haut de la zone de travail du script. Vous pouvez également comparer des versions historiques du même script. Les Résultats s'affichent en bas de la page.
Connecteurs: Connectez les Actions entre elles sur le canevas de script.

Vous pouvez connecter des actions avec des lignes à angle droit, des lignes courbes et des lignes linéaires. Vous pouvez connecter des actions directement à d'autres actions ou à des points d'ancrage de connexion sur l'action. Vous pouvez ajouter des points de sommet aux lignes à angle droit ou courbes en double-cliquant sur le connecteur. Les points de sommet introduisent des coudes ou des courbes supplémentaires dans le connecteur.

Copier et coller des Actions sur le canevas: permet de sélectionner et de copier des actions, puis de les coller à nouveau sur le canevas du script.

Dans Studio, vous pouvez copier et coller une ou plusieurs actions dans le même script ou entre des scripts. Vous pouvez aussi annuler ou rétablir des actions précédentes. Les raccourcis clavier standards sont pris en charge pour ces tâches.

Créer et modifier des Scripts: permet de créer de nouveaux scripts et de modifier ceux qui existent déjà.

 

Vous pouvez créer et modifier des scripts. Chaque script est placé sur un onglet distinct dans votre navigateur.
Désactiver : permet de désactiver un script afin qu'il ne puisse pas être utilisé.

Vous pouvez désactiver des scripts à partir du menu Options situé à côté de chaque script sur la page Scripts dans Studio. Vous pouvez également ouvrir le script et sélectionner Deactivate dans le menu central en haut du script.

Vous pouvez réactiver des scripts sur la Page Scripts dans l'application ACD. La réactivation des scripts n'est pas prise en charge dans Desktop Studio, mais sera ajoutée à Studio dans une prochaine version.

Erreurs et Avertissements (onglet Erreurs du script): Affiche une liste de toutes les erreurs ou avertissements dans le script actuel. Les erreurs et avertissements du script apparaissent sur le panneau des propriétés situé à droite du canevas de script.
Onglet fichiers: Fournit l'accès aux fichiers de l'unité commercialeClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone.. Vous pouvez y charger des fichiers et enregistrer des messages d’invite sonores.

Vous pouvez afficher et téléverser des fichiers sur la page Parcourir les fichiers ACD dans la plateforme NiCE CXone. Dans Studio, vous pouvez afficher et téléverser les types de fichiers suivants :

Actuellement, la page Invites ne permet pas encore d'enregistrer des messages d'invite audio, comme le fait l'onglet Fichiers dans Desktop Studio. Dans Studio, vous pouvez enregistrer des messages d'invite audio à l'aide d'actions telles que PLAY.

Onglet Framework: Affiche une liste complète des actions disponibles dans Studio.

Le côté gauche du canevas de script propose des options pour afficher la palette Actions et la palette Actions d’API. Ces palettes permettent d'accéder à toutes les Studio actions concédées sous licence à votre NiCE CXone système. La disponibilité de certaines actions dépend du type DE support du script.

Importer et exporter des Scripts (Fichier > Importer et Fichier > Exporter): Vous permet d'enregistrer des copies d'un script en tant que fichier sur votre ordinateur, et d'ajouter une copie sauvegardée d'un script à Studio.

Importation et exportation fonctionnent de la même manière que dans Desktop Studio. Cependant, dans Studio, l'importation est appelée chargement et l'exportation est appelée téléchargement.

De plus, Studio scripts sont au format JSON. Desktop Studio scripts sont en xml. Le processus d’importation ne permet pas de convertir les fichiers d’un format à un autre. Ainsi, vous ne pouvez pas importer dans Studio un script qui a été exporté de Desktop Studio, et réciproquement. Toutefois, vous pouvez contourner ce problème en important le script dans l'application à partir de laquelle il a été exporté, puis en l'ouvrant dans l'application souhaitée.

Instances multiples de Studio: permet d'avoir plus que une instance de l'application en cours d'exécution à la fois.

Chaque navigateur peut exécuter deux instances de Studio : une en mode normal et une en mode navigation privée. Vous pouvez exécuter jusqu'à quatre instances simultanément en utilisant Chrome et Microsoft Edge.

Cette capacité est utile si vous devez vous connecter à plusieurs unités commercialesClosed Regroupement organisationnel de haut niveau utilisé pour gérer le soutien technique, la facturation et les paramètres globaux de votre système NiCE CXone. en même temps. Vous pouvez ouvrir plus que un script dans une seule instance de Studio. Chaque script s’ouvre sur un onglet distinct de la fenêtre de navigateur.

Naviguer visuellement dans le canevas de script (onglet Naviguer): affiche une vue miniature du canevas de script dans laquelle vous pouvez vous déplacer pour visualiser rapidement différentes parties du script. Dans Studio, vous pouvez parcourir le canevas du script dans l'aperçu du canevas. Vous pouvez également utiliser les options situées en bas du panneau propriétés. D’autres options sont proposées pour ajuster le script à l’écran, zoomer en avant et en arrière, et recentrer le canevas à l’aide de la souris.

Onglet propriétés (Propriétés d'Action et de script) : Affiche les propriétés de l'action sélectionnée ou du script actuel, et vous permet de les configurer.

Les propriétés de l’action sélectionnée s’affiche dans le panneau sur le côté droit du canevas du script. Vous pouvez voir :

  • Le nom de l’action et son id d’action.

  • Champ permettant de modifier l'étiquette de légende de l'Action. Vous pouvez également effectuer un clic droit sur l'icône de l'Action dans le canevas du script et sélectionner Ajouter une légende.

  • Un bouton Ouvrir l’éditeur permettant d’accéder à la fenêtre d’Éditeur de l’action. Cette option n’est disponible que pour les actions qui possèdent des fenêtres d’éditeur.

  • Propriétés permettant de configurer l'Action. Vous pouvez appuyer sur F1 pour ouvrir la Page d'aide de l'Action sélectionnée.

L'onglet Desktop Studio Propriétés affiche d'autres informations lorsqu'aucune action n'est sélectionnée sur le canevas de script. Ces informations sont disponibles à d'autres emplacements dans Studio :

Revenir à la version précédente de Scripts: Permet de sauvegarder une version précédemment sauvegardée du script et de continuer à y travailler. L'option permettant d'afficher les versions précédentes d'un script, de copier des versions ou de revenir à des versions précédentes d'un script est disponible dans le menu central situé en haut du canevas du script. Lorsqu'une version précédente est affichée pour consultation, elle se charge en mode en lecture seule. Les Boutons permettant de copier ou de revenir à cette version sont disponibles dans le coin supérieur droit de la page.
Verrouillage et déverrouillage du script : permet de faire passer le script en mode en lecture seule et en mode modifiable.

Actuellement, dans Studio, vous pouvez verrouiller un script pour le modifier et le déverrouiller pour le mettre en mode en lecture seule. Vous pouvez outrepasser le verrouillage d’un script verrouillé par un autre utilisateur.

Sur la Page Scripts dans Studio, l'état Verrouillé est affiché pour chaque script. Actuellement, vous ne pouvez pas filtrer la liste des scripts par état verrouillé ni trier le tableau par la colonne Verrouillé. Cela signifie que vous ne pouvez pas facilement afficher une liste de tous les scripts verrouillés. Cela sera inclus dans une future version.

Script traçage: Vous permet de test et de déboguer des scripts.

Actuellement, dans Studio, lorsque vous tracez un script, vous pouvez :

Rechercher des Scripts (onglet Scripts) : Permet de rechercher des scripts dans l'unité commerciale à l'aide du nom du script, de la version et du type DE support du script.

Vous pouvez rechercher des scripts sur la Page Scripts dans Studio. Vous pouvez effectuer une recherche par nom de script, par les variables qu'ils contiennent ou par valeur de variable, légende d'action et type DE support du script.

Extrait Action : contient une fenêtre d'éditeur permettant un codage personnalisé.

Actuellement, la fenêtre de l'éditeur d'Action SNIPPET prend en charge le code d'Extrait personnalisé avec coloration syntaxique. Vous pouvez déboguer les extraits depuis l'intérieur de la fenêtre de l'éditeur.

Des améliorations continuent d’être apportées à la fonctionnalité de l’éditeur.

Modifications non enregistrées: stocke les modifications du script qui n'ont pas été enregistrées avant la fermeture de l'onglet du script. Les modifications de script non sauvegardées sont conservées dans le navigateur. Si vous ouvrez un script contenant des modifications non sauvegardées, Studio vous permet de choisir si vous voulez ouvrir la version contenant ces modifications. Comme les modifications sont conservées dans le navigateur, si vous videz le cache, les modifications non sauvegardées sont supprimées. En outre, les modifications conservées sont liées à l’utilisateur et au navigateur.
Onglet variables : répertorie les variables du script et les actions qui font référence à chacune d'elles. Une liste des variables du script en cours est disponible dans l'onglet variables du volet des propriétés.
Variable Rédaction: Permet de préciser les variables dans un script dont les valeurs doivent être omises des traces et des journaux. Vous pouvez masquer les variables sur l’onglet variables du panneau des propriétés.

Historique de vérification et enregistrements de Script

Lors de l'enregistrement d'un script dans Studio, le système effectue une rotation de version :

  1. Une nouvelle version est créée.

  2. La version précédemment active est définie comme inactive.

  3. La nouvelle version est activée.

Au cours de ce processus, le rapport Historique de vérification peut attribuer la désactivation de la version précédente au dernier utilisateur ayant modifié cette version, plutôt qu'à l'utilisateur effectuant l'enregistrement actuel.