Studio 使用者介面

本頁適用於舊版 Studio 應用程式。如果您是 CXone Studio 控制版本計劃的成員,並希望了解該應用程式的介面,請參閱開始使用CXone Studio説明頁面。

Studio 使用者介面包括中間的畫布,周圍的數字標籤分別位於左側、右側和底部。這些標籤用於造訪 Studio 動作Closed 在 Studio 指令碼內執行一個流程,如收集客戶資料、播放訊息或音樂,或將聯絡人路由至客服專員。和涉及動作和指令碼的資訊。

Studio 選單列

主要選單包含七個下拉式選單:檔案、編輯、檢視、驗證、偵錯、視窗和說明。許多選單項目都是常見的命令,例如儲存檔案或復原變更。常見命令沒有在本主題中描述。

檔案選單

除了通用檔案選單的常見命令外,例如新建、開啟、儲存和退出,Studio檔案選單還包含以下其他選項:

選單選項 詳細資訊
匯入/匯出

允許您將指令碼從 XML 檔案匯入到 Studio,或將指令碼匯出到 XML 檔案。

最近

提供您在 Studio 中最近打開的用於查看您登入到的租戶Closed 用於管理 CXone 環境的技術支援、計費和全域設定的高級組織分組的指令碼清單。點擊列出的指令碼,在新的畫布面板中打開。

登出並退出 選擇登出 Studio 並關閉該應用程式。即使在您關閉應用程式後,Studio 仍然記得您的登入。如果需要完全登出,請使用此選項。

「編輯」選單

「編輯」選單包含「編輯」選單的常見命令,包括「復原」、「剪下」、「複製」和「貼上」。您可以在畫布上使用這些 Studio 動作Closed 在 Studio 指令碼內執行一個流程,如收集客戶資料、播放訊息或音樂,或將聯絡人路由至客服專員。選項。標準的鍵盤捷徑可以執行這些命令(Ctrl+Z、Ctrl+X、Ctrl+C 和 Ctrl+V)。Studio「編輯」選單亦包括以下選項:

選單選項 詳細資訊
將指令碼複制為圖像

將目前的指令碼作為圖像複製到剪貼簿。您可以將圖像貼上到另一個位置,例如電郵或文字文件。

尋找

開啟「在指令碼中尋找」視窗,您可以透過該視窗在已經開啟的所有指令碼或在頂部「畫布」標籤中開啟的指令碼中搜尋特定文字。

前往

搜尋並立即導覽至目前指令碼內的動作 ID。您可以在動作標籤ID 欄位中查看動作 ID。

比較 允許您透過標題、參數、分支或位置來比較兩個指令碼。例如,一對指令碼可能包含完全相同的動作和分支,但可能包含不同的參數。透過比較 2 個指令碼,您可以在「尋找結果」標籤中檢視差異(和相似性)。

「視圖」選單

「視圖」選單提供以下選項:

選單選項 詳細資訊
說明 > 客服專員資訊 檢視有關您目前用來登入 StudioCXone 帳戶的資訊。資訊顯示在「屬性」標籤上。
說明 > 登入資訊 Studio 中檢視有關您的目前工作階段的資訊。

瀏覽器,
工具,
屬性,
庫,
檔案,
導覽,
搜尋,
框架,
尋找結果

點擊標籤名稱,在 Studio 中開啟該標籤。當您關閉了標籤並需要重新開啟它時,這項功能會很有用。

如果您需要重新開啟「指令碼錯誤」、「動作」、「變數」或「相依性」標籤,請參閱「驗證」選單

工具列 > 追蹤 點擊可切換是否在工具列中顯示追蹤選項。

驗證選單

選單選項 詳細資訊
Windows

點擊以開啟以下任何標籤:「指令碼錯誤」、「動作」、「變數」和「相依性」。

如果您需要開啟不在此清單中的標籤,請參閱「檢視」選單

語法檢查

檢查使用中指令碼的連接和屬性錯誤,並在「指令碼錯誤」標籤中顯示警告。這是一種測試指令碼以及對其偵錯的基本方法。

「偵錯」選單

所需權限ACD > Studio > 指令碼 > 偵錯

選單選項 詳細資訊
擷取指令碼

擷取一個指令碼,在其運行時追蹤並記錄其進度。您可以選擇擷取Next instance only 或在其執行時以Continuous 為基礎擷取。當指令碼中的每個動作觸發時,產生的資訊將顯示在追蹤輸出工具中。如果您持續擷取指令碼,追蹤檔案將儲存於 CXone 媒體伺服器上。您可以使用Debug > Load Remote Trace File 來檢視這些追蹤檔案。

以追蹤開始

啟動使用中指令碼並開啟「追蹤輸出」視窗,以顯示指令碼執行的結果。您亦可以使用Start with Trace 按鈕,從工具列開啟追蹤

載入偵錯追蹤檔案

瀏覽追蹤檔案並在「追蹤輸出」視窗中開啟它。

載入遠端追蹤檔案

流覽 CXone 平台上的追蹤檔案並在「追蹤輸出」視窗中開啟它。

「視窗」選單

「視窗」選單允許您在 Studio 中開啟的指令碼之間導覽。在此選單中選擇一個指令碼會將其作為「工作中」標籤放在最前面。如果您僅有一個指令碼開啟,則此選單中僅有一個選項。

「說明」選單

「說明」選單提供了存取 Studio 線上說明的選項,以及其他可幫助您 Studio 的資訊。

選單選項 詳細資訊
NICE CXoneStudio 文件

開啟(您的預設網頁瀏覽器的)一個新瀏覽器標籤並載入線上說明的 Studio 概覽頁面。

線上即時說明      F1

顯示畫布上目前選擇的動作的線上說明主題。您亦可以按鍵盤上的 F1,以存取所選動作的說明主題。說明主題在您的預設網頁瀏覽器的一個新標籤中載入。

業務單元配置

顯示有關如何配置您的租戶的資訊。如果您不確定啟用了哪些應用程式或功能(例如通道類型),您可能需要參考此資訊。

疑難排解 > 手動下載 CefSharp 計畫 開始一個新的 CefSharp 下載,這是 Studio 執行所需的外掛程式。
疑難排解 > 清除快取 清除 Studio 的快取,如果應用程式沒有按預期執行,這項功能將很有幫助。
關於

顯示有關 Studio 的基本資訊,例如版本。

Studio 工具列

工具列提供了通用命令的組合,例如開啟或儲存指令碼,以及特定於 Studio 的命令。

工具列選項 詳細資訊
增加/減少空間

點擊可增加或減少畫布上動作之間的空間大小。每次點擊都會少量改變空間大小。

以追蹤開始 允許您開始追蹤
追蹤指令碼

追蹤指令碼會啟動使用中指令碼並開啟「追蹤輸出」視窗,以顯示指令碼執行的結果。工具列提供了 3 個與追蹤指令碼相關的命令:啟動追蹤、選擇用於追蹤指令碼的 ANIClosed 也被稱為呼叫者 ID。顯示語音來電的電話號碼。DNISClosed 識別聯絡人為聯絡您進行呼入語音通話而撥打的號碼,以及客服專員或系統在進行呼出語音通話時撥打的號碼。,或用於追蹤和擷取指令碼執行的下一個執行個體或連續追蹤和擷取執行的指令碼的每個執行個體(與生產指令碼相關)的選項。更多資訊,請參閱 偵錯指令碼 頁面。

鎖定/解鎖指令碼

點擊可鎖定或解鎖指令碼。鎖定會使一個指令碼進入唯讀模式。解鎖允許您編輯此碼,但其他Studio使用者不能同時編輯它。其他使用者可以在您解鎖或儲存並關閉指令碼之後對其修改。

鎖定指令碼時,畫布背景顯示為白色,標籤上的指令碼圖示是一個鎖定的掛鎖。解鎖指令碼後,畫布背景顯示為灰色,圖示顯示為指令碼類型圖示。

僅有在啟用指令碼鎖定時,此選項才會顯示在 Studio 中。您的 CXone 管理員可以啟用此選項。

如果您有指令碼鎖定覆寫權限,您可以覆寫其他使用者對指令碼的鎖定,這樣您可以編輯它。您可以在「鎖定」標籤中檢視租戶Closed 用於管理 CXone 環境的技術支援、計費和全域設定的高級組織分組上的所有鎖定指令碼。

Studio 畫布

畫布是 Studio 介面中心的大型空間。這是建立指令碼的地方。您可以將來自「工具」和「框架」標籤動作拖放到畫布上。指令碼作為新畫布標籤開啟,就像網頁瀏覽器一樣。

在畫布上,您可以:

  • 點擊標籤或使用「視窗」選單,在開啟的指令碼之間切換。
  • 透過點擊畫布上的X關閉一個指令碼標籤。X 不在指令碼標籤上,因為它在某些網頁瀏覽器中。它位於畫布視窗的右上角。
  • 如果您點擊畫布的空白區域,然後選擇Properties 標籤,您可以存取指令碼的屬性
  • 如果您關閉了所有的指令碼標籤,您可以透過建立新的指令碼來替換畫布。

Studio 標籤

標籤提供了對您在 Studio 工作時需要的許多不同資訊的存取權限。預設情況下,標籤被分為三組。三組分別位於畫布的左邊、右邊和底部。預設情況下,所有標籤都是可見的。如果您關閉了標籤,您可以透過使用「檢視」選單驗證 > 「視窗」選單重新開啟標籤。請查看本頁頂部的圖像來了解預設版面的外觀指南。

預設標籤組

預設標籤組包括:

  • 左側:這些標籤在預設情況下位於 Studio 視窗的左側:
    • 導覽
    • 相依性
    • 變數
    • 動作
  • 右側:以下標籤預設位於 Studio 視窗的右側:
    • 框架
    • 工具
    • 瀏覽器
    • 屬性
  • 底部:以下標籤預設位於Studio視窗的底部:
    • 尋找結果
    • 檔案
    • 指令碼錯誤
    • 搜尋

「重新排列」標籤

標籤的位置可自訂。您可以:

  • 拖放標籤在彼此的頂部,將它們移動到 Studio 的其他位置。如果您抓取一個標籤的標題列,整個標籤堆疊就會移動。如果您僅想移動一個標籤,抓取標籤的另一端(實際上看起來像一個標籤的部分)。
  • 透過點擊標籤右上角的大頭針圖示,將一組標籤固定到介面視窗的邊緣。當您點擊一個固定的標籤,該標籤會滑出,以便您使用。當您點擊離開它,它會最小化並回到固定的邊緣。

  • 使用下拉式區域放置標籤。點擊標籤的標題列並將其從當前位置拖離時,Studio 介面會顯示所有可以停靠標籤的地方的下拉式區域圖示。將游標暫留在下拉式區域上,鬆開滑鼠按鈕。

「動作」標籤

「動作」標籤顯示了目前指令碼中所有動作的清單。動作按新增到指令碼的順序列出。此標籤顯示了關於每個動作的以下資訊:

  • 標題:這是顯示在畫布上動作圖示下面的文字。預設情況下,標題與動作名稱相同。您可以在動作的屬性中變更任何動作的標題。這是記錄動作在指令碼中完成的內容的一種有用方法。例如,對於每一個 Snippet 動作,您可以變更標題,以說明 Snippet 執行個體在指令碼中執行的操作。

  • Tool Name:動作的名稱。此名稱不可修改。
  • ID:根據新增到畫布的順序指派給動作的動作 ID。給定指令碼中動作的每個執行個體都有一個唯一的編號。

「瀏覽器」標籤

「瀏覽器」標籤顯示 Studio 資料夾,其中儲存了您為此租戶建立的所有指令碼。您可以:

  • 透過點擊兩下指令碼,從此標籤開啟指令碼。它在畫布標籤中開啟。
  • 透過右鍵點擊指令碼並將游標暫留在History上,檢視指令碼的歷程記錄。
  • 透過點擊要在「歷程記錄」清單中查看的版本,開啟舊版本的指令碼。
  • 透過開啟較早版本的指令碼並點擊Save As,然後在清單中選擇該指令碼,還原為較早版本的指令碼。

如果您有適用的權限,CXone ACD 應用程式中的指令碼頁面也允許您還原到指令碼的早期版本。

「相依性」標籤

顯示使用中指令碼中動作之間的關係。

「檔案」標籤

所需權限ACD > Studio > 檔案瀏覽器 > 檢視

「檔案」標籤包含指令碼中使用的所有語音提示錄音。這些檔案儲存於您的租戶中。您可以看到有關提示檔案的基本資訊(上次修改日期、目的、描述、檔案播放時長)。您還可以從此標籤上載新的提示

「尋找結果」標籤

顯示使用Edit > Compare 選項進行比較的結果。

「框架」標籤

包含所有 Studio 動作的完整清單。

因為此標籤上的一些動作更高級,所以預設情況下不是對所有使用者都可用。如果您在Studio中沒有看到這個標籤,則它尚未為租戶Closed 用於管理 CXone 環境的技術支援、計費和全域設定的高級組織分組啟用。如果您的組織有可以透過使用 Framework 動作來滿足的需求,則您的CXone 客戶代表可以提供對「框架」標籤的存取。

如果您能存取「框架」標籤,請謹慎使用不熟悉的動作。許多動作在線上說明中沒有記錄。您可以向 CXone 客戶代表 提出問題,或者向 CXone 客戶社群了解有關某個動作的詳細資訊。

您可以在框架動作説明頁面上詳細了解此標籤上可用的動作。

「已鎖定」標籤

所需權限ACD > Studio > 指令碼 > 鎖定覆寫

顯示已鎖定指令碼的清單。如果您的CXone使用者帳戶具有鎖定覆寫權限,則您可以覆寫指令碼鎖定。透過以滑鼠右鍵點擊指令碼並選擇Kick <user> from editing script或點擊Kick按鈕(由紅色箭頭指示)來解鎖指令碼。

「導覽」標籤

允許您在不使用捲軸的情況下快速瀏覽較大的指令碼。紅色方塊顯示您可以在畫布上看到的內容。

「屬性」標籤

「屬性」標籤顯示有關當前選擇的動作的資訊。如果沒有選擇任何動作,此標籤將顯示關於整個指令碼的資訊。

每個動作都有一組唯一的變數、分支和參數。您可以在動作的屬性中配置它們,以定義您希望該動作在指令碼中如何執行。您還可以透過右鍵點擊動作並選擇Properties來檢視動作屬性。

指令碼屬性允許您模擬呼入呼叫來測試指令碼。您還可以編校指令碼中的一個或多個變數。

指令碼錯誤

「指令碼錯誤」標籤顯示與指令碼相關的任何警告和錯誤。在您儲存指令碼或執行語法檢查之前,標籤不會顯示任何內容。警告不會阻止指令碼的執行或儲存,但錯誤會。

「搜尋」標籤

允許您搜尋特定指令碼。您可以透過使用部分指令碼名稱、業務單元、新舊版本以及指令碼類型來縮小搜尋範圍。

「工具」標籤

顯示最常用的動作。點擊類別圖示 以變更動作的組織方式。您可以按類別或字母順序顯示它們。當動作按字母順序排列時,您可以點擊排序圖示 來倒轉清單的順序。

預設類別的分組稱為選擇區。您可以透過點擊工具標籤右上角的選擇區圖示建立您自己的類別和選擇區。預設選擇區包含以下類別:

類別 描述
標準 在任何指令碼類型中使用的基本和一般動作。
額外語音 用於語音媒體類型指令碼的常見動作。
進階 進階動作通常由經驗豐富的指令碼編寫者使用。
資料存取 與從 inData 或客戶資料庫存取資料相關的動作。
系統 用於檔案儲存和操縱的動作。
事件 CXone 觸發的動作。
Web 系統指令碼使用的動作。系統指令碼是 CXone 在內部使用的預設指令碼。
語音 與自動語音識別 (ASRClosed 允許聯絡人透過說話、點擊手機按鍵或兩者組合的方式來回應錄音的語音提示。) 相關的動作。
WFO 勞動力參與度 (WEM) 相關的動作。
Personal Connection CXone Personal Connection 相關的動作。
CXone 自訂驗證 與客戶驗證相關的動作。
自動化和 AI 與自動化 AI 相關的動作,例如客服專員助理Closed 為客服提供內容特定協助的軟體應用程式。虛擬客服專員機器人Closed 代替真人客服專員處理客戶互動的軟體應用程式。

「變數」標籤

顯示使用中指令碼中可用的變數以及引用每個變數的動作。

鍵盤捷徑

Studio 使用許多眾所周知的鍵盤捷徑,如 CTRL + C 來複製某些內容,但也提供了更多的捷徑來簡化您的工作流程。

捷徑 動作
CTRL + A 選擇使用中指令碼中的所有動作圖示。
CTRL + C 執行標準的 Windows 複製功能。
CTRL + E 開啟「匯出到檔案」視窗。
CTRL + F 開啟「在指令碼中尋找」對話方塊。
CTRL + G 前往特定的指令碼動作項目(即根據您輸入的 ID 在使用中指令碼中選擇一個動作圖示)。
CTRL + I 開啟「從檔案匯入...」視窗。
CTRL + N 開啟「建立新指令碼」視窗。
CTRL + O 開啟「從...開啟指令碼」視窗。
CTRL + S 僅儲存對使用中指令碼的變更。
CTRL + SHIFT + S 儲存對所有開啟指令碼的變更。
CTRL + T 僅擷取下一次發生的指令碼追蹤。
CTRL + SHIFT + T 開始執行直到手動結束的連續指令碼追蹤。
CTRL + V 執行標準的 Windows「貼上」功能。
CTRL + X 執行標準的 Windows「剪下」功能。
CTRL + Y 將指令碼恢復到「復原」之前的狀態。
CTRL + Z 執行 Windows「復原」功能(即,將指令碼返回到上次變更之前的狀態)。
Del 刪除 刪除所選項目。
F1 啟動選定動作的線上說明。
CTRL + F2 開啟「瀏覽」標籤。
CTRL + SHIFT + F2 開啟「框架」標籤。
CTRL + F3 開啟「工具」標籤。
CTRL + SHIFT +F3 開啟「尋找結果」標籤(請參閱「在指令碼中尋找」對話方塊)。
CTRL + F4 開啟「屬性」標籤。
CTRL + SHIFT +F4 開啟「已鎖定」標籤。
F5 開啟「追蹤輸出」視窗。
CTRL + F6 開啟「檔案」標籤。
SHIFT + F6 檢查使用中指令碼的語法,然後開啟「指令碼錯誤」標籤。
CTRL + F7 開啟「導覽」標籤。
CTRL + F9 開啟「搜尋」標籤。