管理提示

This help page is for Desktop Studio.This information is also available for CXone Studio.

提示是為聯絡人播放的訊息。提示可以要求聯絡人輸入資訊,也可以傳達資訊而不要求輸入。提示是可由 Auto Attendant、互動式語音應答 (IVRClosed 自動電話選單,允許呼叫者透過語音命令或按鍵輸入或二者進行互動,以獲取資訊、路由至呼入語音通話或二者兼有。) 系統和其他語音處理工具播放。在CXone中,提示可以是預先錄製的音訊檔案或由文字轉語音 (TTSClosed 允許使用者將錄音的提示輸入為文字形式,並使用電腦產生的語音來講述內容。) 服務讀取的文字。

建立 TTS 提示

所需權限ACD > Studio > 指令碼 > 建立/編輯 ACD > Studio > 錄音提示 > 開啟(用於在 Studio 中錄製音訊檔案)

您可以使用序列編輯器新增 TTSClosed 允許使用者將錄音的提示輸入為文字形式,並使用電腦產生的語音來講述內容。 提示,或者直接輸入提示到支援提示的Studio動作的Sequence屬性。

某些動作,例如Reqagent,有Sequence屬性,但沒有與序列編輯器連結。如果您想使用序列編輯器為這些動作建立提示,可以在指令碼中臨時新增Play 。透過Play存取序列編輯器並建立提示。將Sequence屬性中的提示序列複製並貼上到其他動作的Sequence屬性中。完成後,刪除Play

  1. Voiceparams action新增到指令碼中支援 TTSClosed 允許使用者將錄音的提示輸入為文字形式,並使用電腦產生的語音來講述內容。 的動作之前(例如,MenuPlay 動作)。如果 TTS 支援動作設定的屬性將被傳遞給其他指令碼,您可能還需要在子指令碼中放置一個 Voiceparams 動作,以確保這些屬性不會被忽略。

  2. Voiceparams 動作的屬性中,點擊 TTSVoice 欄位中的下拉式清單,並選擇您想要說出提示的語言和語音。
  3. 使用序列編輯器建立提示或將其輸入序列屬性
  4. Phrase 欄中輸入提示的文字,不執行格式化。這讓您能夠在同一處看到整個提示,而不是分解成 Sequence 欄位中的多個區段。Phrase 欄位中的內容僅供您使用。提示並不會說出這些文字。
  5. 點擊套用,以將提示儲存到所選的動作。

在序列編輯器中建立 TTS 提示

序列編輯器允許您使用介面建立 TTS 提示符,此介面為您新增格式。使用序列編輯器時,您可以在 Sequence欄位中新增序列Closed 為聯絡人播放的一段音訊提示。。欄位中顯示的每個 numbered 項都是一個序列。點擊a Play option on the left side of the editor window, such as Play a Date or Synthesize Text.

中的每個序列有 300 字元的限制。如果您需要播放的文字長於此數字,您可以新增額外的序列。例如,如果您需要播放長度為 540 個字元的文字,可以新增兩個文字到語音序列,以用這兩個序列來分段文字。

  1. Studio,開啟或建立指令碼。如有必要,新增支援提示的動作,例如 Menu
  2. 點擊兩下您要新增提示的動作。
  3. 在序列編輯器視窗中,點擊 Synthesize Text。預設文字出現在 Sequence Sequence Value 欄位。Synthesize Text 的預設文字是 The little brown fox

  4. Sequence Value 欄位中,刪除預設值,然後輸入您想要的提示值。例如,您將刪除 The little brown fox,並新增 Thank you for calling Classics, Inc.。 We're here to help you read more.
  5. 如果您包括金錢、日期、時間或您希望逐個字母拼出的文字,如聯絡人的名字,請使用序列編輯器中的其他序列選項。

  6. 如果您想變更 Sequence 欄位中各區段的順序,選擇您想移動的順序,然後點擊向上或向下的箭頭。當指令碼播放提示時,其序列按從上到下的順序讀取。

  7. 使用以下方法之一,在字詞或短語中插入暫停:

    • 使用事先錄製的無聲檔案:使用序列編輯器建立 WAV 檔案上載無聲的聲音檔案。點擊 Play a Wave File ,然後選擇無聲檔案。若有必要,點擊 Sequence 欄位中的 WAV 檔案,使用箭頭鍵 將提示移動到所需的位置。
    • 使用 Wait 動作:使用一個 Play 動作來分隔希望用無聲分隔的提示區段,然後在區段之間新增一個 Wait 動作。配置 Wait 的暫停長度。
  8. 必要時,可修改 Sequence 欄位中的項目。在 Sequence 欄位中選擇序列,變更 Sequence Value 欄位中的內容。
  9. Phrase 欄中輸入提示的全文,不執行格式化。這讓您能夠在同一處看到整個提示,而不是在 Sequence 欄位中分解成多個序列。Phrase 欄位中的內容僅供您使用。TTS 服務不會說出這些文字。
  10. 點擊 Apply 即可儲存提示。

在序列屬性中建立 TTS 提示

您可以在一個動作的Sequence屬性中,透過輸入適當格式的序列來建立一個 TTSClosed 允許使用者將錄音的提示輸入為文字形式,並使用電腦產生的語音來講述內容。 提示。序列是一系列的字元、單詞、短語或句子。TTS 服務可以識別多種類型的序列。可以在Sequence屬性中包括一個以上的序列。每個序列必須:

  • 用雙引號括起來。
  • 包括該序列包含的資訊類型所要求的字串參考字元。唯一不需要字串參考字元是音訊檔案序列的序列類型。
  • 遵循支援的資訊格式,如日期、時間和貨幣。
  • 包含不超過 300 個字元。如果您需要包含超過 300 個字元的文字,請將其分為多個序列。

Classics, Inc.已決定重做其 IVRClosed 自動電話選單,允許呼叫者透過語音命令或按鍵輸入或二者進行互動,以獲取資訊、路由至呼入語音通話或二者兼有。 選單中的一個提示。管理團隊為新的提示編寫了指令碼,並將其交給 Classics, Inc. 的Studio指令碼編寫者 Beowulf Herot。該提示針對要求提供其帳戶餘額和下一次帳單到期日的客戶。當 Beowulf 完成提示時,它包含以下序列:

"% `{firstName} `{lastName} 帳戶的當前餘額為 "
"${accountBal} "
"%.您下次的付款日期為 "
"@{billDueDate} "
"%.要再次聽到此資訊,請按 1。要聽到郵寄付款的地址,請按 2。要註冊電子帳單支付,請按 3。要返回主選單,請按星號鍵。"

建立動態 TTS 提示

您可以在 Snippet 動作中建立動態提示。如果提示內容不斷變化,這將很有幫助。您可以直接在 Snippet 編輯器視窗中輸入提示,也可以在序列編輯器中建立提示,然後複製到 Snippet 動作中。

  1. In Studio, open an existing script or create a new one.
  2. 新增 Snippet 動作和播放提示的動作,如 Play
  3. Snippet 放在 Play 之前並相連。
  4. Sequence Editor 中建立提示,然後複製動作 Sequence 屬性的內容。

    某些動作有 Sequence 屬性,但序列編輯器沒有。如果需要使用的動作不支援序列編輯器,請在指令碼中新增 Play 動作,建立提示,然後從 Sequence 屬性中複製。建立提示符後,刪除額外的動作。

  5. Double-click the Snippet action.
  6. Snippet Editor 視窗中,使用以下語法建立動態對象並為其指派序列:

    DYNAMIC [dynamic object name] = [sequence]

  7. 在序列定義的前面,第一個雙引號之前新增一個美元符號字元 ( $ )。使用反斜線字元轉義提示中的所有雙引號。例如:

    ASSIGN promptList = $"\"{promptPath}YourAccountBalanceIs_{lang}.wav\" \"%{accountBalance}\" \"{promptPath}ToPayYourBillPress_{lang}.wav\"" 
  8. 如果指令碼中不存在,請在 Snippet 中新增完成提示所需的其他變數。

    例如:

    ASSIGN env = "PROD"
    ASSIGN lang = "ENG"
    ASSIGN promptPath = "Prompts\{env}\"
    ASSIGN accountBalance = "$52.65"
    ASSIGN promptList = $"\"{promptPath}YourAccountBalanceIs_{lang}.wav\" \"%{accountBalance}\" \"{promptPath}ToPayYourBillPress_{lang}.wav\""
  9. 點擊套用
  10. 在指令碼的畫布工作區中,選擇將播放提示的動作。
  11. Sequence 屬性中,輸入在 Snippet 動作中儲存提示的動態對象的名稱。在本節使用的範例中,您將輸入 {promptList}
  12. 點擊套用

Studio中錄製語音提示

所需權限ACD > Studio > 指令碼 > 建立/編輯 ACD > Studio > 錄音提示 > 開啟

您可以透過序列編輯器在 Studio 中錄製語音提示。您必須有權存取電話才能透過這種方法錄製提示。您將提供電話號碼,然後接收將記錄您所說內容的自動通話。

您在 Studio 中錄製的音訊檔案將以 WAV 檔案格式儲存在您的CXone租戶Closed 用於管理 CXone 環境的技術支援、計費和全域設定的高級組織分組中。您可以在任何支援序列的動作中將它們用作音訊提示。您可以在 CXone 中的「瀏覽 ACD 檔案」頁面查看所有可用音訊檔案。

  1. Studio 中,打開現有指令碼或建立新指令碼。

  2. 在指令碼中新增支援序列編輯器的動作,如 PlayWhisper
  3. 點擊兩下動作圖示打開序列編輯器。

  4. 點擊 Play a Wave File 並選擇 New

  5. Sequence 欄位中選擇 NewPrompt().wav,然後在 Sequence Value 欄位中輸入預設值以重命名 WAV 檔案。當您在 Sequence Value 欄位中變更檔案的名稱時,序列清單中的名稱也會變更。

  6. 點擊工具列中的 Connect Prompt Manager 圖示 ,打開提示管理器登入視窗。

  7. 現在,輸入您有權存取之電話的的號碼。您將在該電話上接到電話,以便您錄製提示。

  8. 點擊 Connect 來接收來自錄製服務的來電。

  9. 接聽來電。序列編輯器工具列中的部分圖示變得可用,工具列顯示提示管理器就緒訊息。現在可用的圖示允許您在通話過程中控制錄音。

  10. 點擊 Record 圖示 開始錄製您的提示。

  11. 當您聽到電話的嗶聲時,請清楚地說出您的提示或訊息。

  12. 當您完成錄製後,點擊 Stop 圖示 。在您完成提示審核之前,不要掛斷電話。

  13. 要回顧您的錄音,請點擊 Play 圖示

  14. 如果語音提示可以接受,請結束通話。如果不能接受,請點擊 Record 圖示再次錄製提示。

將音訊提示指派給一個動作

所需權限ACD > Studio > 指令碼 > 建立/編輯

錄製或上載新的音訊提示後,您可以將其新增至您要播放該提示的動作。

您可以在動作的 Sequence 屬性中為錄製、上載的音訊提示輸入檔案名。您也可以使用提示管理器,如本任務所述。

  1. 在您的指令碼中,點擊兩下您想指派提示的動作。
  2. 在提示管理器中,點擊 Play a Wave File,然後選擇 Browse
  3. 選擇您要播放的提示,然後點擊 OK
  4. 點擊 Apply 以儲存您的選擇,然後關閉提示管理器。

Studio 中編輯提示

所需權限ACD > Studio > 指令碼 > 建立/編輯

Wave Editor 允許您從頭到尾修剪 WAV 檔案中不需要的音訊。

  1. 點擊兩下支援提示的動作。如果您剛剛錄製了一個提示,提示管理器可能已經打開。
  2. 點擊工具列中的 Edit Wave 圖示,以啟動 Wave Editor。
  3. 從「提示」欄中選擇要編輯的 WAV 檔案。
  4. 點擊滑鼠左鍵以醒目顯示要裁剪掉的提示的開始部分。
  5. 點擊滑鼠右鍵以醒目顯示要裁剪掉的提示的結尾部分。
  6. 您可以透過點擊綠色的 Play 圖示來播放包含要刪除的醒目顯示部分的提示,檢查您已經修剪了適當的音訊量。
  7. 點擊 Edit> Trim 以移除 WAV 檔案的醒目顯示部分。
  8. 儲存您的變更。

上載音訊提示

所需權限ACD > Studio > 檔案瀏覽器 > 編輯 ACD > Studio > 檔案瀏覽器 > 建立

如果您使用第三方音訊應用程式錄製提示,可以在 Studio 中上載。您上載的任何提示必須是受支援的音訊格式。

  • 位元速率:64 kbps
  • 音訊取樣大小:8 位元
  • 聲道數:1(單聲道)
  • 音訊取樣率:8 kHz
  • 音訊格式:CCITT μ-Law

您還可以在 CXone 中的「瀏覽 ACD 檔案」頁面檢視、上載和管理提示資訊和其他檔案。

  1. Studio 中的「檔案」標籤中,展開您要上載檔案的資料夾。如果您要上載一個提示,請展開「提示」資料夾。

  2. 將提示檔案從電腦上的檔案瀏覽器拖動到 Studio 中的「檔案」視窗。
  3. 點擊 Refresh 圖示並確認提示的 Date Modified 欄位已更新。

下載或刪除音訊提示和其他檔案

所需權限ACD > Studio > 檔案瀏覽器 > 編輯 ACD > Studio > 檔案瀏覽器 > 建立

您可以將提示資訊和其他檔案從 Studio 下載到您的電腦或將其刪除。您還可以在 CXone 中的「瀏覽 ACD 檔案」頁面執行此動作。

  1. Studio 中的「檔案」標籤中,展開檔案所在的資料夾。

  2. 若要下載檔案,將其從 Studio 檔案瀏覽器拖動到電腦上的桌面或某個資料夾。
  3. 若要刪除檔案,請選中並點擊紅色的 X 圖示 。點擊 Yes 確認您要刪除該檔案。