Trabalhar com scripts

This help page is for Desktop Studio. This information is also available for CXone Studio.

Esta página fornece informações sobre tarefas de script essenciais, como criar ou abrir scripts, adicionar e configurar ações e bloquear ou desbloquear scripts.

Criar um novo script

Permissões necessárias: Scripts do Studio Criar/Editar

Se o bloqueio estiver ativado para Studio, seu novo script não será bloqueado até que você o salve.

  1. No Studio, clique em Novo Uma janela pequena de programa de computador brilhando com um arquivo à sua frente. na barra de ferramentas.

  2. Selecione o tipo de script que deseja criar na lista à direita da janela. Caso não veja os tipos de script no lado direito da janela, verifique se General Purpose Scripts está selecionado em Available Templates.

  3. Clique em OK. Uma tela de script em branco abre no Studio.
  4. Clique em Save e forneça um nome para o seu script. Escolha o nome com cuidado. Depois de salvos, não será possível renomear os scripts.

Criar um script a partir de um modelo

Permissões necessárias: Scripts do Studio Criar/Editar

Se o bloqueio estiver ativado para Studio, seu novo script não será bloqueado até que você o salve.

  1. No Studio, clique em Novo Uma janela pequena de programa de computador brilhando com um arquivo à sua frente. na barra de ferramentas.

  2. Selecione uma categoria de modelo em Scripts especializados nos Available Templates e clique no modelo que deseja usar na lista à direita.

  3. Clique em OK.
  4. Salve o script. Escolha o nome com cuidado Depois que forem salvos, não será possível renomear os scripts.

Abra um script

Permissões necessárias: Scripts do Studio Criar/Editar

Você pode abrir um script ao:

  • Clicar em FileOpen, selecionando um script e clicando em Select.
  • Clicar em Open na barra de ferramentas, selecionar um script e clicar em Select.
  • Procurar por um script na guia Pesquisar e, em seguida, clicando duas vezes no que deseja abrir.
  • Usar a guia Navegar para localizar um script e clicar duas vezes no que deseja abrir.

Nunca edite um script de produção diretamente. As alterações salvas entram em vigor imediatamente. Se uma alteração causar um problema com um script, isso poderá afetar a capacidade de funcionamento do seu centro de contato. Se você precisar fazer alterações, use Save As para criar uma cópia do script e nomeie-o para indicar que está em desenvolvimento. Apenas put it into production quando estiver totalmente testado e pronto.

Importar um script

Permissões necessárias: Exportar/Importar scripts do Studio

Você pode importar um script de um arquivo XML.

  1. No Studio, clique em File > Import from File.
  2. Navegue até o local do script que deseja importar, selecione-o e clique em Open.
  3. Clique em Save.
  4. Na janela Salvar script como, escolha a pasta na qual salvar o script.
  5. Digite um novo File name para o script caso queira mudá-lo. Depois de salvos os scripts não podem ser renomeados.
  6. Clique em Save.

Exportar um script

Permissões necessárias: Exportar/Importar scripts do Studio

Você pode exportar um script como um arquivo XML.

  1. No Studio, clique em File > Export to File.
  2. Navegue até o local em seu computador onde deseja salvar o script exportado.
  3. Digite um File name para o script e clique em Save.

Desativar um script

Permissões necessárias: ACD > Studio > Scripts > Desativar

Os scripts não podem ser excluídos do Studio. Em vez disso, você pode desativá-los. Os scripts desativados não são mais visíveis no Studio, mas podem ser vistos na página Scripts do aplicativo ACD CXone.

Você não precisa desativar um script para impedir o CXone de usá-lo. O CXone usa somente scripts que estão atribuídos a uma competênciaFechado Usado para automatizar a entrega de interações com base nas competências, habilidades e conhecimento do agente. e um ponto de contatoFechado O ponto de entrada que um contato de entrada usa para iniciar uma interação, como um número de telefone ou endereço de email..

  1. On the Browse tab in Studio, locate the script you want to deactivate.
  2. Select the script and click the red X icon A large red X. Click to deactivate a script. at the top of the tab.
  3. Confirm that you want to deactivate the selected script.
  4. You can add notes to the script to explain why you deactivated the script:
    1. No CXone, clique no seletor de aplicativos e selecioneACDScripts.
    2. Select Inactive from the Show drop-down.
    3. Click the script and add your notes on the Notes tab.

Reativar um script

Permissões necessárias: ACD > Studio > Scripts > Desativar

Voce pode reativar um script para torná-lo visível no Studio novamente.

  1. No CXone, clique no seletor de aplicativos e selecioneACDScripts.
  2. Selecione Inativo no menu suspenso Mostrar.
  3. Clique no script que deseja reativar.
  4. Clique em Ativar na guia Detalhes da página do script.

Adicionar e configurar uma ação em um script

Permissões necessárias: Scripts do Studio Criar/Editar

Ações são os blocos de construção de todos os scripts. A maioria das ações tem um conjunto de propriedades que devem ser configuradas para definir o comportamento da ação para o script específico que você está criando. Consulte a ajuda online de cada ação para obter informações sobre as propriedades da ação. Selecione a ação na tela do script e pressione F1 no teclado. A página de ajuda é carregada em seu navegador padrão.

Esta seção descreve a adição de uma ação da guia Ferramentas. Se a guia Estrutura estiver ativada em Studio, você poderá adicionar ações a partir dela.

  1. No Studio, crie ou abra um script.
  2. Na guia Ferramentas, localize a ação que deseja adicionar. Você pode encontrar ações ao:

    • Inserir texto no campo Filter para procurar uma ação. Você pode pesquisar usando um nome completo ou parcial. Por exemplo, se você digitar ai, a pesquisa localizará todas as ações cujos nomes contenham essas letras em qualquer parte de seus nomes.
    • Clicar em Categories para alternar entre visualizar as ações por categoria ou reunidas em uma só lista.
    • Clicar em Alphabetical para alternar a visualização das ações em ordem alfabética ou em sua ordem padrão.
  3. Clique na ação que deseja adicionar. Você não precisa clicar e segurar.
  4. Clique na tela do script para posicionar a ação.
  5. Selecione a ação e clique com o botão direito do mouse para fazer a janela Properties aparecer. Você também pode clicar na guia Properties.

  6. Altere a propriedade Caption para uma palavra descritiva ou frase curta que indique o que essa ação faz no script. Por exemplo, para uma ação Play, altere a legenda para o nome do arquivo de áudio reproduzido.
  7. Configure as outras propriedades conforme necessário. Você pode configurar propriedades:

    • Selecionando uma opção: Clique no ícone de seta para baixo Uma asna apontando para baixo. que aparece no lado direito do campo e selecione uma opção na lista suspensa.
    • Usando a janela Editor de expressão: Clique no ícone de reticências Uma elipse ou conjunto de três pontos consecutivos. que aparece no lado direito do campo e digite o texto na janela Editor de expressão.
    • Inserindo texto: Clique no campo e insira o texto diretamente. Algumas propriedades exigem texto estático ou variáveis, mas muitas propriedades podem aceitar ambos.
    • Clicando duas vezes na ação: Algumas ações têm definições de configuração adicionais que você pode acessar dessa maneira.
  8. Salve suas alterações no script.

Adicionar uma ação da guia Estrutura

Permissões necessárias: Scripts do Studio Criar/Editar

A guia Estrutura contém uma lista abrangente de todas as ações disponíveis no Studio. Algumas das ações nesta aba são do sistema ou ações internas que só podem ser usadas após consultar um Representante de Contas do CXone. Use ações desconhecidas desta guia com cuidado.

A guia Estrutura só é visível caso um Representante de Contas do CXone a tenha ativado para você. Saiba mais sobre a guia Estrutura e as ações que ela contém.

  1. No Studio, crie ou abra um script.
  2. Na guia Estrutura, expanda as pastas para localizar a ação que você deseja adicionar.
  3. Clique e arraste a ação para a tela do script.

Conecte ações e crie ramais

Permissões necessárias: Scripts do Studio Criar/Editar

  1. No Studio, crie ou abra um script.
  2. Adicione pelo menos duas ações à tela.
  3. Passe o cursor sobre a primeira ação, clique e segure a seta Uma seta apontando para a direita. no canto inferior direito do ícone da ação para iniciar um conector.
  4. Conecte a primeira ação à segunda arrastando o cursor para longe da ação e soltando-o em cima da segunda ação. Se a primeira ação tem mais de uma condição de ramal disponível, a janela PickBranch aparece.

  5. Na janela PickBranch , selecione a condição de ramal que deseja usar para esta conexão. Na maioria dos casos, se a ação estiver se conectando a apenas uma outra ação, você deve usar o ramal Default. Para obter informações sobre cada uma das condições de ramal de uma ação, consulte a ajuda online da ação. Você pode selecionar uma ação e pressionar F1 no teclado para abrir a página de ajuda dela.

  6. Clique em OK.
  7. Repita as etapas 3 a 5 para conectar mais ações. Caso conecte uma ação a mais de uma outra ação, use uma condição de ramal diferente para cada conexão. Você deve sempre criar um ramal que use a condição de ramal Default. Isso dá ao script uma opção a ser seguida se nenhum dos outros ramais se aplicar.
  8. Reorganize as ações na tela se precisar liberar espaço para conexões. Conectores anexados se movem com uma ação. Caso queira mover mais de uma ação por vez, você pode:
    • Clicar na tela e arrastar o cursor para desenhar uma caixa de seleção ao redor das ações que deseja mover. As ações selecionadas ficarão destacadas em vermelho. Clique em uma das ações selecionadas para arrastar o grupo para um novo local.
    • Apertar CTRL e clicar em cada ação que deseja mover, e em seguida clicar em uma das ações selecionadas e arrastar o grupo para um novo local.
    • Clicar em uma ação e, em seguida, clicar em Edit Selection na barra de menus do Studio. Escolha uma opção com base no que você deseja que aconteça e arraste as ações destacadas para um novo local:
      • Select all above: Todas as ações acima da ação selecionada por toda a largura do script serão destacadas.
      • Select all below: Todas as ações abaixo da ação selecionada por toda a largura do script serão destacadas.
      • Select all to the right: Todas as ações à direita da ação selecionada por toda a altura do script serão destacadas.
      • Select all to the left: Todas as ações à esquerda da ação selecionada por toda a altura do script serão destacadas.
  9. Verifique se você não tem becos sem saída onde o script está travado e não tem como ser encerrado ou passar para a próxima ação. Você pode fazer isso testando o script.
  10. Salvar o script.

Criar condições de ramal variáveis

Permissões necessárias: Scripts do Studio Criar/Editar

As condições de ramal variáveis permitem que você crie condições personalizadas que devem ser atendidas para que o script siga um ramal específico. Isso é útil ao criar menus IVRFechado Menu de telefone automatizado que permite que os chamadores interajam por meio de comandos de voz, entradas de teclas ou ambos para obter informações, encaminhar uma chamada de voz de entrada ou ambos.. Você pode criar um ramal para cada opção de menu e definir a condição para que cada um seja o número que o contato deve inserir para selecionar essa opção.

  1. No Studio, crie ou abra um script.
  2. Adicione pelo menos duas ações à tela.
  3. Passe o cursor sobre a primeira ação, clique e segure a seta Uma seta apontando para a direita. no canto inferior direito do ícone da ação para iniciar um conector.
  4. Conecte a primeira ação à segunda arrastando o cursor para longe da ação e soltando-o em cima da segunda ação. A janela PickBranch é exibida.

  5. Clique no ícone + na janela PickBranch .

  6. No campo que aparece em Condição de ramal variável, insira o nome da condição que você está criando. Por exemplo, para criar uma opção de menu para quando o contato pressionar 3, digite 3 no campo.
  7. Clique em OK. Na tela, o nome do retângulo variável aparece em um retângulo na parte superior do conector. Você pode ver um exemplo disso na imagem a seguir.

Exclua um conector

Permissões necessárias: Scripts do Studio Criar/Editar

  1. No Studio, clique na seta no conector que você deseja excluir.
  2. Aperte a tecla Delete no teclado ou clique em Edit Delete.

Alterar a forma de um conector

Permissões necessárias: Scripts do Studio Criar/Editar

Você pode fazer os conectores dobrarem e curvarem para que eles se ajustem melhor ao seu script. Isso pode ajudá-lo a manter seus scripts organizados e fáceis de ler.

  1. No Studio, abra um script.
  2. Pressione e segure CTRL + Shift no teclado e passe o cursor sobre o conector cuja forma você deseja alterar até que a linha fique azul.

  3. Enquanto a linha estiver azul, clique com o botão direito do mouse no conector. Um pequeno quadrado azul é exibido. Este é um ponto de ancoragem.

  4. Clique e segure o ponto de ancoragem e arraste-o em qualquer direção até que o conector tenha a forma desejada.

  5. Você pode repetir as etapas 2 a 4 no mesmo conector para adicionar mais pontos de ancoragem se desejar adicionar mais curvas ao conector.

  6. Clique na seta no conector para ver todos os pontos de ancoragem na linha.
  7. Exclua um único ponto de ancoragem pressionando CTRLShift no teclado e clicando com o botão direito do mouse no ponto de ancoragem que deseja remover. O ponto de ancoragem desaparecerá e a curva da linha do conector será automaticamente ajustada.
  8. Se você deseja excluir todo o conector, clique na seta do conector para que ela fique vermelha. Pressione Delete.

Bloquear e desbloquear scripts

Permissões necessárias: Scripts do Studio, Visualizar/Criar/Editar

Se o bloqueio estiver ativado para scripts Studio, você poderá bloquear e desbloquear os scripts em que está trabalhando. Os scripts desbloqueados são somente leitura. Para editar um script, você deve bloqueá-lo. Isso permite que você trabalhe nele, mas impede que outros usuários salvem as alterações nele.

Se você tentar abrir um script bloqueado por outro usuário, o Studio o notificará que o script está bloqueado. Você pode substituir o bloqueio de um script se o seu perfil de usuário do CXone tiver a permissão apropriada.

Dependendo de como Studio está configurado, os scripts são abertos no modo bloqueado ou no modo somente leitura por padrão. Quando você cria um novo script, ele não está bloqueado nem desbloqueado. Quando você salva o script, ele é bloqueado automaticamente, mesmo que o comportamento padrão para Studio seja definido para abrir scripts no modo somente leitura.

  1. No Studio, abra um script. Se o bloqueio estiver ativado, o script será aberto no modo somente leitura (desbloqueado) ou no modo bloqueado, dependendo de como Studio estiver configurado. Se o bloqueio não estiver ativado, o script será aberto com um fundo de tela em branco e o ícone na guia do script não mudará para um cadeado.
  2. Para bloquear um script e editá-lo, clique no ícone de cadeado na barra de ferramentas. A tela muda de cinza para branco e o ícone na guia de script muda para um cadeado.
  3. Para desbloquear um script e colocá-lo no modo somente leitura, clique no ícone de desbloqueio na barra de ferramentas. A tela muda de branco para cinza e o ícone na guia de script muda para o ícone do tipo de script.

Substituir um script bloqueado

Permissões necessárias: Substituição de bloqueio de scripts do Studio

Quando você abre um script bloqueado por outro usuário, o Studio exibe uma notificação. Você pode substituir o bloqueio em um script se precisar editá-lo. Quando você substitui um bloqueio de script, as alterações salvas de outro usuário são mantidas. Studio exibe uma notificação para o usuário na próxima vez que ele efetuar login. A notificação pode solicitar que ele revise as alterações feitas no script. Você pode revisar as alterações visualizando uma versão anterior do script ou abrindo uma versão anterior do script e comparando-a com a versão atual.

  1. Dentro do Studio, clique na guia Locked.
  2. Selecione o script que deseja substituir e clique em Kick .
  3. Clique em OK quando solicitado a confirmar que deseja expulsar o outro usuário da edição do script.